summaryrefslogtreecommitdiff
path: root/user/firefox-esr
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 05:26:47 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 05:26:47 +0000
commita1830d20f61e0362e84a7f8e44e0c8295f371b85 (patch)
tree5f190b68238a05daf891bd19b08a8a30c942ad4d /user/firefox-esr
parent87d19aac7937fe920a4d04f4fa05282b85f417ff (diff)
downloadpackages-a1830d20f61e0362e84a7f8e44e0c8295f371b85.tar.gz
packages-a1830d20f61e0362e84a7f8e44e0c8295f371b85.tar.bz2
packages-a1830d20f61e0362e84a7f8e44e0c8295f371b85.tar.xz
packages-a1830d20f61e0362e84a7f8e44e0c8295f371b85.zip
user/firefox-esr: Remove upstreamed YUV patch
Diffstat (limited to 'user/firefox-esr')
-rw-r--r--user/firefox-esr/APKBUILD19
-rw-r--r--user/firefox-esr/yuv-be.patch48
2 files changed, 4 insertions, 63 deletions
diff --git a/user/firefox-esr/APKBUILD b/user/firefox-esr/APKBUILD
index 8eae768ac..baaad8d63 100644
--- a/user/firefox-esr/APKBUILD
+++ b/user/firefox-esr/APKBUILD
@@ -15,7 +15,7 @@ depends=""
# actual deps
makedepends="
autoconf2.13 cargo cbindgen clang llvm8-dev node ncurses-dev
- perl rust rust-stdlib cmd:which
+ perl rust rust-std cmd:which
ncurses-dev openssl-dev
@@ -45,7 +45,6 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$_ffxver/source/firefox-$_f
shut-up-warning.patch
stackwalk-x86-ppc.patch
webrtc-broken.patch
- yuv-be.patch
firefox.desktop
firefox-safe.desktop
@@ -129,16 +128,11 @@ unpack() {
}
prepare() {
- cd "$builddir"
default_prepare
cp "$srcdir"/mozconfig "$builddir"/mozconfig
echo "ac_add_options --enable-optimize=\"$CFLAGS\"" >> "$builddir"/mozconfig
echo "ac_add_options --host=\"$CHOST\"" >> "$builddir"/mozconfig
echo "ac_add_options --target=\"$CTARGET\"" >> "$builddir"/mozconfig
- # too much memory
- if [ -z "$JOBS" ] || [ $JOBS -ge 32 ]; then
- JOBS=32
- fi
echo "mk_add_options MOZ_MAKE_FLAGS=\"-j$JOBS\"" >> "$builddir"/mozconfig
case "$CARCH" in
@@ -149,6 +143,9 @@ prepare() {
echo "ac_add_options --disable-webrtc" >> "$builddir"/mozconfig;
export LDFLAGS="$LDFLAGS -latomic"
;;
+ s390x)
+ echo "ac_add_options --disable-startupcache" >> "$builddir"/mozconfig
+ ;;
esac
rm "$builddir"/third_party/python/virtualenv/virtualenv_support/pip*.whl
@@ -158,8 +155,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
@@ -172,9 +167,6 @@ build() {
export UNIXCONFDIR="$srcdir"
- local extra_flags=""
- [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
-
export PATH="$srcdir/python/bin:$PATH"
./mach build
}
@@ -186,14 +178,12 @@ run() {
}
package() {
- cd "$builddir"
export PATH="$srcdir/python/bin:$PATH"
DESTDIR="$pkgdir" ./mach install
install -m755 -d ${pkgdir}/usr/share/applications
install -m755 -d ${pkgdir}/usr/share/pixmaps
- local png
for png in browser/branding/official/default*.png; do
local i="${_png%.png}"
i=${i##*/default}
@@ -239,6 +229,5 @@ e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb1
39ddb15d1453a8412275c36fc8db3befc69dffd4a362e932d280fb7fd1190db595a2af9b468ee49e0714f5e9df6e48eb5794122a64fa9f30d689de8693acbb15 shut-up-warning.patch
452b47b825294779f98ed46bc1065dad76b79ff453521ef049934a120f349c84a1c863b16af1828fe053059823da9690ec917c055ae02dcc5c80c54cad732448 stackwalk-x86-ppc.patch
be68f1387aa6677875a67106e2d6a9db470c934c943056d3b53391a63034235108e41945c53957db427d9cdc59f0aa2f9e6f2f8cd862e090e512a3ab9cbcc9a8 webrtc-broken.patch
-2dfb986089c9afcd6a895302c8a5a1d299cffa4cc3c73fce784c29d348f362c1e7570109c4f09d328275d8549a96531736dd976411c15956b385d7fb211b8af2 yuv-be.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/user/firefox-esr/yuv-be.patch b/user/firefox-esr/yuv-be.patch
deleted file mode 100644
index ccb0c2fd8..000000000
--- a/user/firefox-esr/yuv-be.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-# HG changeset patch
-# User A. Wilcox <AWilcox@Wilcox-Tech.com>
-# Date 1543674229 0
-# Sat Dec 01 14:23:49 2018 +0000
-# Node ID 0309ff19e46b126c527e633518d7de8570442114
-# Parent 53107afbc21ec78e7ac46d37af212505f2032d5d
-Bug 1511604 - Swizzle YCbCr->RGB data on big-endian machines
-
-diff -r 53107afbc21e -r 0309ff19e46b gfx/ycbcr/YCbCrUtils.cpp
---- a/gfx/ycbcr/YCbCrUtils.cpp Wed Nov 07 04:50:21 2018 +0000
-+++ b/gfx/ycbcr/YCbCrUtils.cpp Sat Dec 01 14:23:49 2018 +0000
-@@ -3,7 +3,9 @@
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-+#include "mozilla/EndianUtils.h"
- #include "gfx2DGlue.h"
-+#include "mozilla/gfx/Swizzle.h"
-
- #include "YCbCrUtils.h"
- #include "yuv_convert.h"
-@@ -236,6 +238,13 @@
- yuvtype,
- srcData.mYUVColorSpace);
- }
-+#if MOZ_BIG_ENDIAN
-+ // libyuv makes endian-correct result, which needs to be swapped to BGRX
-+ if (aDestFormat != SurfaceFormat::R5G6B5_UINT16)
-+ gfx::SwizzleData(aDestBuffer, aStride, gfx::SurfaceFormat::X8R8G8B8,
-+ aDestBuffer, aStride, gfx::SurfaceFormat::B8G8R8X8,
-+ srcData.mPicSize);
-+#endif
- }
-
- void
-@@ -257,6 +266,12 @@
- aSrcStrideYA,
- aSrcStrideUV,
- aDstStrideARGB);
-+#if MOZ_BIG_ENDIAN
-+ // libyuv makes endian-correct result, which needs to be swapped to BGRA
-+ gfx::SwizzleData(aDstARGB, aDstStrideARGB, gfx::SurfaceFormat::A8R8G8B8,
-+ aDstARGB, aDstStrideARGB, gfx::SurfaceFormat::B8G8R8A8,
-+ IntSize(aWidth, aHeight));
-+#endif
- }
-
- } // namespace gfx