summaryrefslogtreecommitdiff
path: root/user/fluidsynth/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-05 18:03:31 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-05 18:03:31 -0500
commit1f44bdb65f68781a82360ed4322b51eee884314c (patch)
tree504bcb89f88bbdd5c50eb718f5f63a1298567c84 /user/fluidsynth/APKBUILD
parente1e2a3487f1b419a755b9fa36d134e279be1ea1b (diff)
downloadpackages-1f44bdb65f68781a82360ed4322b51eee884314c.tar.gz
packages-1f44bdb65f68781a82360ed4322b51eee884314c.tar.bz2
packages-1f44bdb65f68781a82360ed4322b51eee884314c.tar.xz
packages-1f44bdb65f68781a82360ed4322b51eee884314c.zip
user/fluidsynth: new package
Diffstat (limited to 'user/fluidsynth/APKBUILD')
-rw-r--r--user/fluidsynth/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/fluidsynth/APKBUILD b/user/fluidsynth/APKBUILD
new file mode 100644
index 000000000..c9865559a
--- /dev/null
+++ b/user/fluidsynth/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=fluidsynth
+pkgver=1.1.10
+pkgrel=0
+pkgdesc="Real-time, software synthesiser based on SoundFont 2"
+url="http://www.fluidsynth.org/"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+makedepends="alsa-lib-dev dbus-dev glib-dev libsndfile-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="fluidsynth-$pkgver.tar.gz::https://github.com/FluidSynth/fluidsynth/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7ff7757baf6dee37f65a4fd214ffab1aa1434cfd1545deb4108fe2e9b0ed19d616880b2740a693b51ade0a4be998a671910b43cae26eb67fb97b16a513752cbc fluidsynth-1.1.10.tar.gz"