summaryrefslogtreecommitdiff
path: root/user/fuse3
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-24 02:01:50 -0500
committerMax Rees <maxcrees@me.com>2020-03-24 02:52:09 -0500
commit89716e150c4103445da0047908fc16d9a5dafec3 (patch)
tree6c1e6c740074bf2122ed16fe7ca9cdb44a184279 /user/fuse3
parent757962135a85c78565cb8746ce6af8dc8d543282 (diff)
downloadpackages-89716e150c4103445da0047908fc16d9a5dafec3.tar.gz
packages-89716e150c4103445da0047908fc16d9a5dafec3.tar.bz2
packages-89716e150c4103445da0047908fc16d9a5dafec3.tar.xz
packages-89716e150c4103445da0047908fc16d9a5dafec3.zip
user/fuse3: bump to 3.9.1
Diffstat (limited to 'user/fuse3')
-rw-r--r--user/fuse3/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/user/fuse3/APKBUILD b/user/fuse3/APKBUILD
index 821be29db..14cafec71 100644
--- a/user/fuse3/APKBUILD
+++ b/user/fuse3/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=fuse3
_pkgname=fuse
-pkgver=3.9.0
+pkgver=3.9.1
pkgrel=0
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
@@ -26,18 +26,26 @@ builddir="$srcdir/$_pkgname-$pkgver"
# - CVE-2018-10906
build() {
+ # The examples are required for the tests to work, and aren't
+ # otherwise installed
+
meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--buildtype=release \
- -Dexamples=false \
+ -Dexamples=true \
. output
ninja -C output
}
check() {
+ # Recommended procedure:
+ # 1. modprobe fuse
+ # 2. chown root and chmod u+s $builddir/output/util/fusermount3
+ # 3. abuild check
+
cd "$builddir"/output
python3 -m pytest test/
}
@@ -72,6 +80,6 @@ openrc() {
install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
-sha512sums="0c96df5db4d0ceb7885ddb6f6c05b523ee7e179f8f411ad0614caecb9fa0f5fd682ab9bf4dfdaa3aff9d90c18b8947a122ee376328535e49fa6091d784aa0cb7 fuse-3.9.0.tar.xz
+sha512sums="295bb62274264789c977a1fee78c6c122a2f227ae85d750b8519cafbdcf6551499b77cf021d83cc8261831e29761c166d84a4e50bdebb4191c76bcad1d15d329 fuse-3.9.1.tar.xz
1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"