summaryrefslogtreecommitdiff
path: root/user/glib
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-09 17:11:35 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-09 17:11:35 +0000
commit1c8444c44b20e37ab788ffb05a8920985aec57a4 (patch)
tree5a787dca26890151bb11dd643f6eaed7a0009b2a /user/glib
parent22a972735d780bdf42f6d35f468cb25a79888383 (diff)
downloadpackages-1c8444c44b20e37ab788ffb05a8920985aec57a4.tar.gz
packages-1c8444c44b20e37ab788ffb05a8920985aec57a4.tar.bz2
packages-1c8444c44b20e37ab788ffb05a8920985aec57a4.tar.xz
packages-1c8444c44b20e37ab788ffb05a8920985aec57a4.zip
user/glib: bump to 2.58.0
Diffstat (limited to 'user/glib')
-rw-r--r--user/glib/APKBUILD48
-rw-r--r--user/glib/thread-test-fix.patch11
2 files changed, 16 insertions, 43 deletions
diff --git a/user/glib/APKBUILD b/user/glib/APKBUILD
index 9a90b5002..e97685a20 100644
--- a/user/glib/APKBUILD
+++ b/user/glib/APKBUILD
@@ -1,19 +1,18 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=glib
-pkgver=2.56.1
+pkgver=2.58.0
pkgrel=0
pkgdesc="Common C routines used by Gtk+ and other libs"
url="https://developer.gnome.org/glib/"
arch="all"
-options="!check"
+options="!check" # Now requires D-Bus running.
license="LGPL-2.1+"
-depends=
-triggers="$pkgname.trigger=/usr/share/glib-2.0/schemas:/usr/lib/gio/modules"
+depends=""
depends_dev="perl python3 attr-dev zlib-dev bzip2-dev libffi-dev util-linux-dev"
-makedepends="$depends_dev pcre-dev xmlto"
checkdepends="tzdata shared-mime-info"
-langdir="/usr/lib/locale"
+makedepends="$depends_dev meson ninja pcre-dev xmlto"
+triggers="$pkgname.trigger=/usr/share/glib-2.0/schemas:/usr/lib/gio/modules"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
0001-gquark-fix-initialization-with-c-constructors.patch
broken-gio-tests.patch
@@ -21,7 +20,6 @@ source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgve
i386-fpu-test.patch
musl-no-locale.patch
ridiculous-strerror-nonconformance.patch
- thread-test-fix.patch
"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang $pkgname-bash-completion:bashcomp:noarch"
@@ -29,37 +27,24 @@ prepare() {
cd "$builddir"
default_prepare
- # workaround packaging issue. gtk-doc.make timestamp was newer than
- # Makefile.am, which triggers automake re-run
- touch -r docs/reference/glib/Makefile.am gtk-doc.make
+ mkdir -p dumb_meson
}
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --disable-gtk-doc \
- --disable-compile-warnings \
- --disable-selinux \
- --with-pcre=system \
- --with-python=python3 \
- --with-pic \
- --enable-static
- make
+ cd "$builddir"/dumb_meson
+ meson --default-library=both -Dprefix=/usr -Dselinux=false -Dman=true ..
+ ninja
}
check() {
- cd "$builddir"
+ cd "$builddir"/dumb_meson
# workaround if a user builds it on a computer running X11
- DISPLAY= make check
+ DISPLAY= ninja test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/dumb_meson
+ DESTDIR="$pkgdir" ninja install
rm -rf "$pkgdir"/usr/lib/charset.alias
}
@@ -78,7 +63,7 @@ dev() {
}
static() {
- pkgdesc="glib static libraries"
+ pkgdesc="$pkgdesc (static libraries)"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
}
@@ -92,11 +77,10 @@ bashcomp() {
[ "$(ls -A "$pkgdir"/usr/share)" ] || rmdir "$pkgdir"/usr/share
}
-sha512sums="7e96cc23f3fa42a41b1974ae8fa2a7b123449643f265763d464620afcb011668e2de013ed2a6e5f13b6bd1bf3ab8eab43c05bf4a8ee0d99b7808767ab4fa69f4 glib-2.56.1.tar.xz
+sha512sums="eedf65ec8e2fb5b9c6c7f96c69fe162db1b00a2b407a64219ba6c070a608804f361a69738a9fc93ff514896deea763e06ae0fcf12b3d1d1ef67d6f2c1a492413 glib-2.58.0.tar.xz
32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch
5bb7ee99cd19bc10f49b64c5bb9d79a0ee5bd918852f6351261bd5b3f3d8486c593bac6285da7e227579af9bac2b27c47251e4a62fd3af6cabe21f6b111e5e7a broken-gio-tests.patch
0f0a98784aeed92f33cd9239d2f668bdc6c09b84ed020825ae88f6aacf6a922152dc3e1384c40d9f30f54c5ab78fe17e0ee5c42b268b297b595d2a6cde5b8998 fix-spawn.patch
aa7444bbdf7b88798adc67c15cdb8b7459450c0b7357caea16b74462c5c9179ba80d4018b1e656e90a5e3be5b2e3c14e9b8c0ccbb2ee4d8c92dc8fa627518b84 i386-fpu-test.patch
34129be883011d266074783b7283af5c6a45055b85026b5aab47a3a0dfa1316a0a6502aaf78ab172356f67493ea7c4867b53279c25967a8cc5bee9320dbff96a musl-no-locale.patch
-56c10a0f64cbd8ce584d428f818e7e678fdeb40a32df792843208ddfa3135d362cc2077bc9fe3bfebe13ee6af0ecf6403a593ad727e0a92276074a17a9c7029c ridiculous-strerror-nonconformance.patch
-0cebf9cbf87a92c3160054eb30189a827847f5820a8b90f4842b4ad5ab5cc343ba06e5f55214864bd0f0d5a21e55ec5e7f35c66207e77b1496142b7ee0c75567 thread-test-fix.patch"
+56c10a0f64cbd8ce584d428f818e7e678fdeb40a32df792843208ddfa3135d362cc2077bc9fe3bfebe13ee6af0ecf6403a593ad727e0a92276074a17a9c7029c ridiculous-strerror-nonconformance.patch"
diff --git a/user/glib/thread-test-fix.patch b/user/glib/thread-test-fix.patch
deleted file mode 100644
index bcfcfc441..000000000
--- a/user/glib/thread-test-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- glib-2.52.1/glib/tests/thread.c.old 2016-10-22 05:21:37.000000000 +0000
-+++ glib-2.52.1/glib/tests/thread.c 2017-08-20 04:51:46.756496035 +0000
-@@ -174,7 +174,7 @@
- static gpointer
- thread6_func (gpointer data)
- {
--#ifdef HAVE_PTHREAD_SETNAME_NP_WITH_TID
-+#if 0
- char name[16];
-
- pthread_getname_np (pthread_self(), name, 16);