summaryrefslogtreecommitdiff
path: root/user/glslang/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-22 15:39:08 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-29 04:55:33 -0600
commitfee7397fd3f6ca6cdd9936bc54ac394d5393a921 (patch)
treed3f353dd3ea68fed5f4a5826b746f2d4d20ed137 /user/glslang/APKBUILD
parent72699bd7edad7dd007ebfa74a19881537f0e9cc0 (diff)
downloadpackages-fee7397fd3f6ca6cdd9936bc54ac394d5393a921.tar.gz
packages-fee7397fd3f6ca6cdd9936bc54ac394d5393a921.tar.bz2
packages-fee7397fd3f6ca6cdd9936bc54ac394d5393a921.tar.xz
packages-fee7397fd3f6ca6cdd9936bc54ac394d5393a921.zip
user/glslang: spirv-remap: Cross-endian support
Reported upstream at https://github.com/KhronosGroup/glslang/issues/3799; I'm not happy with the patch, and I feel like it can be better, but it works and it unblocks Vulkan for beta6.
Diffstat (limited to 'user/glslang/APKBUILD')
-rw-r--r--user/glslang/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/user/glslang/APKBUILD b/user/glslang/APKBUILD
index f4e911e9e..afe29113f 100644
--- a/user/glslang/APKBUILD
+++ b/user/glslang/APKBUILD
@@ -10,7 +10,9 @@ license="BSD-3-Clause AND MIT AND BSD-2-Clause AND GPL-3.0+ WITH Bison-2.2-excep
depends="spirv-tools"
makedepends="cmake python3 spirv-tools-dev"
subpackages="$pkgname-dev"
-source="glslang-$pkgver.tar.gz::https://github.com/KhronosGroup/glslang/archive/$pkgver.tar.gz"
+source="glslang-$pkgver.tar.gz::https://github.com/KhronosGroup/glslang/archive/$pkgver.tar.gz
+ remap-endian.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -37,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ce6d09cc4d98b01d162ec5a196eec017c4a5f25eaf98c6612695d911f8d136c2f7193ff8f2c07931b2e94182d2c654833adc3b645f0c225e1d07c4e6e7abfd76 glslang-14.3.0.tar.gz"
+sha512sums="ce6d09cc4d98b01d162ec5a196eec017c4a5f25eaf98c6612695d911f8d136c2f7193ff8f2c07931b2e94182d2c654833adc3b645f0c225e1d07c4e6e7abfd76 glslang-14.3.0.tar.gz
+4745982dac709fc106f50e4f51800cefef07f11f609dfdaa234c3d61fab5f7bd2350720a294a686e88eb92916d1ccdfa203993419d697eb780ee741395bde8c2 remap-endian.patch"