summaryrefslogtreecommitdiff
path: root/user/gobject-introspection
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-06-10 13:47:32 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commiteedf4f0cf4f1335c315f81c90e284d698b8d07be (patch)
treedb6419bcf0f1a0ef13a36ffa84ee9667cd8076af /user/gobject-introspection
parentb86743e2b6013cb965564d3d4a4b87f0e01b952e (diff)
downloadpackages-eedf4f0cf4f1335c315f81c90e284d698b8d07be.tar.gz
packages-eedf4f0cf4f1335c315f81c90e284d698b8d07be.tar.bz2
packages-eedf4f0cf4f1335c315f81c90e284d698b8d07be.tar.xz
packages-eedf4f0cf4f1335c315f81c90e284d698b8d07be.zip
user/gobject-introspection: add patch for bad file move assumption. fixes #776.
Diffstat (limited to 'user/gobject-introspection')
-rw-r--r--user/gobject-introspection/APKBUILD4
-rw-r--r--user/gobject-introspection/support-cross-filesystem-move.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/user/gobject-introspection/APKBUILD b/user/gobject-introspection/APKBUILD
index be3b42f54..0c1a6f5f2 100644
--- a/user/gobject-introspection/APKBUILD
+++ b/user/gobject-introspection/APKBUILD
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc $pkgname-dev"
replaces="libgirepository"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
musl-time64.patch
+ support-cross-filesystem-move.patch
"
build() {
@@ -40,4 +41,5 @@ dev() {
}
sha512sums="b8fba2bd12e93776c55228acf3487bef36ee40b1abdc7f681b827780ac94a8bfa1f59b0c30d60fa5a1fea2f610de78b9e52029f411128067808f17eb6374cdc5 gobject-introspection-1.72.0.tar.xz
-784acecd0e139685664ba1af6f1df69aeeb2da11a2b7ef9b42f46f42699e087aa90f0a2d95c1ff7aa1c04a3f2505d6006015b5a0f1ba1b125d6b1311474736c2 musl-time64.patch"
+784acecd0e139685664ba1af6f1df69aeeb2da11a2b7ef9b42f46f42699e087aa90f0a2d95c1ff7aa1c04a3f2505d6006015b5a0f1ba1b125d6b1311474736c2 musl-time64.patch
+ce07017598d55a7a0b2a0cad18664a004d4f0425b57c29fd7d6c1d0d340e82db83c2a876cd60f3fb0fbc9e79d83badea4fc7c547f854d44b51bb980df8afa95a support-cross-filesystem-move.patch"
diff --git a/user/gobject-introspection/support-cross-filesystem-move.patch b/user/gobject-introspection/support-cross-filesystem-move.patch
new file mode 100644
index 000000000..80fc80baa
--- /dev/null
+++ b/user/gobject-introspection/support-cross-filesystem-move.patch
@@ -0,0 +1,11 @@
+--- a/misc/update-glib-annotations.py
++++ b/misc/update-glib-annotations.py
+@@ -57,7 +57,7 @@
+ extract_annotations(module_name, glib_src_dir, target)
+ if os.path.isfile(target_path):
+ os.unlink(target_path)
+- os.rename(tmpname, target_path)
++ shutil.move(tmpname, target_path)
+
+ print("Updated '%s'" % (target_path, ))
+