summaryrefslogtreecommitdiff
path: root/user/gpgme
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-11-28 10:09:27 -0600
committerZach van Rijn <me@zv.io>2022-11-28 10:09:27 -0600
commit2828047b155d68a1525bb8c6a6ad840bbb5839d4 (patch)
tree166b108dd59c53ed638408d0ccf8b4e14edc2706 /user/gpgme
parent11e29336513f9b459d6837a5461f4fc0089a4536 (diff)
downloadpackages-2828047b155d68a1525bb8c6a6ad840bbb5839d4.tar.gz
packages-2828047b155d68a1525bb8c6a6ad840bbb5839d4.tar.bz2
packages-2828047b155d68a1525bb8c6a6ad840bbb5839d4.tar.xz
packages-2828047b155d68a1525bb8c6a6ad840bbb5839d4.zip
user/gpgme: update patch to support python 3.11. fixes #899.
Diffstat (limited to 'user/gpgme')
-rw-r--r--user/gpgme/0003-python311.patch (renamed from user/gpgme/0003-python310.patch)16
-rw-r--r--user/gpgme/APKBUILD6
2 files changed, 11 insertions, 11 deletions
diff --git a/user/gpgme/0003-python310.patch b/user/gpgme/0003-python311.patch
index e607cc457..293eb557e 100644
--- a/user/gpgme/0003-python310.patch
+++ b/user/gpgme/0003-python311.patch
@@ -1,5 +1,5 @@
Taken from the Arch Repo
-GPGME fails to detect python 3.10 currently, this patch fixes that
+GPGME fails to detect python 3.11 currently, this patch fixes that
Patch has not been upstreamed as of right now
diff -upr gpgme-1.16.0.orig/configure gpgme-1.16.0/configure
--- gpgme-1.16.0.orig/configure 2021-06-24 20:10:50.000000000 +0300
@@ -226,14 +226,14 @@ diff -upr gpgme-1.16.0.orig/configure gpgme-1.16.0/configure
# If the user set $PYTHON, use it and don't search something else.
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version is >= 3.9" >&5
-$as_echo_n "checking whether $PYTHON version is >= 3.9... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version is >= 3.10" >&5
-+$as_echo_n "checking whether $PYTHON version is >= 3.10... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version is >= 3.11" >&5
++$as_echo_n "checking whether $PYTHON version is >= 3.11... " >&6; }
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
# because we need at least 4 digits for the hex conversion.
# map returns an iterator in Python 3.0 and a list in 2.x
-minver = list(map(int, '3.9'.split('.'))) + [0, 0, 0]
-+minver = list(map(int, '3.10'.split('.'))) + [0, 0, 0]
++minver = list(map(int, '3.11'.split('.'))) + [0, 0, 0]
minverhex = 0
# xrange is not present in Python 3.0 and range returns an iterator
for i in list(range(0, 4)): minverhex = (minverhex << 8) + minver[i]
@@ -243,21 +243,21 @@ diff -upr gpgme-1.16.0.orig/configure gpgme-1.16.0/configure
# VERSION.
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 3.9" >&5
-$as_echo_n "checking for a Python interpreter with version >= 3.9... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 3.10" >&5
-+$as_echo_n "checking for a Python interpreter with version >= 3.10... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 3.11" >&5
++$as_echo_n "checking for a Python interpreter with version >= 3.11... " >&6; }
if ${am_cv_pathless_PYTHON+:} false; then :
$as_echo_n "(cached) " >&6
else
- for am_cv_pathless_PYTHON in python3.9 none; do
-+ for am_cv_pathless_PYTHON in python3.10 none; do
++ for am_cv_pathless_PYTHON in python3.11 none; do
test "$am_cv_pathless_PYTHON" = none && break
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
# because we need at least 4 digits for the hex conversion.
# map returns an iterator in Python 3.0 and a list in 2.x
-minver = list(map(int, '3.9'.split('.'))) + [0, 0, 0]
-+minver = list(map(int, '3.10'.split('.'))) + [0, 0, 0]
++minver = list(map(int, '3.11'.split('.'))) + [0, 0, 0]
minverhex = 0
# xrange is not present in Python 3.0 and range returns an iterator
for i in list(range(0, 4)): minverhex = (minverhex << 8) + minver[i]
diff --git a/user/gpgme/APKBUILD b/user/gpgme/APKBUILD
index 5bbe1cb0e..c2e7d5b06 100644
--- a/user/gpgme/APKBUILD
+++ b/user/gpgme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gpgme
pkgver=1.16.0
-pkgrel=1
+pkgrel=2
pkgdesc="GnuPG Made Easy"
url="https://www.gnupg.org/related_software/gpgme/"
arch="all"
@@ -16,7 +16,7 @@ subpackages="$pkgname-dev $pkgname-doc gpgmepp qgpgme py3-gpg:_py"
source="https://gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
0001-core-Fix-use-after-free-issue-in-test.patch
0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
- 0003-python310.patch
+ 0003-python311.patch
"
build() {
@@ -63,4 +63,4 @@ _py() {
sha512sums="69487be69612e9bf0221ff56ae687248bd13635db1b7087130e93c1670e38f3c810bbca17723555c04fe207976c35871bbc3da005179ce099504321cf33636e4 gpgme-1.16.0.tar.bz2
8e455ffa6590ab976ec52e47a8adf28ddc7fe5cfe6a191375bf19ff0ca3b9dd1a5788f2d33ecd4214eaf59cf7668b64f87add305da169775ad59ebd048e93303 0001-core-Fix-use-after-free-issue-in-test.patch
774e2c28168353c5933293d4ed17ed7c5c88426290ed3500cbf2d3131dd406d2e6944bdc1b3db90c8310c71cd6db67aaae0f3459eadf47484c9cbfaaf1e712de 0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
-d62367b69f31b507f0bbdfd6778a1491892f0ec26f8345a2186af78b8123e6d4e9687a90b0425a8cd5fb074e62d24f849d121c58b004ae68bed4e8260f7d5c6b 0003-python310.patch"
+bddb4d520241e9a2cc7395344fefccbe3f224e7e1b3e24900e71619c4ec22f80a63c25e3c64824229d64cace948c0d2af97576827c744aa0405c8c94d7ecd64f 0003-python311.patch"