summaryrefslogtreecommitdiff
path: root/user/graphene
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-02 02:39:31 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commitf9117878f924da07105e48f152b4bf6135b29c7b (patch)
treeb2e6eaddcc1909c3830dbac7aba73382d0d1a318 /user/graphene
parent44d711c72a91ecc565251e11a2e0de8d87d4d839 (diff)
downloadpackages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.gz
packages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.bz2
packages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.xz
packages-f9117878f924da07105e48f152b4bf6135b29c7b.zip
user/graphene: New package
Diffstat (limited to 'user/graphene')
-rw-r--r--user/graphene/APKBUILD34
-rw-r--r--user/graphene/installed-tests.patch28
2 files changed, 62 insertions, 0 deletions
diff --git a/user/graphene/APKBUILD b/user/graphene/APKBUILD
new file mode 100644
index 000000000..9fcbb6154
--- /dev/null
+++ b/user/graphene/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=graphene
+pkgver=1.10.8
+pkgrel=0
+pkgdesc="Thin layer of graphic data types"
+url="https://ebassi.github.io/graphene/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="glib-dev gobject-introspection-dev meson"
+subpackages="$pkgname-dev"
+source="graphene-$pkgver.tar.gz::https://github.com/ebassi/graphene/archive/refs/tags/$pkgver.tar.gz
+ installed-tests.patch
+ "
+
+build() {
+ meson \
+ -Dprefix=/usr \
+ -Dintrospection=enabled \
+ -Dinstalled_tests=false \
+ _build
+ ninja -C _build
+}
+
+check() {
+ ninja -C _build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C _build install
+}
+
+sha512sums="526b0c17049459b687ceb7f6c26c9d982535e4048e74a0b6282704f9811d3c2e7e0e6cfef166aa953306b6cf77add6677bc600ae0c66cc052dc04c3d0345bd68 graphene-1.10.8.tar.gz
+862c77a54878706adcc5ec438a8aa24b43fdb1e8548942913bfd432411ea69d6541b9a04e99716162fc23354ec7664015ef3157869769a904ad0b281332bdb5d installed-tests.patch"
diff --git a/user/graphene/installed-tests.patch b/user/graphene/installed-tests.patch
new file mode 100644
index 000000000..5a097d996
--- /dev/null
+++ b/user/graphene/installed-tests.patch
@@ -0,0 +1,28 @@
+Upstream-URL: https://github.com/ebassi/graphene/issues/247
+
+From 85289fa63b1a5e4e5a03a79b947d1db5b9ec4778 Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Thu, 7 Apr 2022 19:01:49 +0000
+Subject: [PATCH] meson: don't install introspection file with
+ installed_tests=false
+
+fixes #247
+---
+ tests/meson.build | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 0a6a355..0120c29 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -67,7 +67,9 @@ src_build_path = meson.current_build_dir() / '../src'
+
+ if build_gir and host_system == 'linux' and not meson.is_cross_build()
+ foreach unit: ['introspection.py']
+- install_data(unit, install_dir: installed_test_bindir)
++ if get_option('installed_tests')
++ install_data(unit, install_dir: installed_test_bindir)
++ endif
+
+ wrapper = '@0@.test'.format(unit)
+ custom_target(wrapper,