summaryrefslogtreecommitdiff
path: root/user/graphite2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 03:17:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 03:17:58 -0500
commit6d76d1686c387ab06f9118079fba66901afcd616 (patch)
tree1823a940587968a7295e33c73a63916962f8073d /user/graphite2
parent9dcb14ac47244425af9f31e88fd393f086c499da (diff)
downloadpackages-6d76d1686c387ab06f9118079fba66901afcd616.tar.gz
packages-6d76d1686c387ab06f9118079fba66901afcd616.tar.bz2
packages-6d76d1686c387ab06f9118079fba66901afcd616.tar.xz
packages-6d76d1686c387ab06f9118079fba66901afcd616.zip
user/graphite2: pull in, fix slightly
Diffstat (limited to 'user/graphite2')
-rw-r--r--user/graphite2/APKBUILD46
-rw-r--r--user/graphite2/cmake.patch13
-rw-r--r--user/graphite2/graphite2-1.2.0-cmakepath.patch9
3 files changed, 68 insertions, 0 deletions
diff --git a/user/graphite2/APKBUILD b/user/graphite2/APKBUILD
new file mode 100644
index 000000000..74b3541e6
--- /dev/null
+++ b/user/graphite2/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=graphite2
+_realname=${pkgname/2/}
+pkgver=1.3.10
+pkgrel=1
+pkgdesc="Text processing engine for complex languages"
+url="http://graphite.sil.org/"
+arch="all"
+options="!check" # Test suite requires Graphite 1 and py2-fonttools
+license="LGPL-2.1+ OR MPL-2.0+ OR GPL-2.0+"
+depends=""
+depends_dev="freetype-dev"
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
+ cmake.patch
+ graphite2-1.2.0-cmakepath.patch
+ "
+builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$builddir"
+ mkdir build && cd build
+ cmake -G "Unix Makefiles" .. \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
+ -DGRAPHITE2_COMPARE_RENDERER=OFF \
+ -DGRAPHITE2_NFILEFACE=ON \
+ -DGRAPHITE2_NSEGCACHE=ON
+
+ # fix unwanted -O3 cflag (taken from Debian)
+ find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="9a6ff2ad88f04e55a6da862e6eefcf2d87c562bb9feedddc4532b66f7938b9ade4a12c8a4b19ab7b08ec3e34a96b97331621a7465b672407ab4d1af756df04c1 graphite2-1.3.10.tar.gz
+44dcff1e6c8c5e3df92eae8cab501c9605a1cd3e16b6cdce2e376d78fd08b26b7f6e037b7e5878099ba426a93572114169b5f64c4d2ae0bcbe223f1d28b00eb5 cmake.patch
+4ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch"
diff --git a/user/graphite2/cmake.patch b/user/graphite2/cmake.patch
new file mode 100644
index 000000000..41f1e5187
--- /dev/null
+++ b/user/graphite2/cmake.patch
@@ -0,0 +1,13 @@
+--- ./tests/CMakeLists.txt.orig
++++ ./tests/CMakeLists.txt
+@@ -58,7 +58,9 @@
+ LINKER_LANGUAGE C)
+ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+
+-add_subdirectory(comparerenderer)
++if (GRAPHITE2_COMPARE_RENDERER)
++ add_subdirectory(comparerenderer)
++endif (GRAPHITE2_COMPARE_RENDERER)
+ add_subdirectory(endian)
+ add_subdirectory(bittwiddling)
+ if (NOT GRAPHITE2_NFILEFACE)
diff --git a/user/graphite2/graphite2-1.2.0-cmakepath.patch b/user/graphite2/graphite2-1.2.0-cmakepath.patch
new file mode 100644
index 000000000..daed0770f
--- /dev/null
+++ b/user/graphite2/graphite2-1.2.0-cmakepath.patch
@@ -0,0 +1,9 @@
+diff -urN graphite2-1.2.0.orig/src/CMakeLists.txt graphite2-1.2.0/src/CMakeLists.txt
+--- graphite2-1.2.0.orig/src/CMakeLists.txt 2013-01-29 15:47:32.465841769 +0530
++++ graphite2-1.2.0/src/CMakeLists.txt 2013-01-29 15:48:24.056843352 +0530
+@@ -136,4 +136,4 @@
+
+
+ install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+-install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
++install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/cmake/graphite2 NAMESPACE gr2_)