summaryrefslogtreecommitdiff
path: root/user/gst-plugins-good
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-02 02:55:26 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit289427675ea063b92d60ffc93f521121b424769b (patch)
treec1fd175120ec2006421bbbc2c69b593b032d9f79 /user/gst-plugins-good
parentfdc1d0bac231062f0734d5bc15b3d8a8263c8c40 (diff)
downloadpackages-289427675ea063b92d60ffc93f521121b424769b.tar.gz
packages-289427675ea063b92d60ffc93f521121b424769b.tar.bz2
packages-289427675ea063b92d60ffc93f521121b424769b.tar.xz
packages-289427675ea063b92d60ffc93f521121b424769b.zip
user/gst-plugins-good: Update to 1.20.1
Diffstat (limited to 'user/gst-plugins-good')
-rw-r--r--user/gst-plugins-good/APKBUILD36
-rw-r--r--user/gst-plugins-good/endian-test.patch20
2 files changed, 15 insertions, 41 deletions
diff --git a/user/gst-plugins-good/APKBUILD b/user/gst-plugins-good/APKBUILD
index 0bda3806f..943c07a49 100644
--- a/user/gst-plugins-good/APKBUILD
+++ b/user/gst-plugins-good/APKBUILD
@@ -1,45 +1,40 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gst-plugins-good
-pkgver=1.16.2
+pkgver=1.20.1
pkgrel=0
pkgdesc="GStreamer multimedia framework - Free, well-written plugins"
url="https://gstreamer.freedesktop.org/modules/gst-plugins-good.html"
arch="all"
-options="!check" # elements/souphttpsrc fails due to attempt to listen on :443
license="LGPL-2.1+"
depends=""
-checkdepends="orc-compiler cmd:which"
makedepends="gst-plugins-base-dev gstreamer-dev gobject-introspection-dev
orc-dev libgudev-dev v4l-utils-dev libx11-dev cairo-dev flac-dev
gdk-pixbuf-dev gtk+3.0-dev libjpeg-turbo-dev lame-dev libdv-dev
libpng-dev mpg123-dev pulseaudio-dev libraw1394-dev libiec61883-dev
libavc1394-dev libsoup-dev speex-dev taglib-dev wavpack-dev zlib-dev
- bzip2-dev"
-subpackages="$pkgname-doc $pkgname-gtk $pkgname-lang"
+ bzip2-dev libxdamage-dev libxext-dev libxfixes-dev meson orc-compiler
+ wayland-protocols"
+subpackages="$pkgname-gtk $pkgname-lang"
ldpath="/usr/lib/gstreamer-1.0"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
- endian-test.patch
- "
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --with-package-origin="${DISTRO_NAME:-Adélie Linux} (${DISTRO_URL:-https://www.adelielinux.org/})"
- make
+ meson \
+ -Dprefix=/usr \
+ -Dnls=enabled \
+ -Dpackage-name="GStreamer Good Plugins (${DISTRO_NAME:-Adélie Linux})" \
+ -Dpackage-origin="${DISTRO_URL:-https://www.adelielinux.org/}" \
+ _build
+ ninja -C _build
}
check() {
- make check
+ ninja -C _build test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C _build install
}
gtk() {
@@ -52,5 +47,4 @@ gtk() {
"$subpkgdir"/usr/lib/gstreamer-1.0/
}
-sha512sums="ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4 gst-plugins-good-1.16.2.tar.xz
-1cecf260cfeb19675a819f9858426aaed3b9627ed90b8facb6cb12dfc0b265232639b1888d7cc03edb87025e3eddab6e3606f16b5f7ca261a6b1c39b0dbdc6f7 endian-test.patch"
+sha512sums="6e56f6290465da03bfe162228829e51091896b2c5fe9d1d0718f663a3ab14edf5c790b37998a783981b9c77034252e7dee9fec5136f92ced44c4898e2fbd402e gst-plugins-good-1.20.1.tar.xz"
diff --git a/user/gst-plugins-good/endian-test.patch b/user/gst-plugins-good/endian-test.patch
deleted file mode 100644
index 52065bf34..000000000
--- a/user/gst-plugins-good/endian-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- gst-plugins-good-1.14.4/tests/check/elements/alpha.c.old 2018-03-23 20:44:48.000000000 +0000
-+++ gst-plugins-good-1.14.4/tests/check/elements/alpha.c 2019-01-10 15:47:17.410000000 +0000
-@@ -99,9 +99,17 @@
- int i;
-
- if (color == FILL_GREEN)
-+#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
-+ rgba_col = 0x00ff00ff;
-+#else
- rgba_col = 0xff00ff00; /* GREEN */
-+#endif
- else
-+#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
-+ rgba_col = 0x0000ffff;
-+#else
- rgba_col = 0xffff0000; /* BLUE */
-+#endif
-
- for (i = 0; i < HEIGHT * WIDTH; i++)
- rgba32[i] = rgba_col;