summaryrefslogtreecommitdiff
path: root/user/gst-plugins-good
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-17 23:57:59 +0000
committerZach van Rijn <me@zv.io>2022-12-19 15:02:16 +0000
commitd311d08ff4a901117da5884cfc900f60fc7667cf (patch)
tree113cc462556d6ca4fc2f7d4c3982cfce115c0595 /user/gst-plugins-good
parentba0da9dc793d36929ed1d8f0f9a267e6a0fd4281 (diff)
downloadpackages-d311d08ff4a901117da5884cfc900f60fc7667cf.tar.gz
packages-d311d08ff4a901117da5884cfc900f60fc7667cf.tar.bz2
packages-d311d08ff4a901117da5884cfc900f60fc7667cf.tar.xz
packages-d311d08ff4a901117da5884cfc900f60fc7667cf.zip
user/gst-plugins-good: Fix passed property type
This fixes the drop-messages-interval test in rtpjitterbuffer. Issue: #924
Diffstat (limited to 'user/gst-plugins-good')
-rw-r--r--user/gst-plugins-good/APKBUILD8
-rw-r--r--user/gst-plugins-good/drop-messages-interval-type.patch29
2 files changed, 35 insertions, 2 deletions
diff --git a/user/gst-plugins-good/APKBUILD b/user/gst-plugins-good/APKBUILD
index 95caea350..22f5a44ae 100644
--- a/user/gst-plugins-good/APKBUILD
+++ b/user/gst-plugins-good/APKBUILD
@@ -17,12 +17,15 @@ makedepends="gst-plugins-base-dev gstreamer-dev gobject-introspection-dev
wayland-protocols"
subpackages="$pkgname-gtk $pkgname-lang"
ldpath="/usr/lib/gstreamer-1.0"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
+ drop-messages-interval-type.patch
+ "
build() {
meson \
-Dprefix=/usr \
-Dnls=enabled \
+ -Dorc=disabled \
-Dpackage-name="GStreamer Good Plugins (${DISTRO_NAME:-Adélie Linux})" \
-Dpackage-origin="${DISTRO_URL:-https://www.adelielinux.org/}" \
_build
@@ -47,4 +50,5 @@ gtk() {
"$subpkgdir"/usr/lib/gstreamer-1.0/
}
-sha512sums="a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933 gst-plugins-good-1.20.2.tar.xz"
+sha512sums="a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933 gst-plugins-good-1.20.2.tar.xz
+0f08a08d6f0e8303a9c899c5260f6ca2c0e0a41e1ca2a9c795c1cb1267a9003354cd0e5538022049a09784ba9000a4a60b7a0b07b38a18483ec30d9a86356e46 drop-messages-interval-type.patch"
diff --git a/user/gst-plugins-good/drop-messages-interval-type.patch b/user/gst-plugins-good/drop-messages-interval-type.patch
new file mode 100644
index 000000000..ebf0c1e5a
--- /dev/null
+++ b/user/gst-plugins-good/drop-messages-interval-type.patch
@@ -0,0 +1,29 @@
+Upstream-URL: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3580
+
+From e91ab24c5777986926bea5e9f0c832f606c9fb52 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 16 Dec 2022 01:00:46 -0600
+Subject: [PATCH] tests: Cast drop-messages-interval type properly
+
+The rtpjitterbuffer test drop_messages_interval uses a GstClockTime for
+the message drop interval. This property is defined as a guint. On
+systems with 64-bit time_t but 32-bit uint, this can cause the
+g_object_set function to fail to read the arguments properly.
+
+Fixes: #1656
+---
+ .../gst-plugins-good/tests/check/elements/rtpjitterbuffer.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+
+--- gst-plugins-good-1.20.2/tests/check/elements/rtpjitterbuffer.c.old 2022-05-02 22:29:29.000000000 +0000
++++ gst-plugins-good-1.20.2/tests/check/elements/rtpjitterbuffer.c 2022-12-16 07:04:53.663472650 +0000
+@@ -3097,7 +3097,7 @@
+ guint num_sent_msg = 0;
+
+ g_object_set (h->element, "post-drop-messages", TRUE, NULL);
+- g_object_set (h->element, "drop-messages-interval", interval, NULL);
++ g_object_set (h->element, "drop-messages-interval", (guint)interval, NULL);
+ next_seqnum = construct_deterministic_initial_state (h, latency_ms);
+
+ /* Create a bus to get the drop message on */