summaryrefslogtreecommitdiff
path: root/user/gtkspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 16:28:32 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 16:28:36 +0000
commitb99ad359aa3b14e2f6c5fdb2b9146f9b61ee534d (patch)
tree415cfad910e66adbfdd3c928cdea499a4ae54581 /user/gtkspell
parent24f45322f80ae07dd20a15be39b7758bbdcd09e3 (diff)
downloadpackages-b99ad359aa3b14e2f6c5fdb2b9146f9b61ee534d.tar.gz
packages-b99ad359aa3b14e2f6c5fdb2b9146f9b61ee534d.tar.bz2
packages-b99ad359aa3b14e2f6c5fdb2b9146f9b61ee534d.tar.xz
packages-b99ad359aa3b14e2f6c5fdb2b9146f9b61ee534d.zip
user/gtkspell: port to Enchant 2
Based on https://github.com/manisandro/gtkspell/commit/c29e0bd6bf432b7c990ab8ddcf79fd708d5c9fc3
Diffstat (limited to 'user/gtkspell')
-rw-r--r--user/gtkspell/APKBUILD15
-rw-r--r--user/gtkspell/enchant-2.patch89
2 files changed, 96 insertions, 8 deletions
diff --git a/user/gtkspell/APKBUILD b/user/gtkspell/APKBUILD
index 6ed3ffdcc..cd7b8f100 100644
--- a/user/gtkspell/APKBUILD
+++ b/user/gtkspell/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=gtkspell
pkgver=2.0.16
-pkgrel=9
+pkgrel=10
pkgdesc="Highlighting and replacement of misspelled words in Gtk software"
url="http://gtkspell.sourceforge.net/"
arch="all"
@@ -9,16 +9,16 @@ license="GPL-2.0-only"
makedepends="gtk+2.0-dev enchant-dev intltool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
langdir="/usr/lib/locale"
-source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz
+ enchant-2.patch
+ "
prepare() {
- cd "$builddir"
- update_config_sub
default_prepare
+ update_config_sub
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,13 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz"
+sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz
+0071d81b7dabcf1bb4be76c13c453724606a3d030ea13a7bb87fe4e96b1dc40118110e470f5f4044c55e49c49ff0d6761ef3db7091228ef52225ac35fba42f6d enchant-2.patch"
diff --git a/user/gtkspell/enchant-2.patch b/user/gtkspell/enchant-2.patch
new file mode 100644
index 000000000..e6dd3298b
--- /dev/null
+++ b/user/gtkspell/enchant-2.patch
@@ -0,0 +1,89 @@
+--- gtkspell-2.0.16/configure.ac.old 2009-10-23 02:52:31.000000000 +0000
++++ gtkspell-2.0.16/configure.ac 2019-03-18 16:16:30.890000000 +0000
+@@ -12,12 +12,12 @@
+ AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+ AC_CONFIG_HEADERS([config.h])
+
+-SPELLER_LIB=-lenchant
++SPELLER_LIB=
+
+ AC_SUBST(SPELLER_LIB)
+ GTKSPELL_PACKAGES=gtk+-2.0
+ AC_SUBST(GTKSPELL_PACKAGES)
+-PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant >= 0.4.0 )
++PKG_CHECK_MODULES(GTKSPELL, $GTKSPELL_PACKAGES enchant-2 )
+ AC_SUBST(GTKSPELL_CFLAGS)
+ AC_SUBST(GTKSPELL_LIBS)
+
+--- gtkspell-2.0.16/gtkspell/gtkspell.c.old 2009-10-09 19:01:47.000000000 +0000
++++ gtkspell-2.0.16/gtkspell/gtkspell.c 2019-03-18 16:17:15.140000000 +0000
+@@ -277,7 +277,7 @@
+ get_word_extents_from_mark(spell->buffer, &start, &end, spell->mark_click);
+ word = gtk_text_buffer_get_text(spell->buffer, &start, &end, FALSE);
+
+- enchant_dict_add_to_pwl( spell->speller, word, strlen(word));
++ enchant_dict_add( spell->speller, word, strlen(word));
+
+ gtkspell_recheck_all(spell);
+
+--- gtkspell-2.0.16/configure.old 2009-10-23 02:57:15.000000000 +0000
++++ gtkspell-2.0.16/configure 2019-03-18 16:20:29.900000000 +0000
+@@ -2715,12 +2715,12 @@
+ pkg_cv_GTKSPELL_CFLAGS="$GTKSPELL_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_CFLAGS=`$PKG_CONFIG --cflags "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2733,12 +2733,12 @@
+ pkg_cv_GTKSPELL_LIBS="$GTKSPELL_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant >= 0.4.0 \"") >&5
+- ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 ") 2>&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GTKSPELL_PACKAGES enchant-2 \"") >&5
++ ($PKG_CONFIG --exists --print-errors "$GTKSPELL_PACKAGES enchant-2 ") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant >= 0.4.0 " 2>/dev/null`
++ pkg_cv_GTKSPELL_LIBS=`$PKG_CONFIG --libs "$GTKSPELL_PACKAGES enchant-2 " 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -2757,14 +2757,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ else
+- GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant >= 0.4.0 "`
++ GTKSPELL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GTKSPELL_PACKAGES enchant-2 "`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$GTKSPELL_PKG_ERRORS" >&5
+
+- { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++ { { $as_echo "$as_me:$LINENO: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+
+@@ -2775,7 +2775,7 @@
+ and GTKSPELL_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant >= 0.4.0 ) were not met:
++$as_echo "$as_me: error: Package requirements ($GTKSPELL_PACKAGES enchant-2 ) were not met:
+
+ $GTKSPELL_PKG_ERRORS
+