summaryrefslogtreecommitdiff
path: root/user/hdparm/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/hdparm/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/hdparm/APKBUILD')
-rw-r--r--user/hdparm/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/hdparm/APKBUILD b/user/hdparm/APKBUILD
index f6e5a8f8e..f1ab5fe96 100644
--- a/user/hdparm/APKBUILD
+++ b/user/hdparm/APKBUILD
@@ -6,11 +6,12 @@ pkgrel=0
pkgdesc="Utility for manipulating IDE device parameters"
url="https://sourceforge.net/projects/hdparm"
arch="all"
+options="!check" # This application has no tests.
license="BSD-2-clause OR GPL-2.0-or-later"
+depends=""
makedepends="linux-headers"
-options="!check" # this application has no tests
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -18,13 +19,11 @@ prepare() {
}
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m755 contrib/idectl "$pkgdir"/sbin
install -D -m755 contrib/ultrabayd "$pkgdir"/sbin