summaryrefslogtreecommitdiff
path: root/user/highlight
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 04:15:40 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 04:15:40 -0500
commit0d465b679ec96ac25ae079d28a26e9487f92c160 (patch)
tree4994bb3ff5c8baac019459c9c2dc9310bc1ffebb /user/highlight
parenta46ee632e4f7bb5bcb077316d92b68b844b204e1 (diff)
downloadpackages-0d465b679ec96ac25ae079d28a26e9487f92c160.tar.gz
packages-0d465b679ec96ac25ae079d28a26e9487f92c160.tar.bz2
packages-0d465b679ec96ac25ae079d28a26e9487f92c160.tar.xz
packages-0d465b679ec96ac25ae079d28a26e9487f92c160.zip
user/highlight: pull in, bump, fix
Diffstat (limited to 'user/highlight')
-rw-r--r--user/highlight/APKBUILD28
-rw-r--r--user/highlight/lua.patch27
2 files changed, 55 insertions, 0 deletions
diff --git a/user/highlight/APKBUILD b/user/highlight/APKBUILD
new file mode 100644
index 000000000..8a0173bf2
--- /dev/null
+++ b/user/highlight/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=highlight
+pkgver=3.43
+pkgrel=0
+pkgdesc="Fast and flexible source code highlighter"
+url="http://www.andre-simon.de/doku/highlight/highlight.html"
+arch="all"
+options="!check" # No test suite.
+license="GPL-3.0+"
+makedepends="boost-dev lua5.3-dev"
+subpackages="$pkgname-doc"
+source="http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2
+ lua.patch
+ "
+
+build() {
+ cd "$builddir"
+ make cli
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="77ad159963de64ef3c4732ad70c63ceafe7002c43d8b045e61361f52e56467933790c70e88570e0c866503a621496de2c80934c7f8141721545ff43c807968d1 highlight-3.43.tar.bz2
+8eb742410761dd73e35abbde30f7d30f6d8d86c0f02c27c0ffbe45d1297a1ca40e9e725d52e50bd134c61259e1740515cbdd67a3baf44ee5f73d267af386cb4c lua.patch"
diff --git a/user/highlight/lua.patch b/user/highlight/lua.patch
new file mode 100644
index 000000000..b7c71781d
--- /dev/null
+++ b/user/highlight/lua.patch
@@ -0,0 +1,27 @@
+--- a/src/makefile
++++ b/src/makefile
+@@ -13,7 +13,8 @@
+ # See src/gui-qt/highlight.pro for the Qt GUI compilation options
+
+ #CXX=clang++
+-CXX=g++
++#CXX=g++
++CXX ?= c++
+
+ # was: qmake-qt5
+ QMAKE=qmake
+@@ -38,11 +39,11 @@
+
+ # If Lua 5.2 is not default on your system yet you have to
+ # use lua5.1 in the pkg-config calls
+-
+-LUA_CFLAGS=$(shell pkg-config --cflags lua)
++LUAPC ?= lua5.3
++LUA_CFLAGS=$(shell pkg-config --cflags $(LUAPC))
+
+ # default lua lib
+-LUA_LIBS=$(shell pkg-config --libs lua)
++LUA_LIBS=$(shell pkg-config --libs $(LUAPC))
+
+ # luajit lib
+ # LUA_LIBS=$(shell pkg-config --libs luajit)