summaryrefslogtreecommitdiff
path: root/user/highlight
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 23:27:51 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 23:27:51 -0500
commit824481ba4d56dcd644fccdf8d6236b87b9799184 (patch)
tree0374291d6213526e56aabb9044899182a2388408 /user/highlight
parentf9094d3de016101f4cf8ba79f924e3a66a4d9453 (diff)
downloadpackages-824481ba4d56dcd644fccdf8d6236b87b9799184.tar.gz
packages-824481ba4d56dcd644fccdf8d6236b87b9799184.tar.bz2
packages-824481ba4d56dcd644fccdf8d6236b87b9799184.tar.xz
packages-824481ba4d56dcd644fccdf8d6236b87b9799184.zip
user/highlight: death to multi-versioned lua
Diffstat (limited to 'user/highlight')
-rw-r--r--user/highlight/APKBUILD9
-rw-r--r--user/highlight/lua.patch27
2 files changed, 3 insertions, 33 deletions
diff --git a/user/highlight/APKBUILD b/user/highlight/APKBUILD
index 8a0173bf2..47ce23cf6 100644
--- a/user/highlight/APKBUILD
+++ b/user/highlight/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=highlight
pkgver=3.43
-pkgrel=0
+pkgrel=1
pkgdesc="Fast and flexible source code highlighter"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
arch="all"
@@ -10,9 +10,7 @@ options="!check" # No test suite.
license="GPL-3.0+"
makedepends="boost-dev lua5.3-dev"
subpackages="$pkgname-doc"
-source="http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2
- lua.patch
- "
+source="http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2"
build() {
cd "$builddir"
@@ -24,5 +22,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="77ad159963de64ef3c4732ad70c63ceafe7002c43d8b045e61361f52e56467933790c70e88570e0c866503a621496de2c80934c7f8141721545ff43c807968d1 highlight-3.43.tar.bz2
-8eb742410761dd73e35abbde30f7d30f6d8d86c0f02c27c0ffbe45d1297a1ca40e9e725d52e50bd134c61259e1740515cbdd67a3baf44ee5f73d267af386cb4c lua.patch"
+sha512sums="77ad159963de64ef3c4732ad70c63ceafe7002c43d8b045e61361f52e56467933790c70e88570e0c866503a621496de2c80934c7f8141721545ff43c807968d1 highlight-3.43.tar.bz2"
diff --git a/user/highlight/lua.patch b/user/highlight/lua.patch
deleted file mode 100644
index b7c71781d..000000000
--- a/user/highlight/lua.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/src/makefile
-+++ b/src/makefile
-@@ -13,7 +13,8 @@
- # See src/gui-qt/highlight.pro for the Qt GUI compilation options
-
- #CXX=clang++
--CXX=g++
-+#CXX=g++
-+CXX ?= c++
-
- # was: qmake-qt5
- QMAKE=qmake
-@@ -38,11 +39,11 @@
-
- # If Lua 5.2 is not default on your system yet you have to
- # use lua5.1 in the pkg-config calls
--
--LUA_CFLAGS=$(shell pkg-config --cflags lua)
-+LUAPC ?= lua5.3
-+LUA_CFLAGS=$(shell pkg-config --cflags $(LUAPC))
-
- # default lua lib
--LUA_LIBS=$(shell pkg-config --libs lua)
-+LUA_LIBS=$(shell pkg-config --libs $(LUAPC))
-
- # luajit lib
- # LUA_LIBS=$(shell pkg-config --libs luajit)