summaryrefslogtreecommitdiff
path: root/user/horizon
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-05 02:33:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-05 02:33:26 +0000
commit71c77f314167a8e5e3f18be557c88f28d3e04692 (patch)
tree078c7adb22b9c2917069dff43a7e711f3146f323 /user/horizon
parent925fabf5441a16a7d347fed2b3bd36ef46fc1f62 (diff)
downloadpackages-71c77f314167a8e5e3f18be557c88f28d3e04692.tar.gz
packages-71c77f314167a8e5e3f18be557c88f28d3e04692.tar.bz2
packages-71c77f314167a8e5e3f18be557c88f28d3e04692.tar.xz
packages-71c77f314167a8e5e3f18be557c88f28d3e04692.zip
user/horizon: Fix issue with runner logging
Diffstat (limited to 'user/horizon')
-rw-r--r--user/horizon/APKBUILD9
-rw-r--r--user/horizon/fix-qt-runner.patch25
2 files changed, 31 insertions, 3 deletions
diff --git a/user/horizon/APKBUILD b/user/horizon/APKBUILD
index 7f8c04e21..4d035e184 100644
--- a/user/horizon/APKBUILD
+++ b/user/horizon/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=horizon
pkgver=0.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="Installation tools for Adélie Linux"
url="https://horizon.adelielinux.org/"
arch="all"
@@ -17,7 +17,9 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages="$pkgname-image $pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-qt5
$pkgname-tools $pkgname-wizard"
-source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz
+ fix-qt-runner.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -97,4 +99,5 @@ wizard() {
rm -r "$subpkgdir"/usr/share
}
-sha512sums="fe8f58a232b7e577aeba62cecfd97bec4037d41dd179781af912c9974210ce4648b0c56bd84fbf78866698e91882b8f4b7168c22842bde1682ea118ca931832f horizon-0.9.1.tar.xz"
+sha512sums="fe8f58a232b7e577aeba62cecfd97bec4037d41dd179781af912c9974210ce4648b0c56bd84fbf78866698e91882b8f4b7168c22842bde1682ea118ca931832f horizon-0.9.1.tar.xz
+78d1a1bca7d12a189d506e1fcc42ea0ab968ed3cb9ada7e95fab6256ea2e0cb820d9b41cdd858e22da37a63f899918fe40c00bcd2d67dea81e3a9ce30570ad46 fix-qt-runner.patch"
diff --git a/user/horizon/fix-qt-runner.patch b/user/horizon/fix-qt-runner.patch
new file mode 100644
index 000000000..39cab1181
--- /dev/null
+++ b/user/horizon/fix-qt-runner.patch
@@ -0,0 +1,25 @@
+From 9f737dbab8b9ed9fa57bdf15542cc00a8363d98b Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Thu, 4 Jun 2020 21:29:37 -0500
+Subject: [PATCH] Qt UI: Ensure log is opened when built in release modes
+
+---
+ ui/qt5/runner/executepage.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ui/qt5/runner/executepage.cc b/ui/qt5/runner/executepage.cc
+index 999731a..d5788df 100644
+--- a/ui/qt5/runner/executepage.cc
++++ b/ui/qt5/runner/executepage.cc
+@@ -48,7 +48,7 @@ ExecutePage::ExecutePage(QWidget *parent) : HorizonWizardPage(parent) {
+ });
+
+ log.setFileName("/var/log/horizon/executor.log");
+- Q_ASSERT(log.open(QFile::Append));
++ log.open(QFile::Append);
+
+ this->current = Prepare;
+ markRunning(this->current);
+--
+2.25.4
+