summaryrefslogtreecommitdiff
path: root/user/horizon
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-08-08 21:25:42 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-08-08 21:25:42 +0000
commitc90f8aa823c55cc6ac6758733e6383c7fc168cfe (patch)
treee5f5c1a72fe305aaab823f7e3bbcd1ca3703e081 /user/horizon
parenta18c0d686937c23beb4a833143a4958f27c4fb11 (diff)
downloadpackages-c90f8aa823c55cc6ac6758733e6383c7fc168cfe.tar.gz
packages-c90f8aa823c55cc6ac6758733e6383c7fc168cfe.tar.bz2
packages-c90f8aa823c55cc6ac6758733e6383c7fc168cfe.tar.xz
packages-c90f8aa823c55cc6ac6758733e6383c7fc168cfe.zip
user/horizon: Update to latest git
Diffstat (limited to 'user/horizon')
-rw-r--r--user/horizon/APKBUILD9
-rw-r--r--user/horizon/git.patch660
2 files changed, 666 insertions, 3 deletions
diff --git a/user/horizon/APKBUILD b/user/horizon/APKBUILD
index dcc9d9bf7..3a7e89a8e 100644
--- a/user/horizon/APKBUILD
+++ b/user/horizon/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=horizon
pkgver=0.9.3
-pkgrel=0
+pkgrel=1
pkgdesc="Installation tools for Adélie Linux"
url="https://horizon.adelielinux.org/"
arch="all"
@@ -17,7 +17,9 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages="$pkgname-image $pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-qt5
$pkgname-tools $pkgname-wizard $pkgname-boot"
-source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/horizon-$pkgver.tar.xz
+ git.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -146,4 +148,5 @@ GLOBALS
"$subpkgdir"/usr/share/xsessions/horizon.desktop
}
-sha512sums="99c1d939abc33c4a072712e75c6c8ada16deb1fe59b9da839dffd695a0d40dbf48499cc00751285300127a7fc701e8e1c434e9f8a222f1981ccbebd6ee72e43e horizon-0.9.3.tar.xz"
+sha512sums="99c1d939abc33c4a072712e75c6c8ada16deb1fe59b9da839dffd695a0d40dbf48499cc00751285300127a7fc701e8e1c434e9f8a222f1981ccbebd6ee72e43e horizon-0.9.3.tar.xz
+7c7c4297ae8d0d879a01ac38c0699dd9338e9b9675a0804dc3ec915e98900343e001d0a0558fcaccbf9f5cfafbf9ae869c7ec194d1529683b5874941a77b0125 git.patch"
diff --git a/user/horizon/git.patch b/user/horizon/git.patch
new file mode 100644
index 000000000..3f15448bf
--- /dev/null
+++ b/user/horizon/git.patch
@@ -0,0 +1,660 @@
+diff --git a/devel/script/2_keys.xml b/devel/script/2_keys.xml
+index 4438881..9ffeba8 100644
+--- a/devel/script/2_keys.xml
++++ b/devel/script/2_keys.xml
+@@ -655,7 +655,7 @@ svcenable udev-trigger boot
+ <title>The <literal>svcenable</literal> Key &mdash; Typical Desktop</title>
+ <programlisting>
+ svcenable dbus
+-svcenable consolekit
++svcenable elogind
+ svcenable sddm
+ </programlisting>
+ <para>This configures the target computer to start up a display manager and its required daemons during system boot, enabling graphical logins.</para>
+diff --git a/devel/script/4_json.xml b/devel/script/4_json.xml
+new file mode 100644
+index 0000000..b0234a4
+--- /dev/null
++++ b/devel/script/4_json.xml
+@@ -0,0 +1,451 @@
++<?xml version="1.0" encoding="utf-8"?>
++<chapter label="4" id="json">
++ <title>JSON Schema</title>
++ <para>The Horizon system supports converting JSON files to HorizonScript. This chapter describes the JSON schema supported by the Horizon JSON tooling.</para>
++ <para>It is important to note that not all features of Horizon are available from JSON. For more advanced use cases, consider writing HorizonScript files directly. However, it is felt that supporting JSON interchange is important for interoperability with external systems.</para>
++ <section id="js_doc_structure">
++ <title>Overall document structure</title>
++ <para>There are two document formats supported by the Horizon JSON tooling. The most common is a simple structure where a single root object contains the Horizon JSON keys. The second, and less common, describes multiple configurations called "images" in a single JSON file. The root object contains a single key/value pair, <literal>images</literal>, which is an array of objects containing Horizon JSON keys. See <xref linkend="js_examples" /> for more information.</para>
++ </section>
++ <section id="js_keys">
++ <title>Supported keys</title>
++ <para/>
++ <section id="js_hostname">
++ <title><literal>hostname</literal></title>
++ <formalpara id="js_hostname.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_hostname.desc">
++ <title>Short Description</title>
++ <para>The device's host name.</para>
++ </formalpara>
++ <formalpara id="js_hostname.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="hostname"><literal>hostname</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_packages">
++ <title><literal>packages</literal></title>
++ <formalpara id="js_packages.format">
++ <title>Format</title>
++ <para>Array of String</para>
++ </formalpara>
++ <formalpara id="js_packages.desc">
++ <title>Short Description</title>
++ <para>A list of packages to install to the device.</para>
++ </formalpara>
++ <formalpara id="js_packages.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="pkginstall"><literal>pkginstall</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_rootpw">
++ <title><literal>rootpw</literal></title>
++ <formalpara id="js_rootpw.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_rootpw.desc">
++ <title>Short Description</title>
++ <para>The encrypted root password for the device.</para>
++ </formalpara>
++ <formalpara id="js_rootpw.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="rootpw"><literal>rootpw</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_arch">
++ <title><literal>arch</literal></title>
++ <formalpara id="js_arch.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_arch.desc">
++ <title>Short Description</title>
++ <para>The device's CPU architecture.</para>
++ </formalpara>
++ <formalpara id="js_arch.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="arch"><literal>arch</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_language">
++ <title><literal>language</literal></title>
++ <formalpara id="js_language.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_language.desc">
++ <title>Short Description</title>
++ <para>The language to use for the device's interface.</para>
++ </formalpara>
++ <formalpara id="js_language.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="language"><literal>language</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_keymap">
++ <title><literal>keymap</literal></title>
++ <formalpara id="js_keymap.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_keymap.desc">
++ <title>Short Description</title>
++ <para>The keyboard map to use for the device's hardware inputs.</para>
++ </formalpara>
++ <formalpara id="js_keymap.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="keymap"><literal>keymap</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_firmware">
++ <title><literal>firmware</literal></title>
++ <formalpara id="js_firmware.format">
++ <title>Format</title>
++ <para>String or Boolean</para>
++ </formalpara>
++ <formalpara id="js_firmware.desc">
++ <title>Short Description</title>
++ <para>Determines whether or not the device will have non-free firmware installed.</para>
++ </formalpara>
++ <formalpara id="js_firmware.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="firmware"><literal>firmware</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_services">
++ <title><literal>services</literal></title>
++ <formalpara id="js_services.format">
++ <title>Format</title>
++ <para>Array of Object</para>
++ </formalpara>
++ <formalpara id="js_services.desc">
++ <title>Short Description</title>
++ <para>Specifies additional services to start on device boot.</para>
++ </formalpara>
++ <formalpara id="js_services.struct">
++ <title>Object Structure</title>
++ <para>
++ <variablelist>
++ <varlistentry>
++ <term><literal>service</literal></term>
++ <listitem><para>(String) The name of the service to start.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>runlevel</literal></term>
++ <listitem><para>(String) The runlevel that the service should start under. If no <literal>runlevel</literal> is specified, <literal>default</literal> is used.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ </para>
++ </formalpara>
++ <formalpara id="js_services.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="svcenable"><literal>svcenable</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_netconfig">
++ <title><literal>netconfig</literal></title>
++ <formalpara id="js_netconfig.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_netconfig.desc">
++ <title>Short Description</title>
++ <para>Determines the network configuration system used on the device.</para>
++ </formalpara>
++ <formalpara id="js_netconfig.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="netconfigtype"><literal>netconfigtype</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_netaddresses">
++ <title><literal>netaddresses</literal></title>
++ <formalpara id="js_netaddresses.format">
++ <title>Format</title>
++ <para>Array of Object</para>
++ </formalpara>
++ <formalpara id="js_netaddresses.desc">
++ <title>Short Description</title>
++ <para>Specifies the device's network addressing configuration.</para>
++ </formalpara>
++ <formalpara id="js_netaddresses.struct">
++ <title>Object Structure</title>
++ <para>
++ <variablelist>
++ <varlistentry>
++ <term><literal>id</literal></term>
++ <listitem><para>(String) This connection's identifier. This field is for operator reference only - it will not appear in the HorizonScript or in the device's configuration.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>interface</literal></term>
++ <listitem><para>(String) The network interface to use for this address.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>addr-type</literal></term>
++ <listitem><para>(String) The type of this address: <literal>none</literal> to bring up the interface without an address (common for bridging), <literal>dhcp</literal> for DHCP, or <literal>static</literal> for static addressing.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>address</literal></term>
++ <listitem><para>(Object) The network address. Only valid if <literal>addr-type</literal> is <literal>static</literal>.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ If static addressing is desired, the <literal>address</literal> object is described below.
++ <variablelist>
++ <varlistentry>
++ <term><literal>ip-address</literal></term>
++ <listitem><para>(String) The IPv4 or IPv6 address for this connection.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>net-prefix</literal></term>
++ <listitem><para>(Number) The network prefix for this connection. Valid values are 1-32 for IPv4, and 1-128 for IPv6.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>gateway</literal></term>
++ <listitem><para>(String) The IPv4 or IPv6 address for the gateway for this connection.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ </para>
++ </formalpara>
++ <formalpara id="js_netaddresses.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="netaddress"><literal>netaddress</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_pppoe_links">
++ <title><literal>pppoe_links</literal></title>
++ <formalpara id="js_pppoe_links.format">
++ <title>Format</title>
++ <para>Array of Object</para>
++ </formalpara>
++ <formalpara id="js_pppoe_links.desc">
++ <title>Short Description</title>
++ <para>Specifies the device's PPPoE configuration.</para>
++ </formalpara>
++ <formalpara id="js_pppoe_links.struct">
++ <title>Object Structure</title>
++ <para>
++ <variablelist>
++ <varlistentry>
++ <term><literal>interface</literal></term>
++ <listitem><para>(String) The network interface to use for this PPPoE link.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>mtu</literal></term>
++ <listitem><para>(Number) The MTU for this PPPoE link. Default is 1472.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>username</literal></term>
++ <listitem><para>(String) The username to use for authenticating this PPPoE link.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>password</literal></term>
++ <listitem><para>(String) The passphrase/secret to use for authenticating this PPPoE link.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>lcp-echo-interval</literal></term>
++ <listitem><para>(Number) The number of seconds between LCP echo requests.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>lcp-echo-failure</literal></term>
++ <listitem><para>(Number) The number of echo request failures before this link is failed.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ </para>
++ </formalpara>
++ <formalpara id="js_pppoe_links.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="pppoe"><literal>pppoe</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_nameservers">
++ <title><literal>nameservers</literal></title>
++ <formalpara id="js_nameservers.format">
++ <title>Format</title>
++ <para>Array of String</para>
++ </formalpara>
++ <formalpara id="js_nameservers.desc">
++ <title>Short Description</title>
++ <para>IP addresses used for Domain Name System (DNS) resolution.</para>
++ </formalpara>
++ <formalpara id="js_nameservers.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="nameserver"><literal>nameserver</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_access-points">
++ <title><literal>access-points</literal></title>
++ <formalpara id="js_access-points.format">
++ <title>Format</title>
++ <para>Array of Object</para>
++ </formalpara>
++ <formalpara id="js_access-points.desc">
++ <title>Short Description</title>
++ <para>Specifies the device's wireless networking configuration.</para>
++ </formalpara>
++ <formalpara id="js_access-points.struct">
++ <title>Object Structure</title>
++ <para>
++ <variablelist>
++ <varlistentry>
++ <term><literal>interface</literal></term>
++ <listitem><para>(String) The wireless network interface to use for this access point.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>ssid</literal></term>
++ <listitem><para>(String) The SSID for this access point.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>security</literal></term>
++ <listitem><para>(String) The security type to use for this access point: <literal>none</literal>, <literal>wep</literal>, or <literal>wpa</literal>.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>password</literal></term>
++ <listitem><para>(String) The shared secret to use for authenticating this wireless link.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ </para>
++ </formalpara>
++ <formalpara id="js_access-points.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="netssid"><literal>netssid</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_timezone">
++ <title><literal>timezone</literal></title>
++ <formalpara id="js_timezone.format">
++ <title>Format</title>
++ <para>String</para>
++ </formalpara>
++ <formalpara id="js_timezone.desc">
++ <title>Short Description</title>
++ <para>The time zone to use on the device.</para>
++ </formalpara>
++ <formalpara id="js_timezone.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="timezone"><literal>timezone</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_repositories">
++ <title><literal>repositories</literal></title>
++ <formalpara id="js_repositories.format">
++ <title>Format</title>
++ <para>Array of String</para>
++ </formalpara>
++ <formalpara id="js_repositories.desc">
++ <title>Short Description</title>
++ <para>The APK repositories to use for package installation on the device.</para>
++ </formalpara>
++ <formalpara id="js_repositories.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="repository"><literal>repository</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_signingkeys">
++ <title><literal>signingkeys</literal></title>
++ <formalpara id="js_signingkeys.format">
++ <title>Format</title>
++ <para>Array of String</para>
++ </formalpara>
++ <formalpara id="js_signingkeys.desc">
++ <title>Short Description</title>
++ <para>The location of the signing key(s) used by the device's APK repositories.</para>
++ </formalpara>
++ <formalpara id="js_signingkeys.xref">
++ <title>Corresponding HorizonScript key</title>
++ <para><link linkend="signingkey"><literal>signingkey</literal></link></para>
++ </formalpara>
++ </section>
++ <section id="js_users">
++ <title><literal>users</literal></title>
++ <formalpara id="js_users.format">
++ <title>Format</title>
++ <para>Array of Object</para>
++ </formalpara>
++ <formalpara id="js_users.desc">
++ <title>Short Description</title>
++ <para>Specifies the device's user accounts.</para>
++ </formalpara>
++ <formalpara id="js_users.struct">
++ <title>Object Structure</title>
++ <para>
++ <variablelist>
++ <varlistentry>
++ <term><literal>username</literal></term>
++ <listitem><para>(String) The login name of this account.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>alias</literal></term>
++ <listitem><para>(String) The friendly name/GECOS of this account.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>passphrase</literal></term>
++ <listitem><para>(String) The encrypted passphrase to use to authenticate to this account. See <xref linkend="userpw" /> for information about the format of <literal>passphrase</literal>.</para></listitem>
++ </varlistentry>
++ <varlistentry>
++ <term><literal>groups</literal></term>
++ <listitem><para>(String) Comma-separated list of this account's member groups.</para></listitem>
++ </varlistentry>
++ </variablelist>
++ </para>
++ </formalpara>
++ <formalpara id="js_users.xref">
++ <title>Corresponding HorizonScript keys</title>
++ <para><link linkend="username"><literal>username</literal></link>, <link linkend="useralias"><literal>useralias</literal></link>, <link linkend="userpw"><literal>userpw</literal></link>, <link linkend="usergroups"><literal>usergroups</literal></link></para>
++ </formalpara>
++ </section>
++ </section>
++ <section id="js_examples">
++ <title>Examples</title>
++ <para>
++ <example id="js_0001-basic">
++ <title>Basic example of Horizon JSON file</title>
++ <programlisting>
++{
++ "hostname": "horizon-json-testmachine.adelielinux.org",
++ "packages": ["adelie-base-posix", "easy-kernel", "easy-kernel-modules",
++ "netifrc", "openrc", "s6-linux-init"],
++ "rootpw": "<userinput>...</userinput>",
++ "root": "/dev/sda1",
++ "netaddresses": [{"id":"eth0", "interface":"eth0", "addr-type":"dhcp"}],
++ "nameservers": ["9.9.9.9"],
++ "timezone": "America/Chicago",
++ "repositories": ["https://distfiles.adelielinux.org/adelie/1.0/system",
++ "https://distfiles.adelielinux.org/adelie/1.0/user"],
++ "signingkeys": ["/etc/apk/keys/powerpc-1@packages.adelielinux.org.pub",
++ "/etc/apk/keys/powerpc-2@packages.adelielinux.org.pub"]
++}
++ </programlisting>
++ </example>
++ <example id="js_0002-fuller">
++ <title>Example of multi-configuration Horizon JSON file</title>
++ <programlisting>
++{"images":
++ [
++ {"name": "Test Image",
++ "hostname": "horizon-json-testmachine.adelielinux.org",
++ "packages": ["adelie-base-posix", "easy-kernel", "easy-kernel-modules",
++ "netifrc", "openrc", "s6-linux-init"],
++ "rootpw": "<userinput>...</userinput>",
++ "root": "/dev/sda1",
++ "arch": "ppc64",
++ "language": "en_GB.UTF-8",
++ "keymap": "us",
++ "firmware": false,
++ "netconfig": "netifrc",
++ "netaddresses": [{"id":"eth0", "interface":"eth0", "addr-type":"dhcp"}],
++ "nameservers": ["9.9.9.9"],
++ "timezone": "America/Chicago",
++ "repositories": ["https://distfiles.adelielinux.org/adelie/1.0/system",
++ "https://distfiles.adelielinux.org/adelie/1.0/user"],
++ "signingkeys": ["/etc/apk/keys/powerpc-1@packages.adelielinux.org.pub",
++ "/etc/apk/keys/powerpc-2@packages.adelielinux.org.pub"]
++ }
++ ]
++}
++ </programlisting>
++ </example>
++ </para>
++ </section>
++</chapter>
+diff --git a/devel/script/script.xml b/devel/script/script.xml
+index f8c1a65..bf82a06 100644
+--- a/devel/script/script.xml
++++ b/devel/script/script.xml
+@@ -4,6 +4,7 @@
+ <!ENTITY chap1 SYSTEM "1_introduction.xml">
+ <!ENTITY chap2 SYSTEM "2_keys.xml">
+ <!ENTITY chap3 SYSTEM "3_ondisk.xml">
++ <!ENTITY chap4 SYSTEM "4_json.xml">
+ ]>
+ <book>
+ <bookinfo>
+@@ -11,8 +12,8 @@
+ <authorgroup>
+ <author><firstname>A.</firstname><surname>Wilcox</surname><affiliation><orgname>Adélie Linux</orgname></affiliation></author>
+ </authorgroup>
+- <edition>Specification for HorizonScript (Horizon release 1.0)</edition>
+- <pubdate>2020-06-13</pubdate>
++ <edition>Specification for HorizonScript (Horizon release 1.0) + JSON specification 1.0</edition>
++ <pubdate>2020-07-20</pubdate>
+ <copyright>
+ <year>2019</year><year>2020</year>
+ <holder>Adélie Linux</holder>
+@@ -26,4 +27,5 @@
+ &chap1;
+ &chap2;
+ &chap3;
++ &chap4;
+ </book>
+diff --git a/hscript/meta.cc b/hscript/meta.cc
+index d79f3f5..1227e60 100644
+--- a/hscript/meta.cc
++++ b/hscript/meta.cc
+@@ -722,6 +722,18 @@ const std::string my_arch(const Horizon::Script *script) {
+ return "pmmx";
+ # elif defined(__x86_64__)
+ return "x86_64";
++# elif defined(__mips64)
++# if defined(__BYTE_ORDER__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++ return "mips64el";
++# else /* If byte order is not defined, default to big endian. */
++ return "mips64";
++# endif
++# elif defined(__mips__)
++# if defined(__BYTE_ORDER__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++ return "mipsel";
++# else /* If byte order is not defined, default to big endian. */
++ return "mips";
++# endif
+ # else
+ # error Unknown architecture.
+ # endif
+@@ -755,6 +767,10 @@ bool Bootloader::validate() const {
+ const static std::set<std::string> valid_x86 = {"grub-bios",
+ "grub-efi"};
+ return valid_x86.find(this->value()) != valid_x86.end();
++ } else if(arch == "mips64" || arch == "mips" ||
++ arch == "mips64el" || arch == "mipsel") {
++ const static std::set<std::string> valid_mips = {};
++ return valid_mips.find(this->value()) != valid_mips.end();
+ } else {
+ output_error(pos, "bootloader: unknown architecture", arch);
+ return false;
+diff --git a/hscript/script.cc b/hscript/script.cc
+index 20ccbe5..6e436b7 100644
+--- a/hscript/script.cc
++++ b/hscript/script.cc
+@@ -225,7 +225,12 @@ Script *Script::load(std::istream &sstream, const ScriptOptions &opts,
+ char nextline[SCRIPT_LINE_MAX];
+ const std::string delim(" \t");
+ int errors = 0, warnings = 0;
+- std::string curr_name = fs::canonical(fs::path(name));
++ std::string curr_name;
++ if(name == "/dev/stdin") {
++ curr_name = "<stdin>";
++ } else {
++ curr_name = fs::canonical(fs::path(name));
++ }
+ std::set<std::string> seen = {curr_name};
+ bool inherit = false;
+ std::istream *my_stream = &sstream;
+@@ -311,7 +316,7 @@ Script *Script::load(std::istream &sstream, const ScriptOptions &opts,
+ }
+
+ if(my_stream->fail() && !my_stream->eof()) {
+- output_error("installfile:" + std::to_string(lineno + 1),
++ output_error(curr_name + ":" + std::to_string(lineno + 1),
+ "line exceeds maximum length",
+ "Maximum line length is " +
+ std::to_string(SCRIPT_LINE_MAX));
+@@ -319,14 +324,14 @@ Script *Script::load(std::istream &sstream, const ScriptOptions &opts,
+ }
+
+ if(my_stream->bad() && !my_stream->eof()) {
+- output_error("installfile:" + std::to_string(lineno),
++ output_error(curr_name + ":" + std::to_string(lineno),
+ "I/O error while reading installfile", "");
+ errors++;
+ }
+
+ /* Ensure all required keys are present. */
+ #define MISSING_ERROR(key) \
+- output_error(name, "expected value for key '" + std::string(key) + "'",\
++ output_error(curr_name, "expected value for key '" + std::string(key) + "'",\
+ "this key is required");\
+ errors++;
+
+@@ -349,7 +354,7 @@ Script *Script::load(std::istream &sstream, const ScriptOptions &opts,
+ }
+ #undef MISSING_ERROR
+
+- output_log("parser", "0", name,
++ output_log("parser", "0", curr_name,
+ std::to_string(errors) + " error(s), " +
+ std::to_string(warnings) + " warning(s).", "");
+
+diff --git a/ui/qt5/horizonwizard.cc b/ui/qt5/horizonwizard.cc
+index 6c2ea9e..92b81db 100644
+--- a/ui/qt5/horizonwizard.cc
++++ b/ui/qt5/horizonwizard.cc
+@@ -352,6 +352,18 @@ HorizonWizard::HorizonWizard(QWidget *parent) : QWizard(parent) {
+ arch = pmmx;
+ # elif defined(__x86_64__)
+ arch = x86_64;
++# elif defined(__mips64)
++# if defined(__BYTE_ORDER__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++ arch = mips64el;
++# else /* If byte order is not defined, default to big endian. */
++ arch = mips64;
++# endif
++# elif defined(__mips__)
++# if defined(__BYTE_ORDER__) && __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++ arch = mipsel;
++# else /* If byte order is not defined, default to big endian. */
++ arch = mips;
++# endif
+ # else
+ # error You are attempting to compile the Installation Environment UI \
+ on an unknown architecture. Please add a definition to horizonwizard.hh, a \
+@@ -551,6 +563,19 @@ QString HorizonWizard::toHScript() {
+ lines << "signingkey https://distfiles.adelielinux.org/adelie/keys/x86-1@packages.adelielinux.org.pub";
+ lines << "signingkey https://distfiles.adelielinux.org/adelie/keys/x86-2@packages.adelielinux.org.pub";
+ break;
++ case mips64:
++ lines << "arch mips64";
++ /* XXX: MIPS signing keys are needed before we ship anything. */
++ break;
++ case mips:
++ lines << "arch mips";
++ break;
++ case mips64el:
++ lines << "arch mips64el";
++ break;
++ case mipsel:
++ lines << "arch mipsel";
++ break;
+ case UnknownCPU:
+ /* no arch line. hopefully it's run on the target. */
+ break;
+@@ -608,13 +633,13 @@ QString HorizonWizard::toHScript() {
+ lines << "pkginstall adelie-base-posix firefox-esr libreoffice "
+ "thunderbird vlc kde x11 bluez sddm";
+ lines << "svcenable bluetooth";
+- lines << "svcenable consolekit";
++ lines << "svcenable elogind";
+ lines << "svcenable sddm";
+ break;
+ case Compact:
+ lines << "pkginstall adelie-base netsurf featherpad lxqt-desktop "
+ "abiword gnumeric sddm xorg-apps xorg-drivers xorg-server";
+- lines << "svcenable consolekit";
++ lines << "svcenable elogind";
+ lines << "svcenable sddm";
+ break;
+ case TextOnly:
+diff --git a/ui/qt5/horizonwizard.hh b/ui/qt5/horizonwizard.hh
+index bf53ae0..8af9df7 100644
+--- a/ui/qt5/horizonwizard.hh
++++ b/ui/qt5/horizonwizard.hh
+@@ -96,6 +96,10 @@ public:
+ enum Arch {
+ aarch64,
+ armv7,
++ mips,
++ mips64,
++ mipsel,
++ mips64el,
+ pmmx,
+ ppc,
+ ppc64,