summaryrefslogtreecommitdiff
path: root/user/http-parser
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-06-15 22:55:29 -0500
committerMax Rees <maxcrees@me.com>2020-06-15 23:09:40 -0500
commit58a870ecf6ad95286465981d19022c3d25e8a8da (patch)
tree4f470c7755d9b6d88a7c8f5a49c39632ad8fc67b /user/http-parser
parentffa4f1d4cdbcb15bcaca6332e61294752f3a8bf1 (diff)
downloadpackages-58a870ecf6ad95286465981d19022c3d25e8a8da.tar.gz
packages-58a870ecf6ad95286465981d19022c3d25e8a8da.tar.bz2
packages-58a870ecf6ad95286465981d19022c3d25e8a8da.tar.xz
packages-58a870ecf6ad95286465981d19022c3d25e8a8da.zip
user/http-parser: bump to 2.9.4
Diffstat (limited to 'user/http-parser')
-rw-r--r--user/http-parser/APKBUILD9
-rw-r--r--user/http-parser/remove-bogus-sizeof-test.patch14
2 files changed, 20 insertions, 3 deletions
diff --git a/user/http-parser/APKBUILD b/user/http-parser/APKBUILD
index af90a5f0e..cc6281b98 100644
--- a/user/http-parser/APKBUILD
+++ b/user/http-parser/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=http-parser
-pkgver=2.9.3
+pkgver=2.9.4
pkgrel=0
pkgdesc="Library for parsing HTTP messages in C"
url=" "
@@ -11,7 +11,9 @@ depends=""
depends_dev=""
makedepends="$depends_dev"
subpackages="$pkgname-dev"
-source="http-parser-$pkgver.tar.gz::https://github.com/nodejs/http-parser/archive/v$pkgver.tar.gz"
+source="http-parser-$pkgver.tar.gz::https://github.com/nodejs/http-parser/archive/v$pkgver.tar.gz
+ remove-bogus-sizeof-test.patch
+ "
build() {
make
@@ -25,4 +27,5 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-sha512sums="d200c52f594192ba80a8d5b59d414404843f8601dac647f29c27845db75ac1f015789031e30e91aaab5b553af1ee6af50b90f9342a444c10c1027e10fdb9a31b http-parser-2.9.3.tar.gz"
+sha512sums="b45df7b94d1c51079d44687d0a7f901f44faae51df4e84c7e3fe38f130c2d809d0e7c2a146c57b3723e60732aededc246bf44eadb10a95b710963d641f9fe7cd http-parser-2.9.4.tar.gz
+aaf666728ab860a19398a631276d7caaf696d29bfbce39408bbcd65775f23d452e477af481333631b8dd07eacb8ba44fb4c58d1216dc5fb0dfac88062c7f478b remove-bogus-sizeof-test.patch"
diff --git a/user/http-parser/remove-bogus-sizeof-test.patch b/user/http-parser/remove-bogus-sizeof-test.patch
new file mode 100644
index 000000000..5f912fb5b
--- /dev/null
+++ b/user/http-parser/remove-bogus-sizeof-test.patch
@@ -0,0 +1,14 @@
+Upstream issues:
+https://github.com/nodejs/http-parser/issues/507
+https://github.com/nodejs/http-parser/pull/510
+
+--- http-parser-2.9.4/test.c 2020-03-24 05:54:06.000000000 -0500
++++ http-parser-2.9.4/test.c 2020-06-15 22:54:06.020315073 -0500
+@@ -4221,7 +4221,6 @@ main (void)
+ printf("http_parser v%u.%u.%u (0x%06lx)\n", major, minor, patch, version);
+
+ printf("sizeof(http_parser) = %u\n", (unsigned int)sizeof(http_parser));
+- assert(sizeof(http_parser) == 4 + 4 + 8 + 2 + 2 + 4 + sizeof(void *));
+
+ //// API
+ test_preserve_data();