summaryrefslogtreecommitdiff
path: root/user/hunspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 06:31:31 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 17:56:35 -0500
commit0dbc1c8d70d494d22eea7078e099a08c48c76585 (patch)
treed55cd464af26ddeac2579dcba0a39359842154e9 /user/hunspell
parent99dc7131c241bd1550250db109bd874bd9e899e5 (diff)
downloadpackages-0dbc1c8d70d494d22eea7078e099a08c48c76585.tar.gz
packages-0dbc1c8d70d494d22eea7078e099a08c48c76585.tar.bz2
packages-0dbc1c8d70d494d22eea7078e099a08c48c76585.tar.xz
packages-0dbc1c8d70d494d22eea7078e099a08c48c76585.zip
user/hunspell: bump and fix
Diffstat (limited to 'user/hunspell')
-rw-r--r--user/hunspell/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/hunspell/APKBUILD b/user/hunspell/APKBUILD
new file mode 100644
index 000000000..979afbf9f
--- /dev/null
+++ b/user/hunspell/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer:
+pkgname=hunspell
+pkgver=1.6.2
+pkgrel=2
+pkgdesc="Spell checker and morphological analyzer library and program"
+url="https://hunspell.github.io/"
+arch="all"
+license="GPL-2.0+ AND LGPL-2.0+ AND MPL-1.1"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+makedepends="ncurses-dev autoconf automake libtool"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ LIBS="-ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-ui \
+ --disable-static \
+ --without-included-gettext
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="a23127f1271da95ac06a1fb2f57b659485e959567b61da05b2bb350684003a0fb7e882b5e524c465fd890f79f513ed03174f38611989a1c09081147c47d6da11 hunspell-1.6.2.tar.gz"