summaryrefslogtreecommitdiff
path: root/user/hunspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 06:50:34 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 06:50:34 -0600
commitc7c0916fad338d4743257d0f05e357e9c0f1f670 (patch)
tree5a4b8d5ba4cd7a6b6a36aa22aa58bec657dae485 /user/hunspell
parent092ad87bd24b84b2539294bb00d7dde7c9d2ce23 (diff)
downloadpackages-c7c0916fad338d4743257d0f05e357e9c0f1f670.tar.gz
packages-c7c0916fad338d4743257d0f05e357e9c0f1f670.tar.bz2
packages-c7c0916fad338d4743257d0f05e357e9c0f1f670.tar.xz
packages-c7c0916fad338d4743257d0f05e357e9c0f1f670.zip
user/various libraries: modernise / fix syntax
Diffstat (limited to 'user/hunspell')
-rw-r--r--user/hunspell/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/user/hunspell/APKBUILD b/user/hunspell/APKBUILD
index 6222d58a5..79da8d619 100644
--- a/user/hunspell/APKBUILD
+++ b/user/hunspell/APKBUILD
@@ -6,18 +6,17 @@ pkgdesc="Spell checker and morphological analyzer library and program"
url="https://hunspell.github.io/"
arch="all"
license="GPL-2.0+ AND LGPL-2.0+ AND MPL-1.1"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=""
makedepends="ncurses-dev autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/hunspell/hunspell/archive/v$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
LIBS="-ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}