summaryrefslogtreecommitdiff
path: root/user/i3wm
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2019-06-25 14:02:01 +0000
committerDan Theisen <djt@hxx.in>2019-06-26 09:35:21 +0000
commit8573d680ed22cd62c68179a10e5f6f58f981c761 (patch)
treeec041373952928c681e793695e02e35a1a2d9ed0 /user/i3wm
parent3909831687ae100e3113a395930a33973cdcd92a (diff)
downloadpackages-8573d680ed22cd62c68179a10e5f6f58f981c761.tar.gz
packages-8573d680ed22cd62c68179a10e5f6f58f981c761.tar.bz2
packages-8573d680ed22cd62c68179a10e5f6f58f981c761.tar.xz
packages-8573d680ed22cd62c68179a10e5f6f58f981c761.zip
user/i3wm: bump package to 4.16.1
Diffstat (limited to 'user/i3wm')
-rw-r--r--user/i3wm/APKBUILD6
-rw-r--r--user/i3wm/i3wm-musl-glob-tilde.patch14
2 files changed, 10 insertions, 10 deletions
diff --git a/user/i3wm/APKBUILD b/user/i3wm/APKBUILD
index 59c94e802..7b8bd9469 100644
--- a/user/i3wm/APKBUILD
+++ b/user/i3wm/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=i3wm
-pkgver=4.15
+pkgver=4.16.1
pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
@@ -43,7 +43,7 @@ package() {
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
-sha512sums="60ab61b7e380342126bea12fb4371f98fcf18f6435f79a9519d3f59cfabdb170634366036e1aa20c5592da0832b03140ad1f0c72bad3cfaace0b7c57ad01dfc4 i3-4.15.tar.bz2
-8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 i3wm-musl-glob-tilde.patch
+sha512sums="3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0 i3-4.16.1.tar.bz2
+6378e3619076c03345b4faa1f9d54cab2e7173068bc4d5f2f2894af9cc0e5792fe45ce95cb06328f5040f0ba6d43f3e49c523968732ac2d2046b698042338caa i3wm-musl-glob-tilde.patch
77224b994397b2e2487ae28dfd5781b3630654191813eb3c685f05ebf446e65c36e53a665ff3cc8323ea67e87f7cf977044025dade0a6ed22cbd84f0e6b4cbc7 i3wm-test-fix-off_t.patch
a80384965dff62c51ce77e2baa3cf1b0b6db1df68994ce98383f96554bd296b4b59527fb5b1cb24b08c123699e294ba9b3baaa52afe88d87e7a76f0629194b1f i3wm-test-disable-branch-check.patch"
diff --git a/user/i3wm/i3wm-musl-glob-tilde.patch b/user/i3wm/i3wm-musl-glob-tilde.patch
index 82ad6195b..d4c2d832e 100644
--- a/user/i3wm/i3wm-musl-glob-tilde.patch
+++ b/user/i3wm/i3wm-musl-glob-tilde.patch
@@ -4,7 +4,7 @@ diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
*
*/
- char *expand_path(char *path) {
+ static char *expand_path(char *path) {
- static glob_t globbuf;
- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
- ELOG("glob() failed\n");
@@ -28,11 +28,11 @@ diff -urp i3-4.11/i3bar/src/main.c i3-4.11.new/i3bar/src/main.c
+ return sstrdup(path);
}
- void print_usage(char *elf_name) {
+ static void print_usage(char *elf_name) {
diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
--- i3-4.11/libi3/resolve_tilde.c 2015-09-30 07:55:10.000000000 +0100
+++ i3-4.11.new/libi3/resolve_tilde.c 2016-02-08 20:03:47.849230953 +0000
-@@ -19,27 +19,18 @@
+@@ -19,28 +19,18 @@
*
*/
char *resolve_tilde(const char *path) {
@@ -53,9 +53,9 @@ diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
- } else {
- head = globbuf.gl_pathv[0];
- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strncpy(result, head, strlen(head));
-- if (tail)
-- strncat(result, tail, strlen(tail));
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
+ if (strncmp(path, "~/", 2) == 0) {
+ home = getenv("HOME");
+ if (home != NULL) {
@@ -64,7 +64,7 @@ diff -urp i3-4.11/libi3/resolve_tilde.c i3-4.11.new/libi3/resolve_tilde.c
+ strcpy(expanded, home);
+ strcat(expanded, path+1);
+ return expanded;
-+ }
+ }
}
- globfree(&globbuf);