summaryrefslogtreecommitdiff
path: root/user/icon-naming-utils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-09 20:18:04 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-09 20:18:04 +0000
commitdea46123e881049090d8cddc044d04d8b4eb0d3b (patch)
tree59f5c9a0c139bc714d1cae32b8b33500ef361298 /user/icon-naming-utils
parentbbc8a0ac6fa72271dcc977fd9fd158fb3481810e (diff)
downloadpackages-dea46123e881049090d8cddc044d04d8b4eb0d3b.tar.gz
packages-dea46123e881049090d8cddc044d04d8b4eb0d3b.tar.bz2
packages-dea46123e881049090d8cddc044d04d8b4eb0d3b.tar.xz
packages-dea46123e881049090d8cddc044d04d8b4eb0d3b.zip
user/icon-naming-utils: new package
Diffstat (limited to 'user/icon-naming-utils')
-rw-r--r--user/icon-naming-utils/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/icon-naming-utils/APKBUILD b/user/icon-naming-utils/APKBUILD
new file mode 100644
index 000000000..e878b858c
--- /dev/null
+++ b/user/icon-naming-utils/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=icon-naming-utils
+pkgver=0.8.90
+pkgrel=0
+pkgdesc="Script for migrating to the Icon Naming Specification"
+url="http://tango.freedesktop.org/Tango_Icon_Library"
+arch="noarch"
+license="GPL-2.0-only"
+depends="perl perl-xml-simple"
+makedepends=""
+subpackages="$pkgname-dev"
+source="http://tango.freedesktop.org/releases/icon-naming-utils-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make pkgconfigdir="/usr/lib/pkgconfig" DESTDIR="$pkgdir" install
+}
+
+sha512sums="6c23f6138e053f9fc6de9d56f94b80849f29f9fde46cdf54b705720cb48b0c660f315484fb36fb9936d4ceade7768aad2d17280545a4b392aa56185c9452999d icon-naming-utils-0.8.90.tar.gz"