summaryrefslogtreecommitdiff
path: root/user/id3lib
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-25 01:17:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-25 01:17:29 -0500
commit777afed86d510d6b4dd425db3c62ca4dae07f122 (patch)
tree19f153e9addeda7d183c5122040864b520de3b21 /user/id3lib
parent98eddbaa61eea87b837bab2d705aee990cb1fe99 (diff)
downloadpackages-777afed86d510d6b4dd425db3c62ca4dae07f122.tar.gz
packages-777afed86d510d6b4dd425db3c62ca4dae07f122.tar.bz2
packages-777afed86d510d6b4dd425db3c62ca4dae07f122.tar.xz
packages-777afed86d510d6b4dd425db3c62ca4dae07f122.zip
user/id3lib: add cstring patch for PowerPC
Diffstat (limited to 'user/id3lib')
-rw-r--r--user/id3lib/APKBUILD4
-rw-r--r--user/id3lib/cstring.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/user/id3lib/APKBUILD b/user/id3lib/APKBUILD
index d97b8c684..c395a7645 100644
--- a/user/id3lib/APKBUILD
+++ b/user/id3lib/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=id3lib
pkgver=3.8.3
-pkgrel=0
+pkgrel=1
pkgdesc="Library for reading, writing, and manipulating ID3v2 tags"
url="http://id3lib.sourceforge.net"
arch="all"
@@ -13,6 +13,7 @@ makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/project/id3lib/id3lib/$pkgver/id3lib-$pkgver.tar.gz
+ cstring.patch
modern-cpp.patch
test-expose-proper-stdlib-symbols.patch
"
@@ -47,5 +48,6 @@ package() {
}
sha512sums="3787e261f86933c1c2f2bff2c4b349b42f5d8636e489e4f39f9d75e6dfbdc79b87009a0f4ce4b786f2fb3dbc01ca9d56c4112095b46244f897e6c9a28573adaf id3lib-3.8.3.tar.gz
+e379e848788f7fda3a86b02b9865dfe5db69d66ffcfb81184c1cd92f2f1ed7b4d40f13cc77f9de294afc13ae61ab50c3aa13f9a4cc4eb85cb7a727d25268ee6a cstring.patch
334eed099c93ea279d877437a92f684bfb0df12774fd7fffb628b6e8c4b17b17952d6f7c0bf0dff03a87887f0f1233c70d98b69f23580dcf3bf64c8d4b93fc85 modern-cpp.patch
cd79daddffbafc11e555f16be827ccedc03e419b7c24ab1da1852af294dc486a0836d612318eb9861691ef8462ca38be41cfa2c12849f022ebb187c6ef95a1b9 test-expose-proper-stdlib-symbols.patch"
diff --git a/user/id3lib/cstring.patch b/user/id3lib/cstring.patch
new file mode 100644
index 000000000..dfb80119a
--- /dev/null
+++ b/user/id3lib/cstring.patch
@@ -0,0 +1,10 @@
+--- id3lib-3.8.3/include/id3/id3lib_strings.h.old 2003-03-01 18:23:00.000000000 -0600
++++ id3lib-3.8.3/include/id3/id3lib_strings.h 2018-03-25 14:47:42.035694885 -0500
+@@ -30,6 +30,7 @@
+ #define _ID3LIB_STRINGS_H_
+
+ #include <string>
++#include <cstring>
+
+ #if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
+ namespace std