summaryrefslogtreecommitdiff
path: root/user/id3lib
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-25 14:13:52 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-25 14:37:14 -0500
commitd398872e0b7d9958a8b0b1798cdbc19cd45ea8df (patch)
treef65633ea50cb057c75f9f2d58a03a0207c5a7f30 /user/id3lib
parent8dbe01c2f26ed9fc09a3e1d156a0f208029e9558 (diff)
downloadpackages-d398872e0b7d9958a8b0b1798cdbc19cd45ea8df.tar.gz
packages-d398872e0b7d9958a8b0b1798cdbc19cd45ea8df.tar.bz2
packages-d398872e0b7d9958a8b0b1798cdbc19cd45ea8df.tar.xz
packages-d398872e0b7d9958a8b0b1798cdbc19cd45ea8df.zip
user/id3lib: new package
Diffstat (limited to 'user/id3lib')
-rw-r--r--user/id3lib/APKBUILD51
-rw-r--r--user/id3lib/modern-cpp.patch22
-rw-r--r--user/id3lib/test-expose-proper-stdlib-symbols.patch12
3 files changed, 85 insertions, 0 deletions
diff --git a/user/id3lib/APKBUILD b/user/id3lib/APKBUILD
new file mode 100644
index 000000000..d97b8c684
--- /dev/null
+++ b/user/id3lib/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=id3lib
+pkgver=3.8.3
+pkgrel=0
+pkgdesc="Library for reading, writing, and manipulating ID3v2 tags"
+url="http://id3lib.sourceforge.net"
+arch="all"
+license="LGPL-2.0+"
+depends=""
+depends_dev="zlib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/project/id3lib/id3lib/$pkgver/id3lib-$pkgver.tar.gz
+ modern-cpp.patch
+ test-expose-proper-stdlib-symbols.patch
+ "
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS="$CFLAGS -fPIC"
+ export CXXFLAGS="$CXXFLAGS -fPIC"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3787e261f86933c1c2f2bff2c4b349b42f5d8636e489e4f39f9d75e6dfbdc79b87009a0f4ce4b786f2fb3dbc01ca9d56c4112095b46244f897e6c9a28573adaf id3lib-3.8.3.tar.gz
+334eed099c93ea279d877437a92f684bfb0df12774fd7fffb628b6e8c4b17b17952d6f7c0bf0dff03a87887f0f1233c70d98b69f23580dcf3bf64c8d4b93fc85 modern-cpp.patch
+cd79daddffbafc11e555f16be827ccedc03e419b7c24ab1da1852af294dc486a0836d612318eb9861691ef8462ca38be41cfa2c12849f022ebb187c6ef95a1b9 test-expose-proper-stdlib-symbols.patch"
diff --git a/user/id3lib/modern-cpp.patch b/user/id3lib/modern-cpp.patch
new file mode 100644
index 000000000..e56460167
--- /dev/null
+++ b/user/id3lib/modern-cpp.patch
@@ -0,0 +1,22 @@
+The <iomanip> header is already checked; <iomanip.h> is pre-C++98 alias.
+
+--- id3lib-3.8.3/configure.in.old 2003-03-02 00:23:00.000000000 +0000
++++ id3lib-3.8.3/configure.in 2018-03-25 06:43:58.270837035 +0000
+@@ -227,7 +227,6 @@
+ )
+ AC_CHECK_HEADERS( \
+ string \
+- iomanip.h \
+ ,,AC_MSG_ERROR([Missing a vital header file for id3lib])
+ )
+
+--- id3lib-3.8.3/configure.old 2003-03-02 00:23:00.000000000 +0000
++++ id3lib-3.8.3/configure 2018-03-25 06:44:02.260837054 +0000
+@@ -10296,7 +10296,6 @@
+
+ for ac_header in \
+ string \
+- iomanip.h \
+
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
diff --git a/user/id3lib/test-expose-proper-stdlib-symbols.patch b/user/id3lib/test-expose-proper-stdlib-symbols.patch
new file mode 100644
index 000000000..fbb4d5260
--- /dev/null
+++ b/user/id3lib/test-expose-proper-stdlib-symbols.patch
@@ -0,0 +1,12 @@
+--- id3lib-3.8.3/examples/test_io.cpp.old 2003-03-02 00:23:00.000000000 +0000
++++ id3lib-3.8.3/examples/test_io.cpp 2018-03-25 19:10:54.891043851 +0000
+@@ -11,6 +11,9 @@
+ #include <id3/io_strings.h>
+ #include <id3/utils.h>
+
++using std::cin;
++using std::dec;
++using std::hex;
+ using std::cout;
+ using std::endl;
+ using std::cerr;