summaryrefslogtreecommitdiff
path: root/user/ido
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 03:25:51 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 03:25:51 +0000
commit9d93210680f8aad0bbfcd83cf5493e6629700d5a (patch)
tree45aebd741b0344491c40069da811dcebf05d9079 /user/ido
parenta877cb5d35f5858a95bfbb1a694e224d5e421805 (diff)
downloadpackages-9d93210680f8aad0bbfcd83cf5493e6629700d5a.tar.gz
packages-9d93210680f8aad0bbfcd83cf5493e6629700d5a.tar.bz2
packages-9d93210680f8aad0bbfcd83cf5493e6629700d5a.tar.xz
packages-9d93210680f8aad0bbfcd83cf5493e6629700d5a.zip
user/ido: Bump to 13.10.0
Diffstat (limited to 'user/ido')
-rw-r--r--user/ido/APKBUILD23
-rw-r--r--user/ido/ubuntu-private.patch70
2 files changed, 83 insertions, 10 deletions
diff --git a/user/ido/APKBUILD b/user/ido/APKBUILD
index 9925e1453..329b48ddd 100644
--- a/user/ido/APKBUILD
+++ b/user/ido/APKBUILD
@@ -1,43 +1,46 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=ido
-pkgver=12.10.2
+pkgver=13.10.0
pkgrel=0
pkgdesc="Library for indicator display objects"
url="https://launchpad.net/ido"
arch="all"
options="!check" # broken testsuite
license="(LGPL-2.1-only OR LGPL-3.0-only) AND GPL-3.0-only AND LGPL-2.0+"
-makedepends="gtk+3.0-dev"
+depends=""
+makedepends="gtk+3.0-dev autoconf automake libtool gobject-introspection-dev
+ gtk-doc vala xorg-gtest-dev"
subpackages="$pkgname-dev"
-source="https://launchpad.net/ido/12.10/$pkgver/+download/ido-$pkgver.tar.gz"
+source="http://archive.ubuntu.com/ubuntu/pool/universe/i/ido/ido_$pkgver+17.04.20161028.orig.tar.gz
+ ubuntu-private.patch
+ "
+builddir="$srcdir"
prepare() {
- cd "$builddir"
default_prepare
- update_config_sub
+ autoreconf -vif
}
build() {
- cd "$builddir"
CFLAGS="-Wno-error" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-ubuntu-private-api
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="f745380bbc8b97c739691ae4f0dc27d5903ff078e92aaa2280d2c830c77ea2ad29b3abb4a49ffc7cc928b32e3a60ad64de20087980e02e5d5233eeb22978d2dc ido-12.10.2.tar.gz"
+sha512sums="867157c9e316eb5ed69ebdf1017ed86990aabf7a885ba26acab36782f0f27e10b4621a7db15ac90335e808022490a98560d5ff443e6f697c578eed5868385ebd ido_13.10.0+17.04.20161028.orig.tar.gz
+1894f82bd8c2daa25cf41a0c401979941894ec2be165ddbe40eb5b2bc2a4272b22d19a1710e80c975c33bf4f1a6ff91920bf569e536851e65d702f1267fdc367 ubuntu-private.patch"
diff --git a/user/ido/ubuntu-private.patch b/user/ido/ubuntu-private.patch
new file mode 100644
index 000000000..04aa31ac7
--- /dev/null
+++ b/user/ido/ubuntu-private.patch
@@ -0,0 +1,70 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -140,6 +140,16 @@ dnl = GTK Doc Check ====================
+
+ GTK_DOC_CHECK([1.8])
+
++dnl = GTK+ Ubuntu Private API =================================================
++
++AC_ARG_ENABLE([ubuntu-private-api],
++ [AS_HELP_STRING([--enable-ubuntu-private-api=@<:@no/yes@:>@],
++ [Use Ubuntu GTK+ Private API @<:@default=yes@:>@])],
++ [enable_ubuntu_private_api="$enableval"],
++ [enable_ubuntu_private_api=yes])
++
++AM_CONDITIONAL([USE_UBUNTU_PRIVATE_API], [test "x$enable_ubuntu_private_api" != xno])
++
+ dnl ===========================================================================
+
+ AC_CONFIG_FILES([
+@@ -160,6 +170,7 @@ echo ""
+ echo " Prefix : ${prefix}"
+ echo " gcov : ${use_gcov}"
+ echo " introspection: ${enable_introspection}"
++echo " ubuntu gtk+ : ${enable_ubuntu_private_api}"
+ echo ""
+ echo " Documentation: ${enable_gtk_doc}"
+ echo ""
+--- a/src/idomenuitemfactory.c
++++ b/src/idomenuitemfactory.c
+@@ -17,6 +17,7 @@
+ * Lars Uebernickel <lars.uebernickel@canonical.com>
+ */
+
++#ifdef USE_UBUNTU_PRIVATE_API
+ #include <gtk/gtk.h>
+ #include <gtk/ubuntu-private.h>
+
+@@ -117,3 +118,4 @@ static void
+ ido_menu_item_factory_init (IdoMenuItemFactory *factory)
+ {
+ }
++#endif
+--- a/src/libido.c
++++ b/src/libido.c
+@@ -28,9 +28,11 @@
+ void
+ ido_init (void)
+ {
++#ifdef USE_UBUNTU_PRIVATE_API
+ GType ido_menu_item_factory_get_type (void);
+
+ /* make sure this extension point is registered so that gtk calls it
+ * when finding custom menu items */
+ g_type_ensure (ido_menu_item_factory_get_type ());
++#endif
+ }
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -68,6 +68,10 @@ AM_CPPFLAGS = \
+ $(MAINTAINER_CFLAGS) \
+ -Wall -Werror -Wextra -Wno-unused-parameter -Wno-error=deprecated-declarations
+
++if USE_UBUNTU_PRIVATE_API
++AM_CPPFLAGS += -DUSE_UBUNTU_PRIVATE_API
++endif
++
+ AM_CFLAGS = \
+ $(COVERAGE_CFLAGS)
+
+