summaryrefslogtreecommitdiff
path: root/user/ido
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 22:12:51 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 22:15:56 -0500
commite63f6a2120fdcc6f8dc2eab2da847909d5ac6efa (patch)
treef0867309aafb3b517560db79e81118ca174dbf0c /user/ido
parent118d7556d70f81e78c335b6e71318d5e4e2b5e21 (diff)
downloadpackages-e63f6a2120fdcc6f8dc2eab2da847909d5ac6efa.tar.gz
packages-e63f6a2120fdcc6f8dc2eab2da847909d5ac6efa.tar.bz2
packages-e63f6a2120fdcc6f8dc2eab2da847909d5ac6efa.tar.xz
packages-e63f6a2120fdcc6f8dc2eab2da847909d5ac6efa.zip
user/ido: new package
Diffstat (limited to 'user/ido')
-rw-r--r--user/ido/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/ido/APKBUILD b/user/ido/APKBUILD
new file mode 100644
index 000000000..a2714b183
--- /dev/null
+++ b/user/ido/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=ido
+pkgver=12.10.2
+pkgrel=0
+pkgdesc="Library for indicator display objects"
+url="https://launchpad.net/libido"
+arch="all"
+options="!check" # broken testsuite
+license="(LGPL-2.1-only OR LGPL-3.0-only) AND GPL-3.0-only AND LGPL-2.0+"
+makedepends="gtk+3.0-dev"
+subpackages="$pkgname-dev"
+source="https://launchpad.net/ido/12.10/$pkgver/+download/ido-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ CFLAGS="-Wno-error" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f745380bbc8b97c739691ae4f0dc27d5903ff078e92aaa2280d2c830c77ea2ad29b3abb4a49ffc7cc928b32e3a60ad64de20087980e02e5d5233eeb22978d2dc ido-12.10.2.tar.gz"