summaryrefslogtreecommitdiff
path: root/user/iptables
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
committerMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
commit2707df6cc761dcc2341faa8bafec5b4b4fa33e4d (patch)
tree9df7c2d2fd84f153634581ff4fb249b98bf34ffa /user/iptables
parentb7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71 (diff)
downloadpackages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.gz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.bz2
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.xz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.zip
system/*, user/*: remove bashisms from initd scripts
Diffstat (limited to 'user/iptables')
-rw-r--r--user/iptables/APKBUILD4
-rw-r--r--user/iptables/iptables.initd2
2 files changed, 3 insertions, 3 deletions
diff --git a/user/iptables/APKBUILD b/user/iptables/APKBUILD
index c9b8f4715..1d34a1ce3 100644
--- a/user/iptables/APKBUILD
+++ b/user/iptables/APKBUILD
@@ -3,7 +3,7 @@
pkgname=iptables
pkgver=1.8.3
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
@@ -61,6 +61,6 @@ package() {
}
sha512sums="84b10080646077cbea78b7f3fcc58c6c6e1898213341c69862e1b48179f37a6820c3d84437c896071f966b61aa6d16b132d91948a85fd8c05740f29be3a0986d iptables-1.8.3.tar.bz2
-059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1 iptables.initd
+726dfa1aa598d9dff802b99347138c861703b3dd28b2721a6b79b12f87d988369d3b4b9daee7cb2f9a930daac8921600de1e5342a347b3eae3791f0b9f0acbeb iptables.initd
cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e iptables.confd
0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4 ip6tables.confd"
diff --git a/user/iptables/iptables.initd b/user/iptables/iptables.initd
index 98b52d0cd..63b2f06a4 100644
--- a/user/iptables/iptables.initd
+++ b/user/iptables/iptables.initd
@@ -34,7 +34,7 @@ depend() {
}
set_table_policy() {
- local chains table=$1 policy=$2
+ local chains table="$1" policy="$2"
case ${table} in
nat) chains="PREROUTING POSTROUTING OUTPUT";;
mangle) chains="PREROUTING INPUT FORWARD OUTPUT POSTROUTING";;