summaryrefslogtreecommitdiff
path: root/user/iputils
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2019-06-25 16:34:19 +0000
committerDan Theisen <djt@hxx.in>2019-06-26 09:36:09 +0000
commit849c6d27691fb7901ad3e364ffa4cc69f6cb26e3 (patch)
tree7fe143d50db233a5ac8f605f8fe846bb281aae6b /user/iputils
parentce23089ab69352506edeb69fb0b195c8dee57709 (diff)
downloadpackages-849c6d27691fb7901ad3e364ffa4cc69f6cb26e3.tar.gz
packages-849c6d27691fb7901ad3e364ffa4cc69f6cb26e3.tar.bz2
packages-849c6d27691fb7901ad3e364ffa4cc69f6cb26e3.tar.xz
packages-849c6d27691fb7901ad3e364ffa4cc69f6cb26e3.zip
user/iputils: bump to 20190515
Diffstat (limited to 'user/iputils')
-rw-r--r--user/iputils/APKBUILD47
-rw-r--r--user/iputils/docbook-man.patch33
-rw-r--r--user/iputils/fix-idn.patch14
-rw-r--r--user/iputils/fix-init-of-cmsg.patch20
-rw-r--r--user/iputils/time.patch10
5 files changed, 50 insertions, 74 deletions
diff --git a/user/iputils/APKBUILD b/user/iputils/APKBUILD
index fc6b1b3e6..4a35f931b 100644
--- a/user/iputils/APKBUILD
+++ b/user/iputils/APKBUILD
@@ -1,55 +1,42 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iputils
-pkgver=20180629
+pkgver=20190515
pkgrel=0
pkgdesc="IP Configuration Utilities (and Ping)"
url="https://github.com/iputils/iputils/"
arch="all"
license="BSD-3-Clause AND GPL-2.0-or-later"
-makedepends="libcap-dev openssl-dev libxslt docbook-xsl"
+makedepends="meson libcap-dev libxslt docbook-xsl-ns openssl-dev libgcrypt-dev"
replaces="bbsuid"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-openrc"
source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz
- time.patch
- fix-init-of-cmsg.patch
- fix-idn.patch
+ docbook-man.patch
"
-options="!check suid" # there is no testsuite for these applications
+options="suid"
builddir="$srcdir/$pkgname-s$pkgver"
build() {
cd "$builddir"
# we're waiting for idn support in musl so that we can enable it here
# https://wiki.musl-libc.org/functional-differences-from-glibc.html#Name-Resolver/DNS
- make all ninfod USE_IDN=no USE_NETTLE=no KERNEL_INCLUDE=/usr/include
- make man
+ meson --prefix /usr --buildtype=plain builddir -DUSE_IDN=false
+ ninja -v -C builddir
}
-package() {
- local name
+check() {
cd "$builddir"
+ ninja -C builddir test
+}
- for name in arping clockdiff ipg rarpd rdisc tftpd tracepath; do
- install -D -m755 $name "$pkgdir"/usr/sbin/$name
- done
- install -D -m755 ninfod/ninfod "$pkgdir"/usr/sbin/ninfod
-
- for name in ping traceroute6; do
- install -D -m4755 $name "$pkgdir"/bin/$name
- done
+package() {
+ cd "$builddir"
- mkdir -p "$pkgdir"/usr/share/man/man8
- for doc in ./doc/*.8; do
- gzip $doc
- install -m644 "$doc".gz "$pkgdir"/usr/share/man/man8/
- done
+ DESTDIR=$pkgdir ninja -C builddir install
- ln -s tracepath "$pkgdir"/usr/sbin/tracepath6
- ln -s ping "$pkgdir"/bin/ping6
+ ln -s tracepath "$pkgdir"/usr/bin/tracepath6
+ ln -s ping "$pkgdir"/usr/bin/ping6
}
-sha512sums="16b8f5ad1cf88083ebaee0a71fddb14bb0a904336fd0baebfcca86c27ac0773553b21d12790b05cab7661d6432c75bbb1523e871e5e1b77faacd13ccc84f4476 iputils-20180629.tgz
-530532d16574921d0789af6a82706915e8103e712195c4f2eb6379192cc7126ba6bc9f33e8454118628d59f8932ffd2bb5aaba3b61fa93df83088e3b0d93d227 time.patch
-2779b9d987089a2a9a39c27a092f16da85881e9dfbc99edcca6baea42912b8a1a7e16b00c19684d2ea1a6123d66f78be12bef43398e63be7d7c97d3d6269a5bf fix-init-of-cmsg.patch
-b3a5e5ef9ed1ed12a137f176db6a444f15db67dfaef3706514bc4d0cd2a332fb8aeeae0460fca8a1dfef2e0ce2ae0cf2218a74e3f61c46fcb27715a030425ac0 fix-idn.patch"
+sha512sums="adb8831ca3a567b9a5f3762227c631aefa62eedbaa7578c2bfea90b6d494b9e0cccf49b68713912611ec56c352d6c517df9e8409c9c9478cfc5732371c8cf250 iputils-20190515.tgz
+411f45a2d16c88b09f3547e3f04aa20e257f54650c7783123e4cb021bd8850cd96896480fbf9305d6df72abe32d8d5c2239ce4ac4ef9bfa821c205309451d6ff docbook-man.patch"
diff --git a/user/iputils/docbook-man.patch b/user/iputils/docbook-man.patch
new file mode 100644
index 000000000..1793858e4
--- /dev/null
+++ b/user/iputils/docbook-man.patch
@@ -0,0 +1,33 @@
+--- iputils-s20190515/doc/custom-man.xsl.old 2019-06-25 11:48:48.790000000 +0000
++++ iputils-s20190515/doc/custom-man.xsl 2019-06-25 11:49:06.250000000 +0000
+@@ -5,7 +5,7 @@
+ extension-element-prefixes="exsl"
+ version="1.0">
+
+-<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl"/>
++<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl"/>
+
+ <xsl:template name="top.comment" />
+
+--- iputils-s20190515/doc/meson.build.old 2019-06-25 14:54:58.170000000 +0000
++++ iputils-s20190515/doc/meson.build 2019-06-25 14:55:28.460000000 +0000
+@@ -48,7 +48,7 @@
+ ]
+
+ if xsltproc.found()
+- xsl = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
++ xsl = 'file:///usr/share/xml/docbook/xsl-stylesheets-ns/manpages/docbook.xsl'
+ testrun = run_command([xsltproc, '--nonet', xsl])
+ xsltproc_works = testrun.returncode() == 0
+ if xsltproc_works == false
+--- iputils-s20190515/doc/custom-html.xsl.old 2019-06-25 14:56:50.460000000 +0000
++++ iputils-s20190515/doc/custom-html.xsl 2019-06-25 14:57:11.680000000 +0000
+@@ -2,7 +2,7 @@
+
+ <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
+
+-<xsl:import href="http://docbook.sourceforge.net/release/xsl-ns/current/html/docbook.xsl"/>
++<xsl:import href="file:///usr/share/xml/docbook/xsl-stylesheets-ns/html/docbook.xsl"/>
+ <!--
+ - The docbook stylesheet injects empty anchor tags into generated HTML, identified by an auto-generated ID.
+ - Ask the docbook stylesheet to generate reproducible output when generating (these) ID values.
diff --git a/user/iputils/fix-idn.patch b/user/iputils/fix-idn.patch
deleted file mode 100644
index 4aaae8e82..000000000
--- a/user/iputils/fix-idn.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- iputils-s20180629/ping.c.orig 2018-06-29 11:00:46.000000000 -0700
-+++ iputils-s20180629/ping.c 2018-07-06 01:09:10.479830175 -0700
-@@ -207,9 +210,10 @@
-
- #ifdef USE_IDN
- setlocale(LC_ALL, "");
--#endif
-+
- if (!strcmp(setlocale(LC_ALL, NULL), "C"))
- hints.ai_flags &= ~ AI_CANONIDN;
-+#endif
-
- /* Support being called using `ping4` or `ping6` symlinks */
- if (argv[0][strlen(argv[0])-1] == '4')
diff --git a/user/iputils/fix-init-of-cmsg.patch b/user/iputils/fix-init-of-cmsg.patch
deleted file mode 100644
index 76ebc16c2..000000000
--- a/user/iputils/fix-init-of-cmsg.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fixes ping on s390x.
-
-diff --git a/ping.c b/ping.c
-index a0857a1..329553d 100644
---- a/ping.c
-+++ b/ping.c
-@@ -108,8 +108,11 @@ static int parsetos(char *str);
- static struct {
- struct cmsghdr cm;
- struct in_pktinfo ipi;
--} cmsg = { {sizeof(struct cmsghdr) + sizeof(struct in_pktinfo), SOL_IP, IP_PKTINFO},
-- {0, }};
-+} cmsg = { .cm = {
-+ .cmsg_len = sizeof(struct cmsghdr) + sizeof(struct in_pktinfo),
-+ .cmsg_level = SOL_IP,
-+ .cmsg_type = IP_PKTINFO},
-+ .ipi = {0, }};
- int cmsg_len;
-
- struct sockaddr_in source;
diff --git a/user/iputils/time.patch b/user/iputils/time.patch
deleted file mode 100644
index 1d6033f7a..000000000
--- a/user/iputils/time.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./tracepath.c.orig
-+++ ./tracepath.c
-@@ -12,6 +12,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <unistd.h>
-+#include <time.h>
- #include <sys/socket.h>
- #include <linux/types.h>
- #include <linux/errqueue.h>