summaryrefslogtreecommitdiff
path: root/user/iputils
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2021-10-04 06:54:52 +0000
committerDan Theisen <djt@hxx.in>2021-10-04 06:54:52 +0000
commit922dd4db4c9f63f2fe55d48fd51faec7f39ffc9c (patch)
treeb810f36071e31b82e684fd965ab4097e43601449 /user/iputils
parent753e83817987a3eb75d73ab9d8c8971e4069f0cc (diff)
downloadpackages-922dd4db4c9f63f2fe55d48fd51faec7f39ffc9c.tar.gz
packages-922dd4db4c9f63f2fe55d48fd51faec7f39ffc9c.tar.bz2
packages-922dd4db4c9f63f2fe55d48fd51faec7f39ffc9c.tar.xz
packages-922dd4db4c9f63f2fe55d48fd51faec7f39ffc9c.zip
user/iputils: bump to 20210722
Diffstat (limited to 'user/iputils')
-rw-r--r--user/iputils/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/user/iputils/APKBUILD b/user/iputils/APKBUILD
index 1d625f8f7..b6ce3bad0 100644
--- a/user/iputils/APKBUILD
+++ b/user/iputils/APKBUILD
@@ -1,24 +1,29 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iputils
-pkgver=20190709
+pkgver=20210722
pkgrel=0
pkgdesc="IP Configuration Utilities (and Ping)"
url="https://github.com/iputils/iputils/"
arch="all"
-options="suid"
+options="!check suid" # tests require binaries with suid/capabilities
license="BSD-3-Clause AND GPL-2.0-or-later"
depends=""
makedepends="docbook-xsl docbook-xsl-ns libcap-dev libgcrypt-dev libxslt meson
openssl-dev"
subpackages="$pkgname-doc $pkgname-lang $pkgname-openrc"
-source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/s$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-s$pkgver"
+source="$pkgname-$pkgver.tgz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
# we're waiting for idn support in musl so that we can enable it here
# https://wiki.musl-libc.org/functional-differences-from-glibc.html#Name-Resolver/DNS
- meson --prefix /usr --buildtype=plain builddir -DUSE_IDN=false
+ meson --prefix /usr \
+ --buildtype=plain \
+ -DBUILD_ARPING=true \
+ -DUSE_IDN=false \
+ -DNO_SETCAP_OR_SUID=false \
+ builddir
ninja -v -C builddir
}
@@ -33,4 +38,4 @@ package() {
ln -s ping "$pkgdir"/usr/bin/ping6
}
-sha512sums="5db18ac49fa46ed810da4d508e78f4baf2d5c07e7f923eb49d005ad8745743d8861e5788b34a7e37fb7261cee7ddfb768b737eee9d200502ea53537142cac6b5 iputils-20190709.tgz"
+sha512sums="8f85bf468f8ef1e2832e9bbf9009552df4a6d723dd130fa0d5b2aa3bae617c972f936143c2370c3b4ce2ba2499828c91a299ee42cf81fa81aabe10552db2b328 iputils-20210722.tgz"