summaryrefslogtreecommitdiff
path: root/user/isync
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2019-03-15 22:26:20 +0100
committerLuis Ressel <aranea@aixah.de>2019-03-15 22:26:20 +0100
commit338e21fe28aaec7558d9b889fe51a961526eeabf (patch)
tree02480a52cd783f333d7722bbcd4a87a62800d75c /user/isync
parent8b45e21403ceb94f1f7ac3c097a4633c41f589a8 (diff)
downloadpackages-338e21fe28aaec7558d9b889fe51a961526eeabf.tar.gz
packages-338e21fe28aaec7558d9b889fe51a961526eeabf.tar.bz2
packages-338e21fe28aaec7558d9b889fe51a961526eeabf.tar.xz
packages-338e21fe28aaec7558d9b889fe51a961526eeabf.zip
user/isync: New package
Diffstat (limited to 'user/isync')
-rw-r--r--user/isync/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/isync/APKBUILD b/user/isync/APKBUILD
new file mode 100644
index 000000000..a1a5a09e3
--- /dev/null
+++ b/user/isync/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Luis Ressel <aranea@aixah.de>
+# Maintainer: Luis Ressel <aranea@aixah.de>
+pkgname=isync
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="IMAP and MailDir mailbox synchronizer"
+url="http://isync.sourceforge.net/"
+arch="all"
+license="GPL-2.0+"
+options="!check" # No test suite
+depends=""
+makedepends="db-dev cyrus-sasl-dev openssl-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/isync/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b5186f2afe97cab58ce55d3ec19ae7371676ae614448614a9e3e02d09662c34b74e559f0926661fa0300ab22dab9e2e9089b78ee38b94141ff3f8b4d75578ffa isync-1.3.0.tar.gz"