summaryrefslogtreecommitdiff
path: root/user/kcalcore/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 19:32:09 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 19:32:09 -0500
commitac87ede9d9762bd63a4027472b2b065a2279751c (patch)
treebd44176b0c6d331e2e41fb2c7b4b64d5030b2a52 /user/kcalcore/APKBUILD
parentc7b734339515450c5e38329aa74618d224043e6c (diff)
downloadpackages-ac87ede9d9762bd63a4027472b2b065a2279751c.tar.gz
packages-ac87ede9d9762bd63a4027472b2b065a2279751c.tar.bz2
packages-ac87ede9d9762bd63a4027472b2b065a2279751c.tar.xz
packages-ac87ede9d9762bd63a4027472b2b065a2279751c.zip
user/kcalcore: bump to 18.04.3, modernise, fix tests/deps
Diffstat (limited to 'user/kcalcore/APKBUILD')
-rw-r--r--user/kcalcore/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/user/kcalcore/APKBUILD b/user/kcalcore/APKBUILD
index 6123a52bd..865e206df 100644
--- a/user/kcalcore/APKBUILD
+++ b/user/kcalcore/APKBUILD
@@ -1,20 +1,19 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcalcore
-pkgver=18.04.1
+pkgver=18.04.3
pkgrel=0
pkgdesc="Library for managing a calendar of events"
url="https://www.kde.org/"
arch="all"
-license="LGPL-2.0"
+license="LGPL-2.0+"
depends=""
-depends_dev="qt5-qtbase-dev kconfig-dev kdelibs4support-dev libical-dev"
-makedepends="$depends_dev cmake extra-cmake-modules bison"
+depends_dev="qt5-qtbase-dev attica-dev kparts-dev"
+makedepends="$depends_dev cmake extra-cmake-modules bison libical-dev
+ kconfig-dev kdelibs4support-dev"
checkdepends="tzdata"
-install=""
subpackages="$pkgname-dev"
-source="http://download.kde.org/stable/applications/$pkgver/src/kcalcore-$pkgver.tar.xz"
-builddir="$srcdir/kcalcore-$pkgver"
+source="https://download.kde.org/stable/applications/$pkgver/src/kcalcore-$pkgver.tar.xz"
build() {
cd "$builddir"
@@ -34,7 +33,7 @@ build() {
check() {
cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(RecursOn-RFC2445_RRULETest39.ics|Compat-Mozilla|Compat-Evolution)'
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(RecursOn-RFC2445_RRULETest39.ics|Compat-Mozilla|Compat-Evolution|Compat-libical3)'
}
package() {
@@ -42,4 +41,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="2ce97d97b15bacec0ae208d5f987abc76d5b5712b99030c38170be5712adaeb76fb376d26bad42bde5fc144e3cc182c1e0430e885f4617d5514dd50a86635032 kcalcore-18.04.1.tar.xz"
+sha512sums="2da0993ab1d0c6facbf7f02af186f3554ca38408468dd72f57380817ef1f7f0bf236409a8644d7e84b5019d1eb918f2fd6ff1c1190a89a4e825845659ea84a1b kcalcore-18.04.3.tar.xz"