summaryrefslogtreecommitdiff
path: root/user/kcalendarcore
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-06-04 16:52:38 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit18d37b40a1dff05c8e75928dfdf851bf2f1acf8b (patch)
tree2aa60b0e6a8f7f95a90ef159815c7c2dc675d223 /user/kcalendarcore
parentdadb2364fa576f1b9d7e01fe26de6fae296c5844 (diff)
downloadpackages-18d37b40a1dff05c8e75928dfdf851bf2f1acf8b.tar.gz
packages-18d37b40a1dff05c8e75928dfdf851bf2f1acf8b.tar.bz2
packages-18d37b40a1dff05c8e75928dfdf851bf2f1acf8b.tar.xz
packages-18d37b40a1dff05c8e75928dfdf851bf2f1acf8b.zip
user/[KDE Frameworks]: Update to 5.94.0
Many frameworks have added or removed dependencies. Documentation builds have been fixed for new tag file dependencies. * KIO: Fix build on GCC 8. * Prison: Ensure QR and DTMX barcodes are generated properly on big-endian systems. * Syndication: New framework.
Diffstat (limited to 'user/kcalendarcore')
-rw-r--r--user/kcalendarcore/APKBUILD27
1 files changed, 23 insertions, 4 deletions
diff --git a/user/kcalendarcore/APKBUILD b/user/kcalendarcore/APKBUILD
index a313c8340..7a80ee16c 100644
--- a/user/kcalendarcore/APKBUILD
+++ b/user/kcalendarcore/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kcalendarcore
-pkgver=5.74.0
+pkgver=5.94.0
pkgrel=0
pkgdesc="Library for managing a calendar of events"
url="https://www.kde.org/"
arch="all"
license="LGPL-2.0+"
depends=""
-depends_dev="qt5-qtbase-dev attica-dev kparts-dev"
+depends_dev="qt5-qtbase-dev"
checkdepends="tzdata"
makedepends="$depends_dev cmake extra-cmake-modules libical-dev
doxygen qt5-qttools-dev"
@@ -33,11 +33,30 @@ build() {
}
check() {
- TZ=UTC CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(Compat-libical3|testicaltimezones)'
+ x11_tests="testalarm testattachment testattendee testcalfilter
+ testconference testcustomproperties testdateserialization testduration
+ testevent testincidence testexception testfilestorage testfreebusy
+ testindicdencerelation testicalformat testidentical testjournal
+ testmemorycalendar testperiod testfreebusyperiod testperson
+ testrecurtodo teststartdatetimesfordate testtodo testtimesininterval
+ testcreateddatecompat testrecurrenceexception testoccurrenceiterator
+ testreadrecurrenceid testcalendarobserver"
+
+ # https://invent.kde.org/frameworks/kcalendarcore/-/issues/3
+ failing_tests="Compat-AppleICal Compat-MSExchange"
+
+ skipline="(testicaltimezones"
+ for tname in $failing_tests $x11_tests; do
+ skipline="$skipline|$tname"
+ done
+ skipline="$skipline)"
+ echo $skipline
+
+ TZ=UTC CTEST_PARALLEL_JOBS=${JOBS} CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "$skipline"
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f6b48283d5433e171a1961abcbf47422fb8ce1e6412d0a83de20c16b2e81e065e16c1525440e1a29791b31ec74fbe672878cd554fceab703cc0c9c45c23524af kcalendarcore-5.74.0.tar.xz"
+sha512sums="e9747a1965ca78d6112276cbd501cf00494fe7ba777a24a92e7f0f1b605770f924bca2d1b7e30b69b19051f2c823d71faa37ae4768857d6adb38d7c0dfd9a32c kcalendarcore-5.94.0.tar.xz"