summaryrefslogtreecommitdiff
path: root/user/kcoreaddons
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-27 03:31:45 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-27 03:31:45 +0000
commitc76fbb6394b8371b7262660390c9c4098c1d5f0b (patch)
tree49bf80cde2c1ba2977ce729449fecda32c129500 /user/kcoreaddons
parent2de0997503b0ac33cfc8a90a2fe90d18c48a97a0 (diff)
downloadpackages-c76fbb6394b8371b7262660390c9c4098c1d5f0b.tar.gz
packages-c76fbb6394b8371b7262660390c9c4098c1d5f0b.tar.bz2
packages-c76fbb6394b8371b7262660390c9c4098c1d5f0b.tar.xz
packages-c76fbb6394b8371b7262660390c9c4098c1d5f0b.zip
user/kcoreaddons: Use UTF-8 for parsing /etc/os-release
Diffstat (limited to 'user/kcoreaddons')
-rw-r--r--user/kcoreaddons/APKBUILD7
-rw-r--r--user/kcoreaddons/utf8.patch17
2 files changed, 22 insertions, 2 deletions
diff --git a/user/kcoreaddons/APKBUILD b/user/kcoreaddons/APKBUILD
index 527d9538d..f8637699c 100644
--- a/user/kcoreaddons/APKBUILD
+++ b/user/kcoreaddons/APKBUILD
@@ -13,7 +13,9 @@ depends_dev="qt5-qtbase-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev doxygen
shared-mime-info"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-$pkgver.tar.xz"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-$pkgver.tar.xz
+ utf8.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -39,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="86b24604a9d7ff32b5a1e4c43c11a254b788deb0e289625de3c7acf75d435405273b59be2646df9906558f8190124aeedc061f9b963bf336d0200ed799570b60 kcoreaddons-5.66.0.tar.xz"
+sha512sums="86b24604a9d7ff32b5a1e4c43c11a254b788deb0e289625de3c7acf75d435405273b59be2646df9906558f8190124aeedc061f9b963bf336d0200ed799570b60 kcoreaddons-5.66.0.tar.xz
+d462866912d9cc9a768477d872142eb67be6b616c044436a27aa71577546efe4aa323b3dac913f9dbb52fc62dbe27d464b30ac3c4cb23c5d7c414d96138e9300 utf8.patch"
diff --git a/user/kcoreaddons/utf8.patch b/user/kcoreaddons/utf8.patch
new file mode 100644
index 000000000..3fee25313
--- /dev/null
+++ b/user/kcoreaddons/utf8.patch
@@ -0,0 +1,17 @@
+Use UTF-8 for parsing /etc/os-release.
+
+diff --git a/src/lib/util/kosrelease.cpp b/src/lib/util/kosrelease.cpp
+index 0469aba..1d74f2a 100644
+--- a/src/lib/util/kosrelease.cpp
++++ b/src/lib/util/kosrelease.cpp
+@@ -134,9 +134,9 @@ public:
+ QStringList parts;
+ while (!file.atEnd()) {
+ // Trimmed to handle indented comment lines properly
+- line = QString::fromLatin1(file.readLine()).trimmed();
++ line = QString::fromUtf8(file.readLine()).trimmed();
+
+ if (line.startsWith(QLatin1Char('#'))) {
+ // Comment line
+ // Lines beginning with "#" shall be ignored as comments.
+ continue;