summaryrefslogtreecommitdiff
path: root/user/kde-games
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-14 02:29:41 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-14 02:29:41 -0500
commita5e79537282b0e53f13b2d52935dbb8c50db843a (patch)
tree2f60a098d2a9a78dca153fb79e9d020263f239de /user/kde-games
parent025d6436dd1b7a80f62dcac202b9804969c52f4c (diff)
downloadpackages-a5e79537282b0e53f13b2d52935dbb8c50db843a.tar.gz
packages-a5e79537282b0e53f13b2d52935dbb8c50db843a.tar.bz2
packages-a5e79537282b0e53f13b2d52935dbb8c50db843a.tar.xz
packages-a5e79537282b0e53f13b2d52935dbb8c50db843a.zip
user/kde-games: new metapackage
Diffstat (limited to 'user/kde-games')
-rw-r--r--user/kde-games/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/kde-games/APKBUILD b/user/kde-games/APKBUILD
new file mode 100644
index 000000000..e412a3f3e
--- /dev/null
+++ b/user/kde-games/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kde-games
+pkgver=17.08.1
+pkgrel=0
+pkgdesc="All the KDE games"
+url="https://www.kde.org/applications/games/"
+arch="noarch"
+license="NCSA"
+options="!check" # Metapackage, no tests needed.
+depends="kapman katomic kblackbox kblocks kbounce kbreakout kdiamond
+ kfourinline kgoldrunner kigo killbots kiriki kjumpingcube klickety
+ klines kmahjongg kmines knetwalk kollision konquest kpat kreversi
+ kshisen ksnakeduel ksquares ksudoku kteatime ktuberling kubrick
+ lskat xdg-utils"
+makedepends=""
+install=""
+subpackages=""
+source="https://distfiles.adelielinux.org/source/kde-games-$pkgver.tar.xz"
+builddir="$srcdir/kde-games-$pkgver"
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ install -D -m644 "$builddir"/org.adelie-linux.about-games.desktop \
+ "$pkgdir"/usr/share/applications/org.adelie-linux.about-games.desktop
+}
+
+sha512sums="fafb75c8d7f2f76ecb84afa4d5c93bb7e903e1b4646c0d67c858926371fa9bd4b0d96093a5077bb0429bf982aabec9775c2608414d02cfc2e3bb87b83d9c3e34 kde-games-17.08.1.tar.xz"