summaryrefslogtreecommitdiff
path: root/user/keychain
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-09 06:22:25 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-09 06:22:25 +0000
commitfc973aed71950a37b43cd006a9f62b8c23373915 (patch)
tree61d1a9146d366e978d52e834af7ddc3f9d8015e5 /user/keychain
parent73a0ca55d8be33cce8dde0c35e4273c9bbd6a01e (diff)
downloadpackages-fc973aed71950a37b43cd006a9f62b8c23373915.tar.gz
packages-fc973aed71950a37b43cd006a9f62b8c23373915.tar.bz2
packages-fc973aed71950a37b43cd006a9f62b8c23373915.tar.xz
packages-fc973aed71950a37b43cd006a9f62b8c23373915.zip
user/*: Modernise / fix syntax / deps
Diffstat (limited to 'user/keychain')
-rw-r--r--user/keychain/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/user/keychain/APKBUILD b/user/keychain/APKBUILD
index e3dc1306b..114843930 100644
--- a/user/keychain/APKBUILD
+++ b/user/keychain/APKBUILD
@@ -6,22 +6,18 @@ pkgrel=0
pkgdesc="Agent manager for OpenSSH and GnuPG"
url="https://funtoo.org/Keychain"
arch="noarch"
-options="!check" # no tests
+options="!check" # No test suite.
license="GPL-2.0-only"
depends=""
makedepends="perl"
-install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/funtoo/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
install -Dm755 "./${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "./${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}