summaryrefslogtreecommitdiff
path: root/user/knotifications
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 08:22:01 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 08:22:01 -0600
commit461f104797c3f2ded54e7c02a2cf5b87268362ee (patch)
tree37b3344a590404a2439a2b49c9e0286fb7d08ce6 /user/knotifications
parent460de5048a42a4b31a170fe0f1f116d70719fbcd (diff)
downloadpackages-461f104797c3f2ded54e7c02a2cf5b87268362ee.tar.gz
packages-461f104797c3f2ded54e7c02a2cf5b87268362ee.tar.bz2
packages-461f104797c3f2ded54e7c02a2cf5b87268362ee.tar.xz
packages-461f104797c3f2ded54e7c02a2cf5b87268362ee.zip
user/knotifications: Bump to 5.65.0, add Qt Text-to-Speech support
Diffstat (limited to 'user/knotifications')
-rw-r--r--user/knotifications/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/user/knotifications/APKBUILD b/user/knotifications/APKBUILD
index bbf4a5895..4a8cd8bee 100644
--- a/user/knotifications/APKBUILD
+++ b/user/knotifications/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=knotifications
-pkgver=5.54.0
+pkgver=5.65.0
pkgrel=0
pkgdesc="Framework for sending notifications to users"
url="https://www.kde.org/"
@@ -12,12 +12,11 @@ depends=""
depends_dev="qt5-qtbase-dev qt5-qtx11extras-dev kwindowsystem-dev kconfig-dev
kcodecs-dev kcoreaddons-dev phonon-dev libdbusmenu-qt-dev"
makedepends="$depends_dev cmake extra-cmake-modules libx11-dev libxext-dev
- libice-dev qt5-qttools-dev doxygen graphviz"
+ libice-dev qt5-qtspeech-dev qt5-qttools-dev doxygen graphviz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -29,18 +28,16 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="66098068d707f4b5b5147b2e02dec7b4a11c95af1dcc02ec933d1b5b63d8dab1e7776a34aae80cfb5671ae7e27cfd50dad5566e26152fb94de076384b77cdcfa knotifications-5.54.0.tar.xz"
+sha512sums="36b314546a0591df7e2c9d9b3870e3faefc86feac01f4d95924b4e721714ec1934592aa14948265230f0972cd523bee245637e17964faac5035382c45d6ed44f knotifications-5.65.0.tar.xz"