summaryrefslogtreecommitdiff
path: root/user/konversation/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/konversation/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/konversation/APKBUILD')
-rw-r--r--user/konversation/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/user/konversation/APKBUILD b/user/konversation/APKBUILD
index dd280d582..36e0efe17 100644
--- a/user/konversation/APKBUILD
+++ b/user/konversation/APKBUILD
@@ -15,10 +15,11 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev karchive-dev kconfig-dev
kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev
kitemviews-dev phonon-dev qca-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/konversation/$pkgver/src/konversation-$pkgver.tar.xz"
+source="https://download.kde.org/stable/konversation/$pkgver/src/konversation-$pkgver.tar.xz
+ qt5.patch
+ "
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -29,18 +30,17 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="001534c7f6c5110ca5e210977cc4275e083f5c3704078a74aa573af659154e0fa4c3c960be08f41256db1ac4568f0734741bf10cfb2e15d9e6f6440250682504 konversation-1.7.5.tar.xz"
+sha512sums="001534c7f6c5110ca5e210977cc4275e083f5c3704078a74aa573af659154e0fa4c3c960be08f41256db1ac4568f0734741bf10cfb2e15d9e6f6440250682504 konversation-1.7.5.tar.xz
+a407be142c896eeef3edc4b3b6fa9451341b660c80b300573a2029c6a2b3a4340a2b351ee13e9f0f65aeddf1e47e164faf13d81e626e17093d0ec84f35255b6a qt5.patch"