summaryrefslogtreecommitdiff
path: root/user/kplotting
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-01 05:12:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-01 05:12:13 -0500
commit1534cb3a94b4e36722d1647a14f41189d4ce462c (patch)
tree370bb766a8f76b05aa8a45eb79882eb32fdd8a3a /user/kplotting
parent2bf11564ef200da7c59f2015e259ed728b5f8889 (diff)
downloadpackages-1534cb3a94b4e36722d1647a14f41189d4ce462c.tar.gz
packages-1534cb3a94b4e36722d1647a14f41189d4ce462c.tar.bz2
packages-1534cb3a94b4e36722d1647a14f41189d4ce462c.tar.xz
packages-1534cb3a94b4e36722d1647a14f41189d4ce462c.zip
user/kplotting: new package
Diffstat (limited to 'user/kplotting')
-rw-r--r--user/kplotting/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/kplotting/APKBUILD b/user/kplotting/APKBUILD
new file mode 100644
index 000000000..a8a5ee055
--- /dev/null
+++ b/user/kplotting/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=kplotting
+pkgver=5.38.0
+pkgrel=0
+pkgdesc="Framework for data plotting functions"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1"
+options="!check" # Test requires accelerated X11 display.
+depends=""
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev cmake extra-cmake-modules"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.kde.org/stable/frameworks/5.38/kplotting-$pkgver.tar.xz"
+builddir="$srcdir/kplotting-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a7c09c49686c571d97c14c6017634575aba61e7e93ccd9c44442ea1953c64cf64e7d68d2606d823dae5d05832f38c7d54c8786d5906a8f8cda8d35fb58b55fcc kplotting-5.38.0.tar.xz"