summaryrefslogtreecommitdiff
path: root/user/ktimer/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/ktimer/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/ktimer/APKBUILD')
-rw-r--r--user/ktimer/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/user/ktimer/APKBUILD b/user/ktimer/APKBUILD
index 0ab9de2a3..30d577ba8 100644
--- a/user/ktimer/APKBUILD
+++ b/user/ktimer/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ktimer
-pkgver=19.08.2
+pkgver=19.12.3
pkgrel=0
pkgdesc="Tool to execute programs after some time"
url="https://www.kde.org/applications/utilities/ktimer/"
@@ -11,10 +11,9 @@ depends=""
makedepends="cmake extra-cmake-modules qt5-qtbase-dev kdoctools-dev ki18n-dev
kwidgetsaddons-dev kio-dev kdbusaddons-dev knotifications-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/ktimer-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktimer-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -25,18 +24,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="60e2c16b9fa44bbd9e7cca3a487d9a78d572c1cd20e09782735fc30c586b82691736be2a30c21e07a893856b1c9a02f432bcce00a123219bd857e988bc477ea7 ktimer-19.08.2.tar.xz"
+sha512sums="da075774292f911cdfbc28d3ce76b53cf6e9c3a91ff42c8b18334e8c680a87d08e3f22faf9b646342a7318c7096ed14de740e9e3558a71aed6ca7449b6d11358 ktimer-19.12.3.tar.xz"