summaryrefslogtreecommitdiff
path: root/user/ktouch/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/ktouch/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/ktouch/APKBUILD')
-rw-r--r--user/ktouch/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/ktouch/APKBUILD b/user/ktouch/APKBUILD
index 5917a97cc..f54a8937b 100644
--- a/user/ktouch/APKBUILD
+++ b/user/ktouch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=ktouch
-pkgver=19.08.2
+pkgver=19.12.3
pkgrel=0
pkgdesc="Touch typing tutor"
url="https://www.kde.org/applications/education/ktouch/"
@@ -14,7 +14,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtxmlpatterns-dev
ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev
libx11-dev libxcb-dev libxkbfile-dev qt5-qtquickcontrols2-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/ktouch-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ktouch-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -27,7 +27,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
@@ -39,4 +39,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="46438ec9cb3c45dec0156c13fb780b87b3ce7c3f9272435f0d6b634db7955a1f9fb33384333d42c353f2ac1d91bd3adc725b2eb39b9de1345d7a95780c573fa6 ktouch-19.08.2.tar.xz"
+sha512sums="1a3dc798e5e5c8d63419fbc2d9a70e3f872f00527575dd04cd5a8770fce0412a5445cd57c8716b9a6d613a360895f1f1e269acd963fcb3ccc99161b4efb412c6 ktouch-19.12.3.tar.xz"