summaryrefslogtreecommitdiff
path: root/user/kwave
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-19 00:05:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-19 00:05:46 +0000
commitcc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4 (patch)
tree5615e599278a678ac233adcd437c8eed67070914 /user/kwave
parenta7f03fc523db2f305ffd73220b12fb5a6bd2b3b6 (diff)
downloadpackages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.gz
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.bz2
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.xz
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.zip
user/[KDE Applications]: Update to 20.08.1
Diffstat (limited to 'user/kwave')
-rw-r--r--user/kwave/APKBUILD6
-rw-r--r--user/kwave/lts.patch191
2 files changed, 195 insertions, 2 deletions
diff --git a/user/kwave/APKBUILD b/user/kwave/APKBUILD
index 07d601e6e..e37a21052 100644
--- a/user/kwave/APKBUILD
+++ b/user/kwave/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kwave
-pkgver=20.04.3
+pkgver=20.08.1
pkgrel=0
pkgdesc="Sound editor built for KDE"
url="http://kwave.sourceforge.net/"
@@ -17,6 +17,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtmultimedia-dev
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/release-service/$pkgver/src/kwave-$pkgver.tar.xz
es-doc-fix.patch
+ lts.patch
remove-msgcat.patch
"
@@ -44,6 +45,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f57712472ba19695c77904a804c7dd599cc762e7018fed1d16398746156c25832795215d71aa54b143671342db6a1e442f79bfaed491e16657b820e14ac1306d kwave-20.04.3.tar.xz
+sha512sums="e5d53bdfce2953662ab25edb5c6c3886bb9d4dee6f15c7fb7c09f5a559c9b835bc0e7d6be62eca79c8db298c8e51646a3279c5e200ae3aa2117943d52692b0e1 kwave-20.08.1.tar.xz
63afd083727fd28436c2a8071429ba95fe4342c11669a4e27afc30b8a088b981f284fcff13861d5ef01a6f97152b25eec1fbeb303c9bdd76707e44ff5978dab8 es-doc-fix.patch
+8662f4b8cd374c4f54b0fb5d6ff2c5f8966056e688140ba7fc6fca74e79b72024e932392d93770e3e1b2387b54c33a67255b4c349d3c506660ec6dd55f933e98 lts.patch
43474f73281a7e3e97e2aa9e8c5b7aac50c8153c4ec09345a9ff43eb3c90a17c1dd9fbd2c630967ff87a5b21139f4efd0ecc44f36052549cc2036fd1db1dfac4 remove-msgcat.patch"
diff --git a/user/kwave/lts.patch b/user/kwave/lts.patch
new file mode 100644
index 000000000..ccac61359
--- /dev/null
+++ b/user/kwave/lts.patch
@@ -0,0 +1,191 @@
+--- kwave-20.08.1/CMakeLists.txt.old 2020-09-01 06:22:40.000000000 +0000
++++ kwave-20.08.1/CMakeLists.txt 2020-09-17 15:44:17.136338019 +0000
+@@ -87,7 +87,7 @@
+ ENDIF (POLICY CMP0075)
+
+ SET(ECM_MIN_VERSION "1.7.0")
+-SET(QT_MIN_VERSION "5.14.0")
++SET(QT_MIN_VERSION "5.12.9")
+ SET(KF5_MIN_VERSION "5.33.0")
+
+ #############################################################################
+--- kwave-20.08.1/libkwave/Filter.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/libkwave/Filter.cpp 2020-09-17 15:49:02.775161648 +0000
+@@ -147,9 +147,9 @@
+ file.open(QIODevice::WriteOnly);
+ QTextStream out(&file);
+
+- out << ((m_fir) ? "FIR " : "IIR ") << count() << Qt::endl;
++ out << ((m_fir) ? "FIR " : "IIR ") << count() << endl;
+ for (unsigned int i = 0; i < count(); i++) {
+- out << m_delay[i] << ' ' << m_coeff[i] << Qt::endl;
++ out << m_delay[i] << ' ' << m_coeff[i] << endl;
+ }
+
+ file.close();
+--- kwave-20.08.1/libkwave/Logger.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/libkwave/Logger.cpp 2020-09-17 15:47:40.384154307 +0000
+@@ -89,14 +89,14 @@
+ QTextStream out(m_logfile);
+ const KAboutData about_data = KAboutData::applicationData();
+
+- out << "#Version: 1.0" << Qt::endl;
+- out << "#Fields: x-status date time x-pid x-message" << Qt::endl;
++ out << "#Version: 1.0" << endl;
++ out << "#Fields: x-status date time x-pid x-message" << endl;
+ out << "#Software: " << about_data.displayName() << " "
+- << about_data.version() << Qt::endl;
++ << about_data.version() << endl;
+ QDateTime now = QDateTime::currentDateTime();
+ out << "#Start-Date: "
+ << now.toString(_("yyyy-MM-dd hh:mm:ss"))
+- << Qt::endl;
++ << endl;
+
+ return true;
+ }
+@@ -135,7 +135,7 @@
+
+ out << "<" << x_status << "> " <<
+ now.toString(_("yyyy-MM-dd hh:mm:ss.zzz")) << " " <<
+- x_pid << " " << msg << Qt::endl;
++ x_pid << " " << msg << endl;
+ }
+
+ m_logfile->flush();
+--- kwave-20.08.1/libkwave/CodecBase.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/libkwave/CodecBase.cpp 2020-09-17 15:48:28.188936600 +0000
+@@ -51,7 +51,7 @@
+ const QString type_name = _(name);
+ if (type_name.contains(_(","))) {
+ // list of mime types -> call recursively for each of them
+- QStringList types = type_name.split(_(","), Qt::SkipEmptyParts);
++ QStringList types = type_name.split(_(","), QString::SkipEmptyParts);
+ foreach (const QString &mt, types) {
+ addMimeType(mt.trimmed().toUtf8().data(), description, patterns);
+ }
+@@ -66,7 +66,7 @@
+ // qWarning("mime type '%s' not registered, using built-in!", name);
+ type.name = type_name;
+ type.description = description;
+- type.patterns = _(patterns).split(_("; "), Qt::SkipEmptyParts);
++ type.patterns = _(patterns).split(_("; "), QString::SkipEmptyParts);
+ } else {
+ type.description = t.comment();
+ type.patterns = t.globPatterns();
+--- kwave-20.08.1/plugins/codec_mp3/MP3EncoderDialog.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/plugins/codec_mp3/MP3EncoderDialog.cpp 2020-09-17 15:55:34.602393880 +0000
+@@ -720,7 +720,7 @@
+ const QLatin1Char separator = QLatin1Char(':');
+ #endif
+ QStringList path =
+- _(qgetenv("PATH")).split(separator, Qt::SkipEmptyParts);
++ _(qgetenv("PATH")).split(separator, QString::SkipEmptyParts);
+
+ QFileInfo f(program);
+ QString d = f.path();
+--- kwave-20.08.1/plugins/codec_ascii/AsciiEncoder.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/plugins/codec_ascii/AsciiEncoder.cpp 2020-09-17 15:51:18.470350596 +0000
+@@ -100,10 +100,10 @@
+
+ // write out the default properties:
+ // sample rate, bits, tracks, length
+- m_dst << META_PREFIX << "'rate'=" << info.rate() << Qt::endl;
+- m_dst << META_PREFIX << "'tracks'=" << tracks << Qt::endl;
+- m_dst << META_PREFIX << "'bits'=" << bits << Qt::endl;
+- m_dst << META_PREFIX << "'length'=" << length << Qt::endl;
++ m_dst << META_PREFIX << "'rate'=" << info.rate() << endl;
++ m_dst << META_PREFIX << "'tracks'=" << tracks << endl;
++ m_dst << META_PREFIX << "'bits'=" << bits << endl;
++ m_dst << META_PREFIX << "'length'=" << length << endl;
+
+ // write out all other, non-standard properties that we have
+ QMap<Kwave::FileProperty, QVariant> properties = info.properties();
+@@ -121,7 +121,7 @@
+ // write the property
+ m_dst << META_PREFIX << "'" << info.name(p) << "'='"
+ << Kwave::Parser::escape(v.toString()).toUtf8()
+- << "'" << Qt::endl;
++ << "'" << endl;
+ }
+
+ // write out all labels
+@@ -130,7 +130,7 @@
+ m_dst << META_PREFIX << "'label["
+ << QString::number(label.pos()) << "]'='"
+ << Kwave::Parser::escape(label.name()).toUtf8()
+- << "'" << Qt::endl;
++ << "'" << endl;
+ }
+
+ sample_index_t rest = length;
+@@ -162,13 +162,13 @@
+ pos++;
+
+ // end of line
+- m_dst << Qt::endl;
++ m_dst << endl;
+ }
+
+ } while (false);
+
+ // end of file
+- m_dst << "# EOF " << Qt::endl << Qt::endl;
++ m_dst << "# EOF " << endl << endl;
+
+ m_dst.setDevice(Q_NULLPTR);
+ dst.close();
+--- kwave-20.08.1/plugins/record/RecordDialog.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/plugins/record/RecordDialog.cpp 2020-09-17 15:54:28.909564227 +0000
+@@ -412,7 +412,7 @@
+ foreach (QString dev_id, devices) {
+ QTreeWidgetItem *parent = Q_NULLPTR;
+
+- QStringList list = dev_id.split(_("||"), Qt::KeepEmptyParts);
++ QStringList list = dev_id.split(_("||"), QString::KeepEmptyParts);
+ foreach (QString token, list) {
+ QTreeWidgetItem *item = Q_NULLPTR;
+
+--- kwave-20.08.1/plugins/playback/PlayBackDialog.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/plugins/playback/PlayBackDialog.cpp 2020-09-17 15:54:58.066381771 +0000
+@@ -303,7 +303,7 @@
+ foreach (const QString &dev_id, devices) {
+ QTreeWidgetItem *parent = Q_NULLPTR;
+
+- QStringList list = dev_id.split(_("||"), Qt::KeepEmptyParts);
++ QStringList list = dev_id.split(_("||"), QString::KeepEmptyParts);
+ foreach (const QString &t, list) {
+ QString token(t);
+ QTreeWidgetItem *item = Q_NULLPTR;
+--- kwave-20.08.1/kwave/MainWidget.cpp.old 2020-08-31 18:36:59.000000000 +0000
++++ kwave-20.08.1/kwave/MainWidget.cpp 2020-09-17 15:53:26.496376603 +0000
+@@ -304,8 +304,8 @@
+
+ // process only wheel events on the signal and overview frame,
+ // not on the channel controls or scrollbars
+- if (!m_scroll_area.geometry().contains(event->position().toPoint()) &&
+- !m_overview->geometry().contains(event->position().toPoint()) )
++ if (!m_scroll_area.geometry().contains(event->pos()) &&
++ !m_overview->geometry().contains(event->pos()) )
+ {
+ event->ignore();
+ return;
+@@ -331,8 +331,7 @@
+ break;
+ case Qt::ControlModifier: {
+ // <Ctrl> + <WheelUp/Down> => zoom in/out
+- int x = qMax(m_signal_widget.mapToViewPort(
+- event->globalPosition().toPoint()), 0);
++ int x = qMax(m_signal_widget.mapToViewPort(event->globalPos()), 0);
+ if (event->angleDelta().ry() > 0)
+ executeCommand(_("view:zoom_in(%1)").arg(x));
+ else if (event->angleDelta().ry() < 0)
+@@ -1017,7 +1016,7 @@
+ const QString name = Kwave::Parser::escape(label.name());
+ out << _("label:add(") << pos;
+ if (name.length()) out << _(", ") << name;
+- out << _(")") << Qt::endl;
++ out << _(")") << endl;
+ }
+
+ file.close();