summaryrefslogtreecommitdiff
path: root/user/libbsd
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-17 21:02:15 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-17 21:02:15 +0000
commitedaf1c2e879dace6c96f695c2faf6d7e625f7300 (patch)
tree69bc283f5114a89c34025bdd7d7983b0fede487e /user/libbsd
parent9f98ca9bb20997aae345fa6e50d5189a3c41b385 (diff)
downloadpackages-edaf1c2e879dace6c96f695c2faf6d7e625f7300.tar.gz
packages-edaf1c2e879dace6c96f695c2faf6d7e625f7300.tar.bz2
packages-edaf1c2e879dace6c96f695c2faf6d7e625f7300.tar.xz
packages-edaf1c2e879dace6c96f695c2faf6d7e625f7300.zip
user/libbsd: bump to 0.10.0
Diffstat (limited to 'user/libbsd')
-rw-r--r--user/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch366
-rw-r--r--user/libbsd/APKBUILD15
-rw-r--r--user/libbsd/disable-fpurge-test.patch2
-rw-r--r--user/libbsd/headers.patch10
4 files changed, 4 insertions, 389 deletions
diff --git a/user/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch b/user/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
deleted file mode 100644
index 0d4007d09..000000000
--- a/user/libbsd/0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+++ /dev/null
@@ -1,366 +0,0 @@
-From 88adbe1a855b7aa95bd925c80ed83c86f3fc42e3 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 6 Nov 2016 09:39:31 -0800
-Subject: [PATCH 1/3] Replace __BEGIN_DECLS and __END_DECLS
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- include/bsd/err.h | 10 ++++++++--
- include/bsd/libutil.h | 10 ++++++++--
- include/bsd/md5.h | 10 ++++++++--
- include/bsd/nlist.h | 10 ++++++++--
- include/bsd/readpassphrase.h | 10 ++++++++--
- include/bsd/stdio.h | 10 ++++++++--
- include/bsd/stdlib.h | 10 ++++++++--
- include/bsd/string.h | 10 ++++++++--
- include/bsd/stringlist.h | 10 ++++++++--
- include/bsd/unistd.h | 10 ++++++++--
- include/bsd/vis.h | 10 ++++++++--
- include/bsd/wchar.h | 10 ++++++++--
- src/hash/sha512.h | 10 ++++++++--
- 13 files changed, 104 insertions(+), 26 deletions(-)
-
-diff --git a/include/bsd/err.h b/include/bsd/err.h
-index 12fd051..43dfc32 100644
---- a/include/bsd/err.h
-+++ b/include/bsd/err.h
-@@ -42,7 +42,10 @@
-
- #include <stdarg.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- void warnc(int code, const char *format, ...)
- __printflike(2, 3);
- void vwarnc(int code, const char *format, va_list ap)
-@@ -51,6 +54,9 @@ void errc(int status, int code, const char *format, ...)
- __printflike(3, 4);
- void verrc(int status, int code, const char *format, va_list ap)
- __printflike(3, 0);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
-diff --git a/include/bsd/libutil.h b/include/bsd/libutil.h
-index ebb6160..28b919d 100644
---- a/include/bsd/libutil.h
-+++ b/include/bsd/libutil.h
-@@ -53,7 +53,10 @@ struct pidfh {
- ino_t pf_ino;
- };
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- int humanize_number(char *buf, size_t len, int64_t bytes,
- const char *suffix, int scale, int flags);
- int expand_number(const char *_buf, uint64_t *_num);
-@@ -66,7 +69,10 @@ int pidfile_close(struct pidfh *pfh);
- int pidfile_remove(struct pidfh *pfh);
-
- char *fparseln(FILE *, size_t *, size_t *, const char[3], int);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- /* humanize_number(3) */
- #define HN_DECIMAL 0x01
-diff --git a/include/bsd/md5.h b/include/bsd/md5.h
-index 9a75fad..3531fd6 100644
---- a/include/bsd/md5.h
-+++ b/include/bsd/md5.h
-@@ -30,7 +30,10 @@ typedef struct MD5Context {
- #include <sys/cdefs.h>
- #include <sys/types.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- void MD5Init(MD5_CTX *);
- void MD5Update(MD5_CTX *, const uint8_t *, size_t)
- __attribute__((__bounded__(__string__,2,3)));
-@@ -49,6 +52,9 @@ char *MD5FileChunk(const char *, char *, off_t, off_t)
- char *MD5Data(const uint8_t *, size_t, char *)
- __attribute__((__bounded__(__string__,1,2)))
- __attribute__((__bounded__(__minbytes__,3,MD5_DIGEST_STRING_LENGTH)));
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif /* _MD5_H_ */
-diff --git a/include/bsd/nlist.h b/include/bsd/nlist.h
-index 2730237..0389ab7 100644
---- a/include/bsd/nlist.h
-+++ b/include/bsd/nlist.h
-@@ -30,8 +30,14 @@
- #include <sys/cdefs.h>
- #include <a.out.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- extern int nlist(const char *filename, struct nlist *list);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
-diff --git a/include/bsd/readpassphrase.h b/include/bsd/readpassphrase.h
-index e1dacc3..76e0d33 100644
---- a/include/bsd/readpassphrase.h
-+++ b/include/bsd/readpassphrase.h
-@@ -34,8 +34,14 @@
- #include <sys/cdefs.h>
- #include <sys/types.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- char * readpassphrase(const char *, char *, size_t, int);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif /* !_READPASSPHRASE_H_ */
-diff --git a/include/bsd/stdio.h b/include/bsd/stdio.h
-index 7697425..b5b3efd 100644
---- a/include/bsd/stdio.h
-+++ b/include/bsd/stdio.h
-@@ -41,7 +41,10 @@
- #include <sys/cdefs.h>
- #include <sys/types.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- const char *fmtcheck(const char *, const char *);
-
- /* XXX: The function requires cooperation from the system libc to store the
-@@ -69,7 +72,10 @@ FILE *funopen(const void *cookie,
- #define fwopen(cookie, fn) funopen(cookie, NULL, fn, NULL, NULL)
-
- int fpurge(FILE *fp);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
- #endif
-diff --git a/include/bsd/stdlib.h b/include/bsd/stdlib.h
-index 0604cad..b9f0515 100644
---- a/include/bsd/stdlib.h
-+++ b/include/bsd/stdlib.h
-@@ -46,7 +46,10 @@
- #include <sys/stat.h>
- #include <stdint.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- uint32_t arc4random(void);
- void arc4random_stir(void);
- void arc4random_addrandom(u_char *dat, int datlen);
-@@ -73,6 +76,9 @@ long long strtonum(const char *nptr, long long minval, long long maxval,
- const char **errstr);
-
- char *getbsize(int *headerlenp, long *blocksizep);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
-diff --git a/include/bsd/string.h b/include/bsd/string.h
-index ee2f953..fbf8c54 100644
---- a/include/bsd/string.h
-+++ b/include/bsd/string.h
-@@ -36,16 +36,22 @@
- #include <sys/cdefs.h>
- #include <sys/types.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- size_t strlcpy(char *dst, const char *src, size_t siz);
- size_t strlcat(char *dst, const char *src, size_t siz);
- char *strnstr(const char *str, const char *find, size_t str_len);
- void strmode(mode_t mode, char *str);
-
- #if !defined(__GLIBC__) || \
- (defined(__GLIBC__) && (!__GLIBC_PREREQ(2, 25) || !defined(_GNU_SOURCE)))
- void explicit_bzero(void *buf, size_t len);
- #endif
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
-diff --git a/include/bsd/stringlist.h b/include/bsd/stringlist.h
-index e3c42e9..40d0a52 100644
---- a/include/bsd/stringlist.h
-+++ b/include/bsd/stringlist.h
-@@ -43,12 +43,18 @@ typedef struct _stringlist {
- size_t sl_cur;
- } StringList;
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- StringList *sl_init(void);
- int sl_add(StringList *, char *);
- void sl_free(StringList *, int);
- char *sl_find(StringList *, const char *);
- int sl_delete(StringList *, const char *, int);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif /* _STRINGLIST_H */
-diff --git a/include/bsd/unistd.h b/include/bsd/unistd.h
-index 1f9c5f8..5b2f4c7 100644
---- a/include/bsd/unistd.h
-+++ b/include/bsd/unistd.h
-@@ -45,7 +45,10 @@
- #define S_ISTXT S_ISVTX
- #endif
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- extern int optreset;
-
- #ifdef LIBBSD_OVERLAY
-@@ -68,6 +71,9 @@ void setproctitle(const char *fmt, ...)
- __printflike(1, 2);
-
- int getpeereid(int s, uid_t *euid, gid_t *egid);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
-diff --git a/include/bsd/vis.h b/include/bsd/vis.h
-index 835d2d6..63c951e 100644
---- a/include/bsd/vis.h
-+++ b/include/bsd/vis.h
-@@ -74,7 +74,10 @@
-
- #include <sys/cdefs.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- char *vis(char *, int, int, int);
- int strvis(char *, const char *, int);
- int strvisx(char *, const char *, size_t, int);
-@@ -83,6 +86,9 @@ int strunvis(char *, const char *);
- int strunvisx(char *, const char *, int);
- ssize_t strnunvis(char *, const char *, size_t);
- int unvis(char *, int, int *, int);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif /* !_VIS_H_ */
-diff --git a/include/bsd/wchar.h b/include/bsd/wchar.h
-index 33a500e..aa70742 100644
---- a/include/bsd/wchar.h
-+++ b/include/bsd/wchar.h
-@@ -43,12 +43,18 @@
- #include <sys/cdefs.h>
- #include <sys/types.h>
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- wchar_t *fgetwln(FILE *stream, size_t *len);
-
- size_t wcslcat(wchar_t *dst, const wchar_t *src, size_t size);
- size_t wcslcpy(wchar_t *dst, const wchar_t *src, size_t size);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif
- #endif
-diff --git a/src/hash/sha512.h b/src/hash/sha512.h
-index 4f368a1..27ddc24 100644
---- a/src/hash/sha512.h
-+++ b/src/hash/sha512.h
-@@ -39,7 +39,10 @@ typedef struct SHA512Context {
- unsigned char buf[128];
- } SHA512_CTX;
-
--__BEGIN_DECLS
-+/* __BEGIN_DECLS */
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-
- void SHA512_Init(SHA512_CTX *);
- void SHA512_Update(SHA512_CTX *, const void *, size_t);
-@@ -48,6 +51,9 @@ char *SHA512_End(SHA512_CTX *, char *);
- char *SHA512_File(const char *, char *);
- char *SHA512_FileChunk(const char *, char *, off_t, off_t);
- char *SHA512_Data(const void *, unsigned int, char *);
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+/* __END_DECLS */
-
- #endif /* !_SHA512_H_ */
---
-2.10.2
-
diff --git a/user/libbsd/APKBUILD b/user/libbsd/APKBUILD
index 3c5cb2cf1..283eaa63c 100644
--- a/user/libbsd/APKBUILD
+++ b/user/libbsd/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libbsd
-pkgver=0.9.1
+pkgver=0.10.0
pkgrel=0
pkgdesc="Commonly used BSD functions not implemented by all libcs"
url="https://libbsd.freedesktop.org/"
@@ -13,20 +13,15 @@ depends_dev="bsd-compat-headers linux-headers"
makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="https://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
- 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
disable-fpurge-test.patch
- headers.patch
"
prepare() {
default_prepare
-
- cd "$builddir"
autoreconf -fi
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,16 +34,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="435822b8f2495a5e2705e5ab5c834a4f0f3a177b3e5c46a7c6162924507ca984e957e94a512b5ebd0067ecb413bac458fade357709ef199e9b75edf0315de91c libbsd-0.9.1.tar.xz
-5a3302601e9534ce8493122b20cc53fe320e0d884ca4abf041a8d151175c076e26ac9ef521c65b1654ea2295bd0251b70b0bdc80ed8a03c98777aab8502719ca 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
-34ab57a9b67c0d6035312dff78e6dd0d1c48442c6a1b6e769b6ebb6dccb0dac80ccc2c309724e39c097cdac944bdbd9522582f93f2567da8c6615990e2d0238b disable-fpurge-test.patch
-594d598bc7f6d34bff080a26f8d726bf779d3827423f242ee7caa9a58fc89c89d80e0677c03e9c640e0074afbdc34636fa8ffa47a99fd9c576845e3039a7ccbd headers.patch"
+sha512sums="b75529785b16c93d31401187f8a58258fbebe565dac071c8311775c913af989f62cd29d5ce2651af3ea6221cffd31cf04826577d3e546ab9ca14340f297777b9 libbsd-0.10.0.tar.xz
+424828e759420afbf2d4b97f5d402be9b3d51cb90241da1f047517bb75048255ea6cbbbc1e98bffa67449a7f48efe00d8f99b38bdaac9e8c461d1e989e9697b7 disable-fpurge-test.patch"
diff --git a/user/libbsd/disable-fpurge-test.patch b/user/libbsd/disable-fpurge-test.patch
index 2a1950b12..ef6241f62 100644
--- a/user/libbsd/disable-fpurge-test.patch
+++ b/user/libbsd/disable-fpurge-test.patch
@@ -1,6 +1,6 @@
--- libbsd-0.8.3/test/Makefile.am.old 2017-08-17 02:42:30.045825258 +0000
+++ libbsd-0.8.3/test/Makefile.am 2017-08-17 03:49:17.928202106 +0000
-@@ -37,7 +37,6 @@
+@@ -38,7 +38,6 @@
humanize \
fgetln \
fparseln \
diff --git a/user/libbsd/headers.patch b/user/libbsd/headers.patch
deleted file mode 100644
index 5b8f26425..000000000
--- a/user/libbsd/headers.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- libbsd-0.9.1/src/flopen.c.old 2018-05-21 02:33:33.000000000 +0000
-+++ libbsd-0.9.1/src/flopen.c 2018-09-09 17:43:59.850000000 +0000
-@@ -32,6 +32,7 @@
- #include <sys/stat.h>
-
- #include <errno.h>
-+#include <fcntl.h>
- #include <stdarg.h>
- #include <unistd.h>
-