summaryrefslogtreecommitdiff
path: root/user/libdca
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-05 17:52:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-05 17:52:29 -0500
commite1e2a3487f1b419a755b9fa36d134e279be1ea1b (patch)
tree9c5d45a9f87bf789c9277a7e5f62eb3257865f49 /user/libdca
parentaa767e5ded8cb36c531afed39c2107a7901a6de2 (diff)
downloadpackages-e1e2a3487f1b419a755b9fa36d134e279be1ea1b.tar.gz
packages-e1e2a3487f1b419a755b9fa36d134e279be1ea1b.tar.bz2
packages-e1e2a3487f1b419a755b9fa36d134e279be1ea1b.tar.xz
packages-e1e2a3487f1b419a755b9fa36d134e279be1ea1b.zip
user/libdca: new package
Diffstat (limited to 'user/libdca')
-rw-r--r--user/libdca/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/user/libdca/APKBUILD b/user/libdca/APKBUILD
new file mode 100644
index 000000000..9047074dc
--- /dev/null
+++ b/user/libdca/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libdca
+pkgver=0.0.5
+pkgrel=0
+pkgdesc="Free DTS Coherent Acoustics decoder"
+url="https://www.videolan.org/developers/libdca.html"
+arch="all"
+license="GPL-2.0+"
+depends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.videolan.org/pub/videolan/libdca/$pkgver/libdca-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d9f0ed34efeb3f27af8424fcb3e6df56744c6735854a65b5709c02b42b4513b9c4618dcc19eb44293afa051bd95616651bda5fc3b49dfabe975d0babfb1bc287 libdca-0.0.5.tar.bz2"