summaryrefslogtreecommitdiff
path: root/user/libdvbpsi
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 02:49:47 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 02:49:47 -0500
commit1f2cc9ebe28e0a6418d243aa551c6e0cb544e79c (patch)
tree3a23c4e131f4822baeb50368b3aa01cbb37767d0 /user/libdvbpsi
parent830b3ff955c18c4cfc65135e293b47ab85eeab5f (diff)
downloadpackages-1f2cc9ebe28e0a6418d243aa551c6e0cb544e79c.tar.gz
packages-1f2cc9ebe28e0a6418d243aa551c6e0cb544e79c.tar.bz2
packages-1f2cc9ebe28e0a6418d243aa551c6e0cb544e79c.tar.xz
packages-1f2cc9ebe28e0a6418d243aa551c6e0cb544e79c.zip
user/libdvbpsi: pull in, modernise, bump to 1.3.2
Diffstat (limited to 'user/libdvbpsi')
-rw-r--r--user/libdvbpsi/APKBUILD37
-rw-r--r--user/libdvbpsi/fix-includes.patch24
2 files changed, 61 insertions, 0 deletions
diff --git a/user/libdvbpsi/APKBUILD b/user/libdvbpsi/APKBUILD
new file mode 100644
index 000000000..9f818977d
--- /dev/null
+++ b/user/libdvbpsi/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer:
+pkgname=libdvbpsi
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Library decoding and generating MPEG TS and DVB PSI tables"
+url="https://www.videolan.org/developers/libdvbpsi.html"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="https://download.videolan.org/pub/libdvbpsi/$pkgver/$pkgname-$pkgver.tar.bz2
+ fix-includes.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-release
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="cb59c2e66a214cad7bb96aa1f80a178399fcd80da9fc05b22c72763f2cd818bfab3724d36eee4c6467fb8bc8bae18b1d8afec64c02e8e47cd7a6e887f0230309 libdvbpsi-1.3.2.tar.bz2
+f612bf80b07ec37a83477a37d78971c4bd4331eec86686a8bc7b247f43df2c047c89de419d5cef0b960de2032daedc81a4c380802c76b4dc081e1c09ad364dcb fix-includes.patch"
diff --git a/user/libdvbpsi/fix-includes.patch b/user/libdvbpsi/fix-includes.patch
new file mode 100644
index 000000000..9fbdc8455
--- /dev/null
+++ b/user/libdvbpsi/fix-includes.patch
@@ -0,0 +1,24 @@
+--- libdvbpsi-1.1.1.orig/examples/dvbinfo/buffer.h
++++ libdvbpsi-1.1.1/examples/dvbinfo/buffer.h
+@@ -23,6 +23,9 @@
+ #ifndef DVBINFO_BUFFER_H_
+ #define DVBINFO_BUFFER_H_
+
++#include <sys/types.h>
++#include <stdint.h>
++
+ typedef struct buffer_s buffer_t;
+
+ struct buffer_s
+--- libdvbpsi-1.1.1.orig/src/descriptor.h
++++ libdvbpsi-1.1.1/src/descriptor.h
+@@ -35,6 +35,9 @@
+ #ifndef _DVBPSI_DESCRIPTOR_H_
+ #define _DVBPSI_DESCRIPTOR_H_
+
++#include <sys/types.h>
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif