summaryrefslogtreecommitdiff
path: root/user/libexif
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-06-15 15:25:50 -0500
committerMax Rees <maxcrees@me.com>2020-06-15 15:25:50 -0500
commit29e941e719283d2570dc67038722d6ea6c19874e (patch)
tree9af01b398b77f5e98845d1e9fff434067d6c997b /user/libexif
parent8c8498bd45cbacc5d0436c9ac5cdd64b3d960405 (diff)
downloadpackages-29e941e719283d2570dc67038722d6ea6c19874e.tar.gz
packages-29e941e719283d2570dc67038722d6ea6c19874e.tar.bz2
packages-29e941e719283d2570dc67038722d6ea6c19874e.tar.xz
packages-29e941e719283d2570dc67038722d6ea6c19874e.zip
user/libexif: patch CVE-2020-0198 (#285)
Diffstat (limited to 'user/libexif')
-rw-r--r--user/libexif/APKBUILD9
-rw-r--r--user/libexif/CVE-2020-0198.patch58
2 files changed, 65 insertions, 2 deletions
diff --git a/user/libexif/APKBUILD b/user/libexif/APKBUILD
index 8dd3ff715..320b87492 100644
--- a/user/libexif/APKBUILD
+++ b/user/libexif/APKBUILD
@@ -10,7 +10,9 @@ license="LGPL-2.0+"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
depends=""
makedepends=""
-source="https://github.com/libexif/libexif/releases/download/libexif-$_pkgver-release/libexif-$pkgver.tar.xz"
+source="https://github.com/libexif/libexif/releases/download/libexif-$_pkgver-release/libexif-$pkgver.tar.xz
+ CVE-2020-0198.patch
+ "
# secfixes:
# 0.6.21-r3:
@@ -21,6 +23,8 @@ source="https://github.com/libexif/libexif/releases/download/libexif-$_pkgver-re
# - CVE-2019-9278
# 0.6.22-r0:
# - CVE-2020-0093
+# - CVE-2020-0182
+# - CVE-2020-0198
# - CVE-2020-12767
# - CVE-2020-13112
# - CVE-2020-13113
@@ -47,4 +51,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0a9e7bf0258ed98a794b667d45e8fc65299101a2a2d2e39c358715b20b003beff258782f0736cd5b53978428a2f878a989f303bee249a978850a065f33c534af libexif-0.6.22.tar.xz"
+sha512sums="0a9e7bf0258ed98a794b667d45e8fc65299101a2a2d2e39c358715b20b003beff258782f0736cd5b53978428a2f878a989f303bee249a978850a065f33c534af libexif-0.6.22.tar.xz
+7df084f9acdc09bd05fadfb66332956d8587fcaac9d693000f47fadeba17b3c49eafa402d1e2c9b7d394e697feccd1f760bab8b64378deaea1777c5a3b90c3b2 CVE-2020-0198.patch"
diff --git a/user/libexif/CVE-2020-0198.patch b/user/libexif/CVE-2020-0198.patch
new file mode 100644
index 000000000..e0358c220
--- /dev/null
+++ b/user/libexif/CVE-2020-0198.patch
@@ -0,0 +1,58 @@
+From ce03ad7ef4e8aeefce79192bf5b6f69fae396f0c Mon Sep 17 00:00:00 2001
+From: Marcus Meissner <marcus@jet.franken.de>
+Date: Mon, 8 Jun 2020 17:27:06 +0200
+Subject: [PATCH] fixed another unsigned integer overflow
+
+first fixed by google in android fork,
+https://android.googlesource.com/platform/external/libexif/+/1e187b62682ffab5003c702657d6d725b4278f16%5E%21/#F0
+
+(use a more generic overflow check method, also check second overflow instance.)
+
+https://security-tracker.debian.org/tracker/CVE-2020-0198
+---
+ libexif/exif-data.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/libexif/exif-data.c b/libexif/exif-data.c
+index 8b280d3..b495726 100644
+--- a/libexif/exif-data.c
++++ b/libexif/exif-data.c
+@@ -47,6 +47,8 @@
+ #undef JPEG_MARKER_APP1
+ #define JPEG_MARKER_APP1 0xe1
+
++#define CHECKOVERFLOW(offset,datasize,structsize) (( offset >= datasize) || (structsize > datasize) || (offset > datasize - structsize ))
++
+ static const unsigned char ExifHeader[] = {0x45, 0x78, 0x69, 0x66, 0x00, 0x00};
+
+ struct _ExifDataPrivate
+@@ -327,7 +329,7 @@ exif_data_load_data_thumbnail (ExifData *data, const unsigned char *d,
+ exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData", "Bogus thumbnail offset (%u).", o);
+ return;
+ }
+- if (s > ds - o) {
++ if (CHECKOVERFLOW(o,ds,s)) {
+ exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData", "Bogus thumbnail size (%u), max would be %u.", s, ds-o);
+ return;
+ }
+@@ -420,9 +422,9 @@ exif_data_load_data_content (ExifData *data, ExifIfd ifd,
+ }
+
+ /* Read the number of entries */
+- if ((offset + 2 < offset) || (offset + 2 < 2) || (offset + 2 > ds)) {
++ if (CHECKOVERFLOW(offset, ds, 2)) {
+ exif_log (data->priv->log, EXIF_LOG_CODE_CORRUPT_DATA, "ExifData",
+- "Tag data past end of buffer (%u > %u)", offset+2, ds);
++ "Tag data past end of buffer (%u+2 > %u)", offset, ds);
+ return;
+ }
+ n = exif_get_short (d + offset, data->priv->order);
+@@ -431,7 +433,7 @@ exif_data_load_data_content (ExifData *data, ExifIfd ifd,
+ offset += 2;
+
+ /* Check if we have enough data. */
+- if (offset + 12 * n > ds) {
++ if (CHECKOVERFLOW(offset, ds, 12*n)) {
+ n = (ds - offset) / 12;
+ exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData",
+ "Short data; only loading %hu entries...", n);