summaryrefslogtreecommitdiff
path: root/user/libfakekey
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-07 02:40:53 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-07 02:40:53 +0000
commitfb406132ea3e792279435d801dc4da23dc8294ee (patch)
tree3bee626f3474a7ae5870783dff7ee8dda05c5a7c /user/libfakekey
parentcbd19047ab4d7db5f86056d8b71fbc22176cc987 (diff)
downloadpackages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.gz
packages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.bz2
packages-fb406132ea3e792279435d801dc4da23dc8294ee.tar.xz
packages-fb406132ea3e792279435d801dc4da23dc8294ee.zip
user/*: Modernise / fix syntax / deps
Also, take APR
Diffstat (limited to 'user/libfakekey')
-rw-r--r--user/libfakekey/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/user/libfakekey/APKBUILD b/user/libfakekey/APKBUILD
index decd8540e..af08c494c 100644
--- a/user/libfakekey/APKBUILD
+++ b/user/libfakekey/APKBUILD
@@ -3,23 +3,21 @@
pkgname=libfakekey
pkgver=0.3
pkgrel=0
-pkgdesc="Library for faking X key-presses from character inputs"
+pkgdesc="Library for faking X11 key presses from character inputs"
url="https://www.yoctoproject.org/software-item/matchbox/"
arch="all"
license="LGPL-2.0+"
depends=""
-makedepends="libx11-dev libxtst-dev"
+makedepends="autoconf automake libtool libx11-dev libxtst-dev"
subpackages="$pkgname-dev"
source="http://git.yoctoproject.org/cgit.cgi/libfakekey/snapshot/libfakekey-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
LIBS="-lX11" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}