summaryrefslogtreecommitdiff
path: root/user/libfm-qt
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2019-01-27 02:56:12 -0600
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2019-01-27 08:55:17 -0600
commit7d266e01ae552facbf13ee5e425cb5735d2c4463 (patch)
tree1e84f0ac25927b0f3f1e7d2ed538f9e1f468d151 /user/libfm-qt
parent349f229521ad05dcd5d7142be32a36e2b21e65f4 (diff)
downloadpackages-7d266e01ae552facbf13ee5e425cb5735d2c4463.tar.gz
packages-7d266e01ae552facbf13ee5e425cb5735d2c4463.tar.bz2
packages-7d266e01ae552facbf13ee5e425cb5735d2c4463.tar.xz
packages-7d266e01ae552facbf13ee5e425cb5735d2c4463.zip
user/libfm-qt: upgrade to 0.14.0
Diffstat (limited to 'user/libfm-qt')
-rw-r--r--user/libfm-qt/APKBUILD6
-rw-r--r--user/libfm-qt/libfm-qt-0.11.2-const-fixes.patch22
2 files changed, 3 insertions, 25 deletions
diff --git a/user/libfm-qt/APKBUILD b/user/libfm-qt/APKBUILD
index 13869d231..2035a8679 100644
--- a/user/libfm-qt/APKBUILD
+++ b/user/libfm-qt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libfm-qt
-pkgver=0.13.1
+pkgver=0.14.0
pkgrel=0
pkgdesc="Qt library for file management and bindings for libfm"
url="https://lxqt.org"
@@ -9,7 +9,7 @@ arch="all"
license="LGPL-2.1+"
depends=""
depends_dev="libfm-dev menu-cache-dev libexif-dev"
-makedepends="cmake extra-cmake-modules lxqt-build-tools>=0.5.0 qt5-qttools-dev
+makedepends="cmake extra-cmake-modules lxqt-build-tools>=0.6.0 qt5-qttools-dev
qt5-qtx11extras-dev $depends_dev"
subpackages="$pkgname-dev"
source="https://github.com/lxqt/libfm-qt/releases/download/$pkgver/libfm-qt-$pkgver.tar.xz"
@@ -42,4 +42,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="29b8f686950a7b0ea86468d01ca64a6ff8316ccd5f0144808a4332692cf96199431470880a9b560780efeba7add833ab6a0d9b4b24220f8fb7091cc5ef151dc8 libfm-qt-0.13.1.tar.xz"
+sha512sums="2d496f3963dd7e7a433ec16c87ca4682c1fb1564b935499bbeee354f09cbf2a0dcdeab2609e9429e87035731ea9f0a9c64c0bcec55be2eb92f806067d6d2e02a libfm-qt-0.14.0.tar.xz"
diff --git a/user/libfm-qt/libfm-qt-0.11.2-const-fixes.patch b/user/libfm-qt/libfm-qt-0.11.2-const-fixes.patch
deleted file mode 100644
index f9732fce2..000000000
--- a/user/libfm-qt/libfm-qt-0.11.2-const-fixes.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- libfm-qt-0.11.2/src/folderview.cpp.old 2016-12-21 11:44:23.000000000 -0600
-+++ libfm-qt-0.11.2/src/folderview.cpp 2017-10-12 19:33:06.121769699 -0500
-@@ -727,7 +727,7 @@
- if(!selIndexes.isEmpty()) {
- PathList paths;
- QModelIndexList::const_iterator it;
-- for(it = selIndexes.begin(); it != selIndexes.end(); ++it) {
-+ for(it = selIndexes.constBegin(); it != selIndexes.constEnd(); ++it) {
- FmFileInfo* file = model_->fileInfoFromIndex(*it);
- paths.pushTail(fm_file_info_get_path(file));
- }
---- libfm-qt-0.11.2/src/utilities.cpp.old 2016-12-21 11:44:23.000000000 -0600
-+++ libfm-qt-0.11.2/src/utilities.cpp 2017-10-12 19:39:07.683967576 -0500
-@@ -40,7 +40,7 @@
- QList<QUrl>::const_iterator it;
- FmPathList* pathList = fm_path_list_new();
-
-- for(it = urls.begin(); it != urls.end(); ++it) {
-+ for(it = urls.constBegin(); it != urls.constEnd(); ++it) {
- QUrl url = *it;
- FmPath* path = fm_path_new_for_uri(url.toString().toUtf8());
- fm_path_list_push_tail(pathList, path);