summaryrefslogtreecommitdiff
path: root/user/libgnt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-06 23:20:02 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-06 23:20:02 +0000
commit9fb33f7de3fd9052f575c060d3d6e657abe537ee (patch)
tree83333212294bca9d07c22b42ebb1c91a3a7b5662 /user/libgnt
parent99396fd6b2cdd269fef8522aebcfa694d0f32fd3 (diff)
downloadpackages-9fb33f7de3fd9052f575c060d3d6e657abe537ee.tar.gz
packages-9fb33f7de3fd9052f575c060d3d6e657abe537ee.tar.bz2
packages-9fb33f7de3fd9052f575c060d3d6e657abe537ee.tar.xz
packages-9fb33f7de3fd9052f575c060d3d6e657abe537ee.zip
user/libgnt: New package
Diffstat (limited to 'user/libgnt')
-rw-r--r--user/libgnt/APKBUILD37
-rw-r--r--user/libgnt/tinfo.patch18
2 files changed, 55 insertions, 0 deletions
diff --git a/user/libgnt/APKBUILD b/user/libgnt/APKBUILD
new file mode 100644
index 000000000..bd4b921c4
--- /dev/null
+++ b/user/libgnt/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libgnt
+pkgver=2.14.0
+pkgrel=0
+pkgdesc="Glib Ncurses Toolkit"
+url="https://pidgin.im/"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="glib-dev gtk-doc meson ncurses-dev ninja"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/pidgin/libgnt-$pkgver.tar.xz
+ tinfo.patch
+ "
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="0d9c5550374696a0e6ede5246cda3c372d7055d21b9ffaf10be88d6a469bdf18c7dd1113ec612acf4889c0e5686ea87bb0e8348ca8985fd5ff8913afc5813b38 libgnt-2.14.0.tar.xz
+56ce8dab03e74714ecfe0cb7dd274c5fce996d84793fff5e247ee329b1c5bebf2d933b96cc6fe916dafb4f402269d3b1b8cacda07deff4c149869d509ee5c416 tinfo.patch"
diff --git a/user/libgnt/tinfo.patch b/user/libgnt/tinfo.patch
new file mode 100644
index 000000000..1e4ab4902
--- /dev/null
+++ b/user/libgnt/tinfo.patch
@@ -0,0 +1,18 @@
+--- libgnt-2.14.0/meson.build
++++ libgnt-2.14.0/meson.build
+@@ -72,6 +72,7 @@
+ ncurses_available = true
+ ncurses_inc = []
+ ncurses_libs = [
++ compiler.find_library('tinfow', required : false),
+ compiler.find_library('ncursesw', required : false),
+ compiler.find_library('panelw', required : false)
+ ]
+@@ -113,6 +114,7 @@
+ else
+ # ncursesw was not found. Look for plain old ncurses
+ ncurses_libs = [
++ compiler.find_library('tinfo', required : false),
+ compiler.find_library('ncurses', required : false),
+ compiler.find_library('panel', required : false)
+ ]