summaryrefslogtreecommitdiff
path: root/user/libinput
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-26 02:40:52 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-26 02:40:52 +0000
commit5751afad2204f090323ea37034c9cb345086fd3f (patch)
tree55db1aae68c13399d0cf28fdb59fec048b50c9c2 /user/libinput
parentd56f2dece4de462cf1f6d57f4c45c2c8a0381393 (diff)
downloadpackages-5751afad2204f090323ea37034c9cb345086fd3f.tar.gz
packages-5751afad2204f090323ea37034c9cb345086fd3f.tar.bz2
packages-5751afad2204f090323ea37034c9cb345086fd3f.tar.xz
packages-5751afad2204f090323ea37034c9cb345086fd3f.zip
user/libinput: Bump to 1.15.2
Diffstat (limited to 'user/libinput')
-rw-r--r--user/libinput/APKBUILD12
-rw-r--r--user/libinput/time64.patch49
2 files changed, 5 insertions, 56 deletions
diff --git a/user/libinput/APKBUILD b/user/libinput/APKBUILD
index 584fbf44a..21aeed83d 100644
--- a/user/libinput/APKBUILD
+++ b/user/libinput/APKBUILD
@@ -1,21 +1,20 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libinput
-pkgver=1.15.0
+pkgver=1.15.2
pkgrel=0
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput/"
arch="all"
options="!check" # wow, such broken
license="MIT"
+depends=""
+checkdepends="check-dev valgrind"
makedepends="doxygen eudev-dev graphviz libevdev-dev libwacom-dev meson
mtdev-dev ninja py3-recommonmark py3-sphinx py3-sphinx-rtd-theme"
-checkdepends="check-dev valgrind"
subpackages="$pkgname-dev $pkgname-doc"
replaces="$pkgname-libs"
-source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
- time64.patch
- "
+source="https://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
meson --prefix=/usr \
@@ -33,5 +32,4 @@ package() {
DESTDIR="$pkgdir" ninja -C builddir/ install
}
-sha512sums="5dab48e1b4c9c0deb5b01ebc3ccb4cc28d614be25d87daaf42f51fbd2d955266f3fdba73029bc0094caa55060dad8967751b72d8f45f19a40b542f0c9118c1b6 libinput-1.15.0.tar.xz
-e4c898359c8264651b0d0a795c05ccfebcd24e44c7b2dbad8a2bce2c0da6138288e0be93bd68e4b61cc0fb56e9a46ad5c4b670f3f88e493b8a7993020f1d2c61 time64.patch"
+sha512sums="f6b50dbdf6ee6b65f88e020c4292c94c3178125d58629f27c2e52f92b658ccd67e0c5604fbf0b303621ff0386637ce1e291daaa991761d4145e8bcda4dd128a2 libinput-1.15.2.tar.xz"
diff --git a/user/libinput/time64.patch b/user/libinput/time64.patch
deleted file mode 100644
index 47833b6ee..000000000
--- a/user/libinput/time64.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 2e15e1f56d673626d518760c1b7997543bb01fea Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sun, 19 Jan 2020 16:01:57 -0600
-Subject: [PATCH] evdev-fallback: Use input_event_init for fallback
-
-Old-style field initialisation ignores the 64-bit time_t change in
-Linux UAPI, which causes the structure to be incompletely initialised
-on 32-bit systems with the 64-bit time_t kernel headers.
-
-This patch uses the input_event_init helper from the original 64-bit
-time_t enablement patch.
-
-Signed-off-by: A. Wilcox <AWilcox@Wilcox-Tech.com>
-Fixes: 5dc1a7ebd ("Adjust for 64bit time_t for 32bit architectures")
-See-Also: libinput/libinput!346
----
- src/evdev-fallback.c | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/src/evdev-fallback.c b/src/evdev-fallback.c
-index 651f0111..99c87c87 100644
---- a/src/evdev-fallback.c
-+++ b/src/evdev-fallback.c
-@@ -29,6 +29,7 @@
- #include <mtdev-plumbing.h>
-
- #include "evdev-fallback.h"
-+#include "util-input-event.h"
-
- static void
- fallback_keyboard_notify_key(struct fallback_dispatch *dispatch,
-@@ -701,10 +702,10 @@ fallback_lid_keyboard_event(uint64_t time,
- if (dispatch->lid.reliability == RELIABILITY_WRITE_OPEN) {
- int fd = libevdev_get_fd(dispatch->device->evdev);
- int rc;
-- struct input_event ev[2] = {
-- {{ 0, 0 }, EV_SW, SW_LID, 0 },
-- {{ 0, 0 }, EV_SYN, SYN_REPORT, 0 },
-- };
-+ struct input_event ev[2];
-+
-+ ev[0] = input_event_init(0, EV_SW, SW_LID, 0);
-+ ev[1] = input_event_init(0, EV_SYN, SYN_REPORT, 0);
-
- rc = write(fd, ev, sizeof(ev));
-
---
-2.24.1
-