summaryrefslogtreecommitdiff
path: root/user/libixion
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-09-13 01:29:54 -0500
committerMax Rees <maxcrees@me.com>2020-02-04 19:36:04 -0600
commit021ad96efba4bdb2f124fcad5b8e95fedc63339a (patch)
tree6174e19713cda591da4787638524c9b63473cc7e /user/libixion
parentcaca406f828ee712d9f4f6a5591ae7f9d532a2b2 (diff)
downloadpackages-021ad96efba4bdb2f124fcad5b8e95fedc63339a.tar.gz
packages-021ad96efba4bdb2f124fcad5b8e95fedc63339a.tar.bz2
packages-021ad96efba4bdb2f124fcad5b8e95fedc63339a.tar.xz
packages-021ad96efba4bdb2f124fcad5b8e95fedc63339a.zip
user/libixion: bump to 0.15.0
Diffstat (limited to 'user/libixion')
-rw-r--r--user/libixion/APKBUILD12
-rw-r--r--user/libixion/nullptr.patch25
2 files changed, 32 insertions, 5 deletions
diff --git a/user/libixion/APKBUILD b/user/libixion/APKBUILD
index 174323bd3..69d394253 100644
--- a/user/libixion/APKBUILD
+++ b/user/libixion/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libixion
-pkgver=0.14.1
+pkgver=0.15.0
pkgrel=0
pkgdesc="A general purpose formula parser & interpreter"
url="https://gitlab.com/ixion/ixion"
arch="all"
license="MPL-2.0"
depends=""
-depends_dev="mdds~1.4"
-makedepends="$depends_dev boost-dev"
+depends_dev="mdds~1.5"
+makedepends="$depends_dev boost-dev spdlog"
subpackages="$pkgname-dev"
-source="http://kohei.us/files/ixion/src/$pkgname-$pkgver.tar.xz"
+source="http://kohei.us/files/ixion/src/$pkgname-$pkgver.tar.xz
+ nullptr.patch"
build() {
./configure \
@@ -39,4 +40,5 @@ dev() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="e4ae6348833d2178c1dc76916937bcc9d7821dc6570fe13093c441ca22e0301a1ca6a4cf85d9814b83534733dba98f4c4a372791f93bc57173317657675b9ae3 libixion-0.14.1.tar.xz"
+sha512sums="feecaa4a8e6191649a7ecbc6c0f4d7db6dba3a5e4a031c1f55236907bf94e2ece9ee05d18ed345e3503cffb4a380b04f6c4941ef4214ddf92687998a070b7543 libixion-0.15.0.tar.xz
+1c4c06c1f0d1ef4d34ec7d92a5238dc9ee11cc8cf09262208468d409579696b754d26efc06987c2d66ae47f896b5273fb28cdba08203286265c6ebf85000c3d9 nullptr.patch"
diff --git a/user/libixion/nullptr.patch b/user/libixion/nullptr.patch
new file mode 100644
index 000000000..27540bf30
--- /dev/null
+++ b/user/libixion/nullptr.patch
@@ -0,0 +1,25 @@
+From a8fe2c542b16ee30723ab3d7f3b643ee479e9723 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 23 Aug 2019 08:50:28 -0700
+Subject: [PATCH] Fix build with clang.
+
+---
+ include/ixion/model_context.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/ixion/model_context.hpp b/include/ixion/model_context.hpp
+index 6ff5b678..dc27ed03 100644
+--- a/include/ixion/model_context.hpp
++++ b/include/ixion/model_context.hpp
+@@ -61,7 +61,7 @@ public:
+ } value;
+
+ /** Initializes the cell to be empty. */
+- input_cell(nullptr_t);
++ input_cell(std::nullptr_t);
+ /** Boolean cell value. */
+ input_cell(bool b);
+ /** The char array must be null-terminated. */
+--
+2.22.0
+